Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » EclipsVirgo Nano and RAP
EclipsVirgo Nano and RAP [message #1255337] Mon, 24 February 2014 10:37 Go to next message
Karl Mehltretter is currently offline Karl MehltretterFriend
Messages: 2
Registered: February 2014
Junior Member
Hi all,

This is my first post here. I am developing an intranet application using Eclipse RAP . So far I am quite happy with RAP, keep up the good work!

Now I wanted to try out the new Virgo nano deployment http://www.eclipse.org/rap/noteworthy/2.3/?build=M1. Hower on startup I get the following error message:

[2014-02-24 11:23:40.292] fs-watcher <DE0012E> Failed to start bundle 'org.example.dummy' version '1.0.0.201402241045'. See the logs for more information. org.osgi.framework.BundleException: The bundle "org.example.dummy [79]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.7
Re: EclipsVirgo Nano and RAP [message #1256461 is a reply to message #1255337] Tue, 25 February 2014 13:04 Go to previous messageGo to next message
Florian Waibel is currently offline Florian WaibelFriend
Messages: 100
Registered: June 2010
Senior Member
Hi,

Quote:
Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.7


Which version of Java are you using? More details about execution environments can be found here.

Regards,
florian
Re: EclipsVirgo Nano and RAP [message #1257614 is a reply to message #1256461] Wed, 26 February 2014 16:25 Go to previous message
Karl Mehltretter is currently offline Karl MehltretterFriend
Messages: 2
Registered: February 2014
Junior Member
Hi Florian,

I tried both Oracle JRE7 and OpenJRE7...

I now found the issue: I had to edit the file
config/java6-server.profile
to include JavaSE-1.7.

Now the app (which uses some Java7 language features) deploys and runs great!
Another solution is to remove the "Bundle-RequiredExecutionEnvironment" line from the MANIFEST.MF.
So this is more of an Eclipse Virgo problem.

So the deployment with Eclipse Virgo Nano looks like a promising option.
We may still deploy our app as a WAR file on Tomcat, because Tomcat
- is included in most Linux distributions as a service
- has a nice web management interface for deploying WAR files etc


Regards,
Karl



[Updated on: Wed, 26 February 2014 16:25]

Report message to a moderator

Previous Topic:Menu access via keyboard not possible
Next Topic:Traverse listener not firing on Arrow-Keys
Goto Forum:
  


Current Time: Sun Nov 23 17:26:39 GMT 2014

Powered by FUDForum. Page generated in 0.10100 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software