Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Maven Integration (M2E) » [tycho] cannot run demo on 0.3.0-DEV-1819
[tycho] cannot run demo on 0.3.0-DEV-1819 [message #19845] Fri, 12 December 2008 23:19 Go to next message
Will Horn is currently offline Will Horn
Messages: 265
Registered: July 2009
Senior Member
When I run "mvn org.codehaus.tycho:maven-tycho-plugin:generate-poms" on
1819, I get this error:

[ERROR]
Cannot find mojo descriptor for:
'org.codehaus.tycho:maven-tycho-plugin:generate
-poms' - Treating as non-aggregator.

The same command works on 0.3.0-DEV-1719. Any tips?
Re: [tycho] cannot run demo on 0.3.0-DEV-1819 [message #19918 is a reply to message #19845] Sat, 13 December 2008 16:05 Go to previous messageGo to next message
Eclipse User
Originally posted by: igor.ifedorenko.com

Will,

I just tried tycho demo script [1] on linux using 0.3.0-DEV-1819 and
everything worked as expected. What platform you are on? What is exact
command you used to generate pom.xml files? Can you rerun the command
with error stack traces enabled (-e parameter) and post output here?

As a side note, tycho needs really basic pom.xml files, so it should not
be too difficult to write them by hand. And even for generated pom.xml
files, I recommend keeping them as part of project source tree. This way
you will be able to customize your build when needed.


[1] http://docs.codehaus.org/display/M2ECLIPSE/Tycho+technology+ demo+script

--
Regards,
Igor

Will Horn wrote:
> When I run "mvn org.codehaus.tycho:maven-tycho-plugin:generate-poms" on
> 1819, I get this error:
>
> [ERROR]
> Cannot find mojo descriptor for:
> 'org.codehaus.tycho:maven-tycho-plugin:generate
> -poms' - Treating as non-aggregator.
>
> The same command works on 0.3.0-DEV-1719. Any tips?
Re: [tycho] cannot run demo on 0.3.0-DEV-1819 [message #19942 is a reply to message #19918] Wed, 17 December 2008 00:49 Go to previous messageGo to next message
Will Horn is currently offline Will Horn
Messages: 265
Registered: July 2009
Senior Member
Thanks for investigating. I tried again (in the same shell, in fact!)
and it worked fine. So this must have been an issue with my
connectivity or a temporary blip in the repo.

This was on Windows Vista, by the way (full command and output from
before is below).

After generating the poms, I was able to successfully build a
feature-based version of the tycho demo (something I couldn't do in
1719). It is truly quite amazing to see this happening in maven and I am
really looking forward to maven 3.0. I am willing to document the
feature-based steps if that would be helpful to others.

-Will

c:\workspaces\tycho-demo>c:\tycho-distribution-0.3.0-DEV-1819\bin\mvn
org.codehaus.tycho:maven-tycho-plugin:generate-poms -DgroupId=tycho.demo
-Dtycho.targetPlatform=c:\eclipse\eclipse-3.4.1-rcp
[INFO] Build target platform
tycho.targetPlatform=c:\eclipse\eclipse-3.4.1-rcp. This overrides target
platform specified in pom.xml files, if any.
[ERROR]
Cannot find mojo descriptor for:
'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
non-aggregator.

[INFO]
------------------------------------------------------------ ------------
[INFO] For more information, run with the -e flag
[INFO]
------------------------------------------------------------ ------------
[INFO] BUILD FAILED
[INFO]
------------------------------------------------------------ ------------
[INFO] Total time: < 1 second
[INFO] Finished at: Fri Dec 12 15:16:38 PST 2008
[INFO] Final Memory: 3M/7M
[INFO]
------------------------------------------------------------ ------------

Igor Fedorenko wrote:
> Will,
>
> I just tried tycho demo script [1] on linux using 0.3.0-DEV-1819 and
> everything worked as expected. What platform you are on? What is exact
> command you used to generate pom.xml files? Can you rerun the command
> with error stack traces enabled (-e parameter) and post output here?
>
> As a side note, tycho needs really basic pom.xml files, so it should not
> be too difficult to write them by hand. And even for generated pom.xml
> files, I recommend keeping them as part of project source tree. This way
> you will be able to customize your build when needed.
>
>
> [1] http://docs.codehaus.org/display/M2ECLIPSE/Tycho+technology+ demo+script
>
> --
> Regards,
> Igor
>
> Will Horn wrote:
>> When I run "mvn org.codehaus.tycho:maven-tycho-plugin:generate-poms"
>> on 1819, I get this error:
>>
>> [ERROR]
>> Cannot find mojo descriptor for:
>> 'org.codehaus.tycho:maven-tycho-plugin:generate
>> -poms' - Treating as non-aggregator.
>>
>> The same command works on 0.3.0-DEV-1719. Any tips?
Re: [tycho] cannot run demo on 0.3.0-DEV-1819 [message #25197 is a reply to message #19942] Thu, 30 April 2009 11:57 Go to previous messageGo to next message
petr is currently offline petr
Messages: 6
Registered: July 2009
Junior Member
Hi Will and Igor,

I am facing similar problem in Linux. I tried to clean ~/.m2/repository
to verify that my proxy allows to upload necessary plug-ins. To me it
seems that I cannot upload only maven-tycho-plugin.

Could you help?

-Petr


here is my command/output:


mvn -e org.codehaus.tycho:maven-tycho-plugin:generate-poms
-DgroupId=tycho.demo -Dtycho.targetPlatform=/home/petr/ganymede/eclipse/

+ Error stacktraces are turned on.
[INFO] Attempting to resolve a version for plugin:
org.codehaus.tycho:maven-tycho-plugin using meta-version: LATEST
[INFO] Using version: LATEST of plugin:
org.codehaus.tycho:maven-tycho-plugin
[ERROR]
Cannot find mojo descriptor for:
'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
non-aggregator.

Error stacktrace:
org.apache.maven.InvalidTaskException: Cannot find mojo descriptor for:
'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
non-aggregator.
at
org.apache.maven.lifecycle.TaskValidationResult.generateInva lidTaskException(TaskValidationResult.java:78)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:182)
at org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedde r.java:846)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:160)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:63)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:57)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnha nced(Launcher.java:289)
at
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Lau ncher.java:229)
at
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithEx itCode(Launcher.java:408)
at
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launc her.java:351)
Caused by: org.apache.maven.plugin.loader.PluginLoaderException: Failed
to load plugin. Reason: Plugin could not be found - check that the goal
name is correct: Unable to determine the latest version

Try downloading the file manually from the project website.

Then, install it using the command:
mvn install:install-file -DgroupId=org.codehaus.tycho
-DartifactId=maven-tycho-plugin -Dversion=LATEST
-Dpackaging=maven-plugin -Dfile=/path/to/file

Alternatively, if you host your own repository you can deploy the file
there:
mvn deploy:deploy-file -DgroupId=org.codehaus.tycho
-DartifactId=maven-tycho-plugin -Dversion=LATEST
-Dpackaging=maven-plugin -Dfile=/path/to/file -Durl=[url]
-DrepositoryId=[id]


org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST


org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST


at
org.apache.maven.plugin.loader.DefaultPluginLoader.loadPlugi n(DefaultPluginLoader.java:99)
at
org.apache.maven.plugin.loader.DefaultPluginLoader.loadPlugi n(DefaultPluginLoader.java:54)
at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoD escriptorForDirectInvocation(DefaultLifecycleExecutor.java:8 50)
at
org.apache.maven.lifecycle.DefaultLifecycleExecutor.isTaskVa lid(DefaultLifecycleExecutor.java:672)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:178)
... 11 more
Caused by: org.apache.maven.plugin.PluginNotFoundException: Plugin could
not be found - check that the goal name is correct: Unable to determine
the latest version

Try downloading the file manually from the project website.

Then, install it using the command:
mvn install:install-file -DgroupId=org.codehaus.tycho
-DartifactId=maven-tycho-plugin -Dversion=LATEST
-Dpackaging=maven-plugin -Dfile=/path/to/file

Alternatively, if you host your own repository you can deploy the file
there:
mvn deploy:deploy-file -DgroupId=org.codehaus.tycho
-DartifactId=maven-tycho-plugin -Dversion=LATEST
-Dpackaging=maven-plugin -Dfile=/path/to/file -Durl=[url]
-DrepositoryId=[id]


org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST


org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST


at
org.apache.maven.plugin.DefaultPluginManager.verifyVersioned Plugin(DefaultPluginManager.java:250)
at
org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(De faultPluginManager.java:199)
at
org.apache.maven.plugin.loader.DefaultPluginLoader.loadPlugi n(DefaultPluginLoader.java:81)
... 15 more

[INFO]
------------------------------------------------------------ ------------
[INFO] BUILD FAILED
[INFO]



Will Horn wrote:
> Thanks for investigating. I tried again (in the same shell, in fact!)
> and it worked fine. So this must have been an issue with my
> connectivity or a temporary blip in the repo.
>
> This was on Windows Vista, by the way (full command and output from
> before is below).
>
> After generating the poms, I was able to successfully build a
> feature-based version of the tycho demo (something I couldn't do in
> 1719). It is truly quite amazing to see this happening in maven and I am
> really looking forward to maven 3.0. I am willing to document the
> feature-based steps if that would be helpful to others.
>
> -Will
>
> c:\workspaces\tycho-demo>c:\tycho-distribution-0.3.0-DEV-1819\bin\mvn
> org.codehaus.tycho:maven-tycho-plugin:generate-poms -DgroupId=tycho.demo
> -Dtycho.targetPlatform=c:\eclipse\eclipse-3.4.1-rcp
> [INFO] Build target platform
> tycho.targetPlatform=c:\eclipse\eclipse-3.4.1-rcp. This overrides target
> platform specified in pom.xml files, if any.
> [ERROR]
> Cannot find mojo descriptor for:
> 'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
> non-aggregator.
>
> [INFO]
> ------------------------------------------------------------ ------------
> [INFO] For more information, run with the -e flag
> [INFO]
> ------------------------------------------------------------ ------------
> [INFO] BUILD FAILED
> [INFO]
> ------------------------------------------------------------ ------------
> [INFO] Total time: < 1 second
> [INFO] Finished at: Fri Dec 12 15:16:38 PST 2008
> [INFO] Final Memory: 3M/7M
> [INFO]
> ------------------------------------------------------------ ------------
>
> Igor Fedorenko wrote:
>> Will,
>>
>> I just tried tycho demo script [1] on linux using 0.3.0-DEV-1819 and
>> everything worked as expected. What platform you are on? What is exact
>> command you used to generate pom.xml files? Can you rerun the command
>> with error stack traces enabled (-e parameter) and post output here?
>>
>> As a side note, tycho needs really basic pom.xml files, so it should
>> not be too difficult to write them by hand. And even for generated
>> pom.xml files, I recommend keeping them as part of project source
>> tree. This way you will be able to customize your build when needed.
>>
>>
>> [1]
>> http://docs.codehaus.org/display/M2ECLIPSE/Tycho+technology+ demo+script
>>
>> --
>> Regards,
>> Igor
>>
>> Will Horn wrote:
>>> When I run "mvn org.codehaus.tycho:maven-tycho-plugin:generate-poms"
>>> on 1819, I get this error:
>>>
>>> [ERROR]
>>> Cannot find mojo descriptor for:
>>> 'org.codehaus.tycho:maven-tycho-plugin:generate
>>> -poms' - Treating as non-aggregator.
>>>
>>> The same command works on 0.3.0-DEV-1719. Any tips?
Re: [tycho] cannot run demo on 0.3.0-DEV-1819 [message #25238 is a reply to message #25197] Thu, 30 April 2009 14:06 Go to previous messageGo to next message
Eclipse User
Originally posted by: igor.ifedorenko.com

Petr,

Can you confirm that you are using Tycho installation to run
generate-poms? Also, check M2_HOME environment variable. If set, it must
point to Tycho installation.

Also, we have a mailing list dedicated to Tycho. You can subscribe by
sending email to tycho-users-subscribe@lists.sonatype.com.

--
Regards,
Igor

Petr Baranov wrote:
> Hi Will and Igor,
>
> I am facing similar problem in Linux. I tried to clean ~/.m2/repository
> to verify that my proxy allows to upload necessary plug-ins. To me it
> seems that I cannot upload only maven-tycho-plugin.
>
> Could you help?
>
> -Petr
>
>
> here is my command/output:
>
>
> mvn -e org.codehaus.tycho:maven-tycho-plugin:generate-poms
> -DgroupId=tycho.demo -Dtycho.targetPlatform=/home/petr/ganymede/eclipse/
>
> + Error stacktraces are turned on.
> [INFO] Attempting to resolve a version for plugin:
> org.codehaus.tycho:maven-tycho-plugin using meta-version: LATEST
> [INFO] Using version: LATEST of plugin:
> org.codehaus.tycho:maven-tycho-plugin
> [ERROR]
> Cannot find mojo descriptor for:
> 'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
> non-aggregator.
>
> Error stacktrace:
> org.apache.maven.InvalidTaskException: Cannot find mojo descriptor for:
> 'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
> non-aggregator.
> at
> org.apache.maven.lifecycle.TaskValidationResult.generateInva lidTaskException(TaskValidationResult.java:78)
>
> at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:182)
> at
> org.apache.maven.embedder.MavenEmbedder.execute(MavenEmbedde r.java:846)
> at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:160)
> at org.apache.maven.cli.MavenCli.main(MavenCli.java:63)
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcce ssorImpl.java:57)
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMe thodAccessorImpl.java:43)
>
> at java.lang.reflect.Method.invoke(Method.java:616)
> at
> org.codehaus.plexus.classworlds.launcher.Launcher.launchEnha nced(Launcher.java:289)
>
> at
> org.codehaus.plexus.classworlds.launcher.Launcher.launch(Lau ncher.java:229)
> at
> org.codehaus.plexus.classworlds.launcher.Launcher.mainWithEx itCode(Launcher.java:408)
>
> at
> org.codehaus.plexus.classworlds.launcher.Launcher.main(Launc her.java:351)
> Caused by: org.apache.maven.plugin.loader.PluginLoaderException: Failed
> to load plugin. Reason: Plugin could not be found - check that the goal
> name is correct: Unable to determine the latest version
>
> Try downloading the file manually from the project website.
>
> Then, install it using the command:
> mvn install:install-file -DgroupId=org.codehaus.tycho
> -DartifactId=maven-tycho-plugin -Dversion=LATEST
> -Dpackaging=maven-plugin -Dfile=/path/to/file
>
> Alternatively, if you host your own repository you can deploy the file
> there:
> mvn deploy:deploy-file -DgroupId=org.codehaus.tycho
> -DartifactId=maven-tycho-plugin -Dversion=LATEST
> -Dpackaging=maven-plugin -Dfile=/path/to/file -Durl=[url]
> -DrepositoryId=[id]
>
>
> org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST
>
>
> org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST
>
>
> at
> org.apache.maven.plugin.loader.DefaultPluginLoader.loadPlugi n(DefaultPluginLoader.java:99)
>
> at
> org.apache.maven.plugin.loader.DefaultPluginLoader.loadPlugi n(DefaultPluginLoader.java:54)
>
> at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.getMojoD escriptorForDirectInvocation(DefaultLifecycleExecutor.java:8 50)
>
> at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.isTaskVa lid(DefaultLifecycleExecutor.java:672)
>
> at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:178)
> ... 11 more
> Caused by: org.apache.maven.plugin.PluginNotFoundException: Plugin could
> not be found - check that the goal name is correct: Unable to determine
> the latest version
>
> Try downloading the file manually from the project website.
>
> Then, install it using the command:
> mvn install:install-file -DgroupId=org.codehaus.tycho
> -DartifactId=maven-tycho-plugin -Dversion=LATEST
> -Dpackaging=maven-plugin -Dfile=/path/to/file
>
> Alternatively, if you host your own repository you can deploy the file
> there:
> mvn deploy:deploy-file -DgroupId=org.codehaus.tycho
> -DartifactId=maven-tycho-plugin -Dversion=LATEST
> -Dpackaging=maven-plugin -Dfile=/path/to/file -Durl=[url]
> -DrepositoryId=[id]
>
>
> org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST
>
>
> org.codehaus.tycho:maven-tycho-plugin:maven-plugin:LATEST
>
>
> at
> org.apache.maven.plugin.DefaultPluginManager.verifyVersioned Plugin(DefaultPluginManager.java:250)
>
> at
> org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(De faultPluginManager.java:199)
>
> at
> org.apache.maven.plugin.loader.DefaultPluginLoader.loadPlugi n(DefaultPluginLoader.java:81)
>
> ... 15 more
>
> [INFO]
> ------------------------------------------------------------ ------------
> [INFO] BUILD FAILED
> [INFO]
>
>
>
> Will Horn wrote:
>> Thanks for investigating. I tried again (in the same shell, in fact!)
>> and it worked fine. So this must have been an issue with my
>> connectivity or a temporary blip in the repo.
>>
>> This was on Windows Vista, by the way (full command and output from
>> before is below).
>>
>> After generating the poms, I was able to successfully build a
>> feature-based version of the tycho demo (something I couldn't do in
>> 1719). It is truly quite amazing to see this happening in maven and I
>> am really looking forward to maven 3.0. I am willing to document the
>> feature-based steps if that would be helpful to others.
>>
>> -Will
>>
>> c:\workspaces\tycho-demo>c:\tycho-distribution-0.3.0-DEV-1819\bin\mvn
>> org.codehaus.tycho:maven-tycho-plugin:generate-poms
>> -DgroupId=tycho.demo -Dtycho.targetPlatform=c:\eclipse\eclipse-3.4.1-rcp
>> [INFO] Build target platform
>> tycho.targetPlatform=c:\eclipse\eclipse-3.4.1-rcp. This overrides
>> target platform specified in pom.xml files, if any.
>> [ERROR]
>> Cannot find mojo descriptor for:
>> 'org.codehaus.tycho:maven-tycho-plugin:generate-poms' - Treating as
>> non-aggregator.
>>
>> [INFO]
>> ------------------------------------------------------------ ------------
>> [INFO] For more information, run with the -e flag
>> [INFO]
>> ------------------------------------------------------------ ------------
>> [INFO] BUILD FAILED
>> [INFO]
>> ------------------------------------------------------------ ------------
>> [INFO] Total time: < 1 second
>> [INFO] Finished at: Fri Dec 12 15:16:38 PST 2008
>> [INFO] Final Memory: 3M/7M
>> [INFO]
>> ------------------------------------------------------------ ------------
>>
>> Igor Fedorenko wrote:
>>> Will,
>>>
>>> I just tried tycho demo script [1] on linux using 0.3.0-DEV-1819 and
>>> everything worked as expected. What platform you are on? What is
>>> exact command you used to generate pom.xml files? Can you rerun the
>>> command with error stack traces enabled (-e parameter) and post
>>> output here?
>>>
>>> As a side note, tycho needs really basic pom.xml files, so it should
>>> not be too difficult to write them by hand. And even for generated
>>> pom.xml files, I recommend keeping them as part of project source
>>> tree. This way you will be able to customize your build when needed.
>>>
>>>
>>> [1]
>>> http://docs.codehaus.org/display/M2ECLIPSE/Tycho+technology+ demo+script
>>>
>>> --
>>> Regards,
>>> Igor
>>>
>>> Will Horn wrote:
>>>> When I run "mvn org.codehaus.tycho:maven-tycho-plugin:generate-poms"
>>>> on 1819, I get this error:
>>>>
>>>> [ERROR]
>>>> Cannot find mojo descriptor for:
>>>> 'org.codehaus.tycho:maven-tycho-plugin:generate
>>>> -poms' - Treating as non-aggregator.
>>>>
>>>> The same command works on 0.3.0-DEV-1719. Any tips?
Re: [tycho] cannot run demo on 0.3.0-DEV-1819 [message #25319 is a reply to message #25238] Thu, 07 May 2009 13:43 Go to previous messageGo to next message
Joerg Buchberger is currently offline Joerg Buchberger
Messages: 25
Registered: July 2009
Junior Member
Hi all,

trying to use 0.3.0-DEV-1819 back in February and now 0.4.0-DEV-2233
respectively, I had the very same problem. I still do not know the reason
why, but I suppose it has to do with our company firewall.

Once I installed Nexus (v1.3.3-gpl) and configured the tycho settings as
described in the nexus docs... BUILD SUCCESSFUL.

Note, that I have a 2.0.9 installation on the same machine, which never
had any problems getting dependencies from public repos.

Regards.
Joerg
Re: [tycho] cannot run demo on 0.3.0-DEV-1819 [message #25482 is a reply to message #25319] Thu, 07 May 2009 23:44 Go to previous message
Eclipse User
Originally posted by: igor.ifedorenko.com

This probably does not help much, but I believe there were issues with
mirror and proxy support in Maven 3.0-alpha-1 used in Tycho.

FYI, Maven codebase is changing very quickly right now, so we decided to
wait until things settle down a bit before updating Tycho.

--
Regards,
Igor

Joerg Buchberger wrote:
> Hi all,
>
> trying to use 0.3.0-DEV-1819 back in February and now 0.4.0-DEV-2233
> respectively, I had the very same problem. I still do not know the
> reason why, but I suppose it has to do with our company firewall.
>
> Once I installed Nexus (v1.3.3-gpl) and configured the tycho settings as
> described in the nexus docs... BUILD SUCCESSFUL.
>
> Note, that I have a 2.0.9 installation on the same machine, which never
> had any problems getting dependencies from public repos.
>
> Regards.
> Joerg
>
>
Previous Topic:M2Eclipse and Eclipse 3.4.2?
Next Topic:[tycho] best way of using multiple maven versions in parallel
Goto Forum:
  


Current Time: Thu Sep 18 21:50:56 GMT 2014

Powered by FUDForum. Page generated in 0.02137 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software