Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Eclipse & Axis2 Problem
Eclipse & Axis2 Problem [message #205045] Tue, 27 November 2007 20:50 Go to next message
Eclipse User
Originally posted by: brfullwood.hotmail.com

I'm new to Eclipse and Axis 2. I'm using the following tutorial to set up
my first Axis Web Service:

http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html

When I try to run the example (start the server), I get the following
exception (I haven't included the entire stack trace):

[ERROR] The mex-1.3.mar module, which is not valid, caused
org.apache.axis2.mex.MetadataExchangeModule
org.apache.axis2.deployment.DeploymentException:
org.apache.axis2.mex.MetadataExchangeModule

MORE TRACE LINES

Caused by: org.apache.axis2.deployment.DeploymentException:
org.apache.axis2.mex.MetadataExchangeModule

MORE TRACE LINES

Caused by: java.lang.ClassNotFoundException:
org.apache.axis2.mex.MetadataExchangeModule

And then the service, obviously, isn't available/doesn't work.

Here's my environment:

Eclipse Version: 3.3.1.1 Build id: M20071023-1652 (the Europa build)
JDK Version: 1.6.0_03
Axis 2 Version: 1.3
Tomcat Verstion: 6.0.14

Your help is very much appreciated. I'd really love to get away from ASMX
Web Services.
Re: Eclipse & Axis2 Problem [message #205080 is a reply to message #205045] Wed, 28 November 2007 21:17 Go to previous messageGo to next message
Eclipse User
Originally posted by: khvatov.yahoo.com

I had this problem when used newest release of WTP 2.01.
The problem went away after downgrading to WTP 2.0.
Hope it helps.
Alex


"Bruce Fullwood" <brfullwood@hotmail.com> wrote in message
news:c8a6eba60790ff8c1e14b13758a4bf95$1@www.eclipse.org...
> I'm new to Eclipse and Axis 2. I'm using the following tutorial to set up
> my first Axis Web Service:
>
> http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html
>
> When I try to run the example (start the server), I get the following
> exception (I haven't included the entire stack trace):
>
> [ERROR] The mex-1.3.mar module, which is not valid, caused
> org.apache.axis2.mex.MetadataExchangeModule
> org.apache.axis2.deployment.DeploymentException:
> org.apache.axis2.mex.MetadataExchangeModule
>
> MORE TRACE LINES
>
> Caused by: org.apache.axis2.deployment.DeploymentException:
> org.apache.axis2.mex.MetadataExchangeModule
>
> MORE TRACE LINES
>
> Caused by: java.lang.ClassNotFoundException:
> org.apache.axis2.mex.MetadataExchangeModule
>
> And then the service, obviously, isn't available/doesn't work.
>
> Here's my environment:
>
> Eclipse Version: 3.3.1.1 Build id: M20071023-1652 (the Europa build)
> JDK Version: 1.6.0_03
> Axis 2 Version: 1.3
> Tomcat Verstion: 6.0.14
>
> Your help is very much appreciated. I'd really love to get away from ASMX
> Web Services.
>
>
Re: Eclipse & Axis2 Problem [message #205235 is a reply to message #205045] Fri, 30 November 2007 23:58 Go to previous message
Kathy Chan is currently offline Kathy Chan
Messages: 93
Registered: July 2009
Member
Hi Bruce,

I'm able to reproduce the problem on WTP 2.0.1 using Axis2 v1.3. However,
even though I got that stack trace in the server console, the Web service
worked properly. If you use Axis2 v1.2 with WTP 2.0.1, you would not get
that problem in the server console.

Please note that this problem has been fixed in WTP bugzilla defect 206967
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=206967). It's available in
WTP 2.0.2 driver or WTP 3.0 after 11/01.

Regards,
Kathy Chan

"Bruce Fullwood" <brfullwood@hotmail.com> wrote in message
news:c8a6eba60790ff8c1e14b13758a4bf95$1@www.eclipse.org...
> I'm new to Eclipse and Axis 2. I'm using the following tutorial to set up
> my first Axis Web Service:
>
> http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html
>
> When I try to run the example (start the server), I get the following
> exception (I haven't included the entire stack trace):
>
> [ERROR] The mex-1.3.mar module, which is not valid, caused
> org.apache.axis2.mex.MetadataExchangeModule
> org.apache.axis2.deployment.DeploymentException:
> org.apache.axis2.mex.MetadataExchangeModule
>
> MORE TRACE LINES
>
> Caused by: org.apache.axis2.deployment.DeploymentException:
> org.apache.axis2.mex.MetadataExchangeModule
>
> MORE TRACE LINES
>
> Caused by: java.lang.ClassNotFoundException:
> org.apache.axis2.mex.MetadataExchangeModule
>
> And then the service, obviously, isn't available/doesn't work.
>
> Here's my environment:
>
> Eclipse Version: 3.3.1.1 Build id: M20071023-1652 (the Europa build)
> JDK Version: 1.6.0_03
> Axis 2 Version: 1.3
> Tomcat Verstion: 6.0.14
>
> Your help is very much appreciated. I'd really love to get away from ASMX
> Web Services.
>
>
Previous Topic:Tomcat/shared/lib and WTP
Next Topic:JAX-WS support
Goto Forum:
  


Current Time: Mon Oct 20 13:20:21 GMT 2014

Powered by FUDForum. Page generated in 0.15884 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software