Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Error when deploying Axis2 webapp.
Error when deploying Axis2 webapp. [message #204782] Wed, 21 November 2007 06:50 Go to next message
Eclipse User
Originally posted by: Sanjay.Vivek.newcastle.ac.uk

Hi everyone,

I'm attempting to deploy a simple Axis 2 webapp but I keep getting the
errors shown below. It appears that Tomcat can't find the mex-1.3.mar
module. How do I go about fixing this? I'm using Eclipse 3.3.1 and Tomcat
6.0.14. Any help would be greatly appreciated.

Cheers
Sanjay
21-Nov-2007 11:27:29 org.apache.catalina.core.AprLifecycleListener init
INFO: The Apache Tomcat Native library which allows optimal performance in
production environments was not found on the java.library.path: C:\Program
Files\Java\jre1.6.0_03\bin;.;C:\WINDOWS\Sun\Java\bin;C:\WIND OWS\system32;C:\WINDOWS;C:\Program
Files\Java\jre1.6.0_03\bin\client;C:\Program
Files\Java\jre1.6.0_03\bin;C:\Program Files\Real\RealProducer Basic
11;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C :\Program
Files\QuickTime\QTSystem\;C:\Program Files\Java\jdk1.6.0_03\bin
21-Nov-2007 11:27:29 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
21-Nov-2007 11:27:29 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 410 ms
21-Nov-2007 11:27:29 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
21-Nov-2007 11:27:29 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.14
[INFO] Deploying module: addressing-1.3
[ERROR] The mex-1.3.mar module, which is not valid, caused
org.apache.axis2.mex.MetadataExchangeModule
org.apache.axis2.deployment.DeploymentException:
org.apache.axis2.mex.MetadataExchangeModule
at
org.apache.axis2.deployment.repository.util.ArchiveReader.re adModuleArchive(ArchiveReader.java:493)
at
org.apache.axis2.deployment.ModuleDeployer.deploy(ModuleDepl oyer.java:69)
at
org.apache.axis2.deployment.repository.util.DeploymentFileDa ta.deploy(DeploymentFileData.java:137)
at
org.apache.axis2.deployment.DeploymentEngine.doDeploy(Deploy mentEngine.java:571)
at
org.apache.axis2.deployment.RepositoryListener.init(Reposito ryListener.java:231)
at
org.apache.axis2.deployment.RepositoryListener.init2(Reposit oryListener.java:64)
at
org.apache.axis2.deployment.RepositoryListener.<init>(RepositoryListener.java:59)
at
org.apache.axis2.deployment.DeploymentEngine.loadRepository( DeploymentEngine.java:134)
at
org.apache.axis2.deployment.WarBasedAxisConfigurator.getAxis Configuration(WarBasedAxisConfigurator.java:218)
at
org.apache.axis2.context.ConfigurationContextFactory.createC onfigurationContext(ConfigurationContextFactory.java:64)
at
org.apache.axis2.transport.http.AxisServlet.initConfigContex t(AxisServlet.java:500)
at org.apache.axis2.transport.http.AxisServlet.init(AxisServlet .java:420)
at
org.apache.axis2.transport.http.AxisAdminServlet.init(AxisAd minServlet.java:54)
at
org.apache.catalina.core.StandardWrapper.loadServlet(Standar dWrapper.java:1161)
at org.apache.catalina.core.StandardWrapper.load(StandardWrappe r.java:981)
at
org.apache.catalina.core.StandardContext.loadOnStartup(Stand ardContext.java:4045)
at
org.apache.catalina.core.StandardContext.start(StandardConte xt.java:4351)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.j ava:1045)
at org.apache.catalina.core.StandardHost.start(StandardHost.jav a:719)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.j ava:1045)
at org.apache.catalina.core.StandardEngine.start(StandardEngine .java:443)
at
org.apache.catalina.core.StandardService.start(StandardServi ce.java:516)
at org.apache.catalina.core.StandardServer.start(StandardServer .java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:566 )
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:2 88)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:41 3)
Caused by: org.apache.axis2.deployment.DeploymentException:
org.apache.axis2.mex.MetadataExchangeModule
at
org.apache.axis2.deployment.ModuleBuilder.loadModuleClass(Mo duleBuilder.java:82)
at
org.apache.axis2.deployment.ModuleBuilder.populateModule(Mod uleBuilder.java:96)
at
org.apache.axis2.deployment.repository.util.ArchiveReader.re adModuleArchive(ArchiveReader.java:480)
... 29 more
Caused by: java.lang.ClassNotFoundException:
org.apache.axis2.mex.MetadataExchangeModule
at
org.apache.catalina.loader.WebappClassLoader.loadClass(Webap pClassLoader.java:1358)
at
org.apache.catalina.loader.WebappClassLoader.loadClass(Webap pClassLoader.java:1204)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.apache.axis2.util.Loader.loadClass(Loader.java:261)
at org.apache.axis2.util.Loader.loadClass(Loader.java:229)
at
org.apache.axis2.deployment.ModuleBuilder.loadModuleClass(Mo duleBuilder.java:66)
... 31 more
[INFO] Deploying module: ping-1.3
[INFO] Deploying module: script-1.3
[INFO] Deploying module: soapmonitor-1.3
[INFO] script module activated
[INFO] Deploying Web service: Converter
[INFO] Deploying Web service: version.aar
21-Nov-2007 11:27:30 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
21-Nov-2007 11:27:30 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
21-Nov-2007 11:27:30 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/31 config=null
21-Nov-2007 11:27:30 org.apache.catalina.startup.Catalina start
INFO: Server startup in 1166 ms
Re: Error when deploying Axis2 webapp. [message #821538 is a reply to message #204782] Thu, 15 March 2012 09:51 Go to previous message
Pradeep Bommisetty is currently offline Pradeep Bommisetty
Messages: 4
Registered: March 2012
Junior Member
Add all the axis related jars manually to the WEB-INF\lib in case the eclipse wizard does not update it when you try to create a webservice. It worked for me.
Previous Topic:[resolved]
Next Topic:Generating axis2 web service client in project
Goto Forum:
  


Current Time: Wed Aug 20 18:42:30 EDT 2014

Powered by FUDForum. Page generated in 0.01599 seconds