Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Performance Monitor Agent crash on WinXP
Performance Monitor Agent crash on WinXP [message #19635] Wed, 08 June 2005 11:39 Go to next message
Eclipse User
Originally posted by: stefano.scheda.formula.it

I'm trying to test TPTP, by following the EclipseCon 2005 Tutorial, on a
WinXPSP2 machine with Eclipse 3.0.2 and JRE 1.4.2.
When I try to start a new profile (page 46 of the tutorial) Eclipse takes
some time "launching..." (rebuilding the workspace projects?) then when it
moves to launch the agent I get a Windows GPF ("Performance Monitor Agent
has encountered a problem...").

The system event log contains this application error:
Faulting application perfmonagent.exe, version 3.1.0.0, faulting module
rac.dll, version 3.1.0.0, fault address 0x00001d79.

and the agent controller service.log, modified to loggingLevel="DEBUG",
lists these as the last entries (simplified):
msg="Forwarding command to agent: tag=25 agent=PerfmonAgent - #1118244647735
pid=4592" severity="5"
msg="Sent 112 bytes to agent 5e1422e8-2eb9-4b16-9849-72d6d2ac0279"
severity="5"
msg="Validated message of 104 bytes" severity="5"
msg="Processing message of length 104 bytes." severity="5"
msg="Processing command: tag=25" severity="5"
msg="Forwarding command to agent: tag=25 agent=PerfmonAgent - #1118244647735
pid=4592" severity="5"
msg="Sent 104 bytes to agent 5e1422e8-2eb9-4b16-9849-72d6d2ac0279"
severity="5"

any help appreciated

TIA
--
Stefano Scheda
Re: Performance Monitor Agent crash on WinXP [message #19725 is a reply to message #19635] Thu, 09 June 2005 13:58 Go to previous messageGo to next message
Eclipse User
Originally posted by: lars.nospam.nix_ohlenDOT.se

Hi,

I never got the Performance Monitor to work until I upgraded to 3.2A of
TPTP.

You should also note that there is a bug that can prevent the Performornace
Monitor chart generator from rendering values.
If this happens you should try to change your national settings and change
the decimal separator character to a period (e.g a dot).

/L








"Stefano Scheda" <stefano.scheda@formula.it> skrev i meddelandet
news:d873fs$c81$1@news.eclipse.org...
> I'm trying to test TPTP, by following the EclipseCon 2005 Tutorial, on a
> WinXPSP2 machine with Eclipse 3.0.2 and JRE 1.4.2.
> When I try to start a new profile (page 46 of the tutorial) Eclipse takes
> some time "launching..." (rebuilding the workspace projects?) then when it
> moves to launch the agent I get a Windows GPF ("Performance Monitor Agent
> has encountered a problem...").
>
> The system event log contains this application error:
> Faulting application perfmonagent.exe, version 3.1.0.0, faulting module
> rac.dll, version 3.1.0.0, fault address 0x00001d79.
>
> and the agent controller service.log, modified to loggingLevel="DEBUG",
> lists these as the last entries (simplified):
> msg="Forwarding command to agent: tag=25 agent=PerfmonAgent -
> #1118244647735 pid=4592" severity="5"
> msg="Sent 112 bytes to agent 5e1422e8-2eb9-4b16-9849-72d6d2ac0279"
> severity="5"
> msg="Validated message of 104 bytes" severity="5"
> msg="Processing message of length 104 bytes." severity="5"
> msg="Processing command: tag=25" severity="5"
> msg="Forwarding command to agent: tag=25 agent=PerfmonAgent -
> #1118244647735 pid=4592" severity="5"
> msg="Sent 104 bytes to agent 5e1422e8-2eb9-4b16-9849-72d6d2ac0279"
> severity="5"
>
> any help appreciated
>
> TIA
> --
> Stefano Scheda
>
Re: Performance Monitor Agent crash on WinXP [message #19974 is a reply to message #19725] Tue, 14 June 2005 04:54 Go to previous messageGo to next message
George Christelis is currently offline George Christelis
Messages: 15
Registered: July 2009
Junior Member
Hi Stefano,

There was a known issue in the agent building up to 3.2A. The locale bug
is a known issue and has been fixed in Hyades 3.3, but not in 3.2A.
Unless there is a particular reason why you require Hyades TPTP 3.1 then
I think your problems might be fixed just by upgrading to a more recent
Hyades version.

Let me know how you get on, or if this is not an option.
George

Lars Ohlén wrote:
> Hi,
>
> I never got the Performance Monitor to work until I upgraded to 3.2A of
> TPTP.
>
> You should also note that there is a bug that can prevent the Performornace
> Monitor chart generator from rendering values.
> If this happens you should try to change your national settings and change
> the decimal separator character to a period (e.g a dot).
>
> /L
>
>
>
>
>
>
>
>
> "Stefano Scheda" <stefano.scheda@formula.it> skrev i meddelandet
> news:d873fs$c81$1@news.eclipse.org...
>
>>I'm trying to test TPTP, by following the EclipseCon 2005 Tutorial, on a
>>WinXPSP2 machine with Eclipse 3.0.2 and JRE 1.4.2.
>>When I try to start a new profile (page 46 of the tutorial) Eclipse takes
>>some time "launching..." (rebuilding the workspace projects?) then when it
>>moves to launch the agent I get a Windows GPF ("Performance Monitor Agent
>>has encountered a problem...").
>>
>>The system event log contains this application error:
>>Faulting application perfmonagent.exe, version 3.1.0.0, faulting module
>>rac.dll, version 3.1.0.0, fault address 0x00001d79.
>>
>>and the agent controller service.log, modified to loggingLevel="DEBUG",
>>lists these as the last entries (simplified):
>>msg="Forwarding command to agent: tag=25 agent=PerfmonAgent -
>>#1118244647735 pid=4592" severity="5"
>>msg="Sent 112 bytes to agent 5e1422e8-2eb9-4b16-9849-72d6d2ac0279"
>>severity="5"
>>msg="Validated message of 104 bytes" severity="5"
>>msg="Processing message of length 104 bytes." severity="5"
>>msg="Processing command: tag=25" severity="5"
>>msg="Forwarding command to agent: tag=25 agent=PerfmonAgent -
>>#1118244647735 pid=4592" severity="5"
>>msg="Sent 104 bytes to agent 5e1422e8-2eb9-4b16-9849-72d6d2ac0279"
>>severity="5"
>>
>>any help appreciated
>>
>>TIA
>>--
>>Stefano Scheda
>>
>
>
>
Re: Performance Monitor Agent crash on WinXP [message #20006 is a reply to message #19974] Tue, 14 June 2005 08:06 Go to previous message
Eclipse User
Originally posted by: stefano.scheda.formula.it

Hi George,

actually I've no real need to use the Performance Monitor Agent. I was just
following the EclipseCon 2005 tutorial as a way to get started with TPTP,
and my real interest is profiling J2EE apps running under JBoss.

In fact I'm much more worried about a conflict between the TPTP (and its
requisites EMF and XSD) installation and the other plugins I had installed
in my Eclipse env, as described in another post just few hours ago.

Stefano

"George Christelis" <george.christelis@scapatech.com> wrote in message
news:d8m612$vra$1@news.eclipse.org...
> Hi Stefano,
>
> There was a known issue in the agent building up to 3.2A. The locale bug
> is a known issue and has been fixed in Hyades 3.3, but not in 3.2A. Unless
> there is a particular reason why you require Hyades TPTP 3.1 then I think
> your problems might be fixed just by upgrading to a more recent Hyades
> version.
>
> Let me know how you get on, or if this is not an option.
> George
Previous Topic:Installation conflict
Next Topic:TPTP and CDT links
Goto Forum:
  


Current Time: Fri Jul 25 06:43:22 EDT 2014

Powered by FUDForum. Page generated in 0.02344 seconds