Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orion » i have installed jslintPlugin but i need another library like node.js angular (the default of the plugin jslint don't know many new libraries how can i the supported of them )
i have installed jslintPlugin but i need another library like node.js angular [message #1244373] Wed, 12 February 2014 03:28 Go to next message
abed masrawa is currently offline abed masrawa
Messages: 1
Registered: February 2014
Junior Member
I am using orion editor and i added the jslintPlugin for my java-Script Files
I have problem that the JSHInt don't working for many basic javaScript objects Like window,console ...

in the code of the plugin i find this:

var DEFAULT_VALIDATION_OPTIONS = {bitwise: false, eqeqeq: true, es5: true, immed:true, indent: 1, maxerr: 300, newcap: true, nomen: false,onevar: false, plusplus: false, regexp: true, strict: false, undef: true, white: false
};


how can add another validation for this?
Re: i have installed jslintPlugin but i need another library like node.js angular [message #1244581 is a reply to message #1244373] Wed, 12 February 2014 09:51 Go to previous messageGo to next message
Adrian Aichner is currently offline Adrian Aichner
Messages: 14
Registered: March 2010
Junior Member
Hi Abed, where are you using this plugin, orionhub?

There you can take a look at
https://orionhub.org/settings/settings.html#,category=validation

JSLint is the old way, the new Orion JavaScript Tool Support does not use it.

At the moment both validation method still use comment directives, either in your source files, or specified at the URL provided above.

See
http://www.jslint.com/lint.html#options
for the full list of options.
Re: i have installed jslintPlugin but i need another library like node.js angular [message #1251737 is a reply to message #1244581] Thu, 20 February 2014 09:48 Go to previous message
Mark Macdonald is currently offline Mark Macdonald
Messages: 21
Registered: July 2009
Junior Member
Try putting these comment directives near the top of your javascript file:

/*jslint browser:true */
/*global console*/


This should work in any version of Orion. The new, ESLint-based validator recognizes certain comment directives for compatibility with the older JSLint-based validator.
Previous Topic:Orion SaaS/PaaS
Next Topic:Adding additional servlets to Orion server
Goto Forum:
  


Current Time: Fri Aug 22 17:49:47 EDT 2014

Powered by FUDForum. Page generated in 0.01988 seconds