Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Migrating from eclipse3.1 to eclipse 3.3
Migrating from eclipse3.1 to eclipse 3.3 [message #203684] Mon, 05 November 2007 19:18 Go to next message
Eclipse User
Originally posted by: ka_one45.hotmail.com

Hi,

I am trying to migrate my existing project from eclipse 3.1 to eclipse 3.3
but i am getting over 100 errors. The project works perfectly in eclipse
3.1 and now my manager will like me to upgrade and I am a bit stuck. Can
anyone help me out with this I dont understand the problem. Also, I tried
searching multiple sources but I did not find anything solid, please help.
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203731 is a reply to message #203684] Mon, 05 November 2007 19:58 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

Karim,

Did you export the projects from one workspace and import them into
another. Are you reusing the same workspace? What kinds of errors are
you getting?


Karim wrote:
> Hi,
>
> I am trying to migrate my existing project from eclipse 3.1 to eclipse 3.3
> but i am getting over 100 errors. The project works perfectly in eclipse
> 3.1 and now my manager will like me to upgrade and I am a bit stuck. Can
> anyone help me out with this I dont understand the problem. Also, I tried
> searching multiple sources but I did not find anything solid, please help.
>
>
>
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203738 is a reply to message #203731] Mon, 05 November 2007 22:00 Go to previous messageGo to next message
Eclipse User
Originally posted by: ka_one45.hotmail.com

Hi Ed,

I just changed the workspace to point to my current workspace that works
with eclipse 3.1 and I have a whole bunch of errors. I disabled validation
but it seems like the project doesn't build correctl because when i try to
run it on the server i get a 404 error like it never built.

I also tried importing the project from scratch but the same things....I m
running out of things try!



"Ed Merks" <merks@ca.ibm.com> wrote in message
news:fgnsho$oa3$2@build.eclipse.org...
> Karim,
>
> Did you export the projects from one workspace and import them into
> another. Are you reusing the same workspace? What kinds of errors are
> you getting?
>
> Karim wrote:
>> Hi,
>>
>> I am trying to migrate my existing project from eclipse 3.1 to eclipse
>> 3.3 but i am getting over 100 errors. The project works perfectly in
>> eclipse 3.1 and now my manager will like me to upgrade and I am a bit
>> stuck. Can anyone help me out with this I dont understand the problem.
>> Also, I tried searching multiple sources but I did not find anything
>> solid, please help.
>>
>>
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203769 is a reply to message #203738] Tue, 06 November 2007 12:14 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------090200000601000803000404
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Karim,

I don't know much about WTP so it's hard for me to help with specific
issues. But then, "a whole bunch of errors" really doesn't give anyone
much to go on. I suppose the problems are likely to be classpath
problems. Perhaps you have libraries or classpath variables that are
unbound or point at the old installation. Do things look okay in
Window->Preferences->Java->Build Path->Classpath Variable/Libraries?


Karim wrote:
> Hi Ed,
>
> I just changed the workspace to point to my current workspace that works
> with eclipse 3.1 and I have a whole bunch of errors. I disabled validation
> but it seems like the project doesn't build correctl because when i try to
> run it on the server i get a 404 error like it never built.
>
> I also tried importing the project from scratch but the same things....I m
> running out of things try!
>
>
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:fgnsho$oa3$2@build.eclipse.org...
>
>> Karim,
>>
>> Did you export the projects from one workspace and import them into
>> another. Are you reusing the same workspace? What kinds of errors are
>> you getting?
>>
>> Karim wrote:
>>
>>> Hi,
>>>
>>> I am trying to migrate my existing project from eclipse 3.1 to eclipse
>>> 3.3 but i am getting over 100 errors. The project works perfectly in
>>> eclipse 3.1 and now my manager will like me to upgrade and I am a bit
>>> stuck. Can anyone help me out with this I dont understand the problem.
>>> Also, I tried searching multiple sources but I did not find anything
>>> solid, please help.
>>>
>>>
>>>
>
>
>


--------------090200000601000803000404
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Karim,<br>
<br>
I don't know much about WTP so it's hard for me to help with specific
issues.&nbsp; But then, "a whole bunch of errors" really doesn't give anyone
much to go on.&nbsp;&nbsp; I suppose the problems are likely to be classpath
problems.&nbsp; Perhaps you have libraries or classpath variables that are
unbound or point at the old installation.&nbsp; Do things look okay in
Window-&gt;Preferences-&gt;Java-&gt;Build Path-&gt;Classpath
Variable/Libraries? <br>
<br>
<br>
Karim wrote:
<blockquote cite="mid:fgo3o6$c6t$1@build.eclipse.org" type="cite">
<pre wrap="">Hi Ed,

I just changed the workspace to point to my current workspace that works
with eclipse 3.1 and I have a whole bunch of errors. I disabled validation
but it seems like the project doesn't build correctl because when i try to
run it on the server i get a 404 error like it never built.

I also tried importing the project from scratch but the same things....I m
running out of things try!



"Ed Merks" <a class="moz-txt-link-rfc2396E" href="mailto:merks@ca.ibm.com">&lt;merks@ca.ibm.com&gt;</a> wrote in message
<a class="moz-txt-link-freetext" href="news:fgnsho$oa3$2@build.eclipse.org">news:fgnsho$oa3$2@build.eclipse.org</a>...
</pre>
<blockquote type="cite">
<pre wrap="">Karim,

Did you export the projects from one workspace and import them into
another. Are you reusing the same workspace? What kinds of errors are
you getting?

Karim wrote:
</pre>
<blockquote type="cite">
<pre wrap="">Hi,

I am trying to migrate my existing project from eclipse 3.1 to eclipse
3.3 but i am getting over 100 errors. The project works perfectly in
eclipse 3.1 and now my manager will like me to upgrade and I am a bit
stuck. Can anyone help me out with this I dont understand the problem.
Also, I tried searching multiple sources but I did not find anything
solid, please help.


</pre>
</blockquote>
</blockquote>
<pre wrap=""><!---->

</pre>
</blockquote>
<br>
</body>
</html>

--------------090200000601000803000404--
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203777 is a reply to message #203731] Tue, 06 November 2007 13:09 Go to previous messageGo to next message
Eclipse User
Originally posted by: ka_one45.hotmail.com

Ed,

I tried it in couple of different ways.

1. I just opened the new eclipe to point at that specific workspace
2. I dragged and dropped the whole folder
3. I tried checking it out from CVS right into the new eclipse


I am getting many errors such as X's on all my source files. If I remove
validation the X's go away and but when i try to run it on the server I get
a 404 error like the files never got built.



"Ed Merks" <merks@ca.ibm.com> wrote in message
news:fgnsho$oa3$2@build.eclipse.org...
> Karim,
>
> Did you export the projects from one workspace and import them into
> another. Are you reusing the same workspace? What kinds of errors are
> you getting?
>
> Karim wrote:
>> Hi,
>>
>> I am trying to migrate my existing project from eclipse 3.1 to eclipse
>> 3.3 but i am getting over 100 errors. The project works perfectly in
>> eclipse 3.1 and now my manager will like me to upgrade and I am a bit
>> stuck. Can anyone help me out with this I dont understand the problem.
>> Also, I tried searching multiple sources but I did not find anything
>> solid, please help.
>>
>>
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203784 is a reply to message #203769] Tue, 06 November 2007 13:11 Go to previous messageGo to next message
Eclipse User
Originally posted by: ka_one45.hotmail.com

This is a multi-part message in MIME format.

------=_NextPart_000_0077_01C8204C.9E9E7FD0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Ed,

Yes all the libraries are there.
"Ed Merks" <merks@ca.ibm.com> wrote in message =
news:fgploe$qek$1@build.eclipse.org...
Karim,

I don't know much about WTP so it's hard for me to help with specific =
issues. But then, "a whole bunch of errors" really doesn't give anyone =
much to go on. I suppose the problems are likely to be classpath =
problems. Perhaps you have libraries or classpath variables that are =
unbound or point at the old installation. Do things look okay in =
Window->Preferences->Java->Build Path->Classpath Variable/Libraries?=20


Karim wrote:=20
Hi Ed,

I just changed the workspace to point to my current workspace that works =

with eclipse 3.1 and I have a whole bunch of errors. I disabled =
validation=20
but it seems like the project doesn't build correctl because when i try =
to=20
run it on the server i get a 404 error like it never built.

I also tried importing the project from scratch but the same =
things....I m=20
running out of things try!



"Ed Merks" <merks@ca.ibm.com> wrote in message=20
news:fgnsho$oa3$2@build.eclipse.org...
Karim,

Did you export the projects from one workspace and import them into=20
another. Are you reusing the same workspace? What kinds of errors are=20
you getting?

Karim wrote:
Hi,

I am trying to migrate my existing project from eclipse 3.1 to eclipse=20
3.3 but i am getting over 100 errors. The project works perfectly in=20
eclipse 3.1 and now my manager will like me to upgrade and I am a bit=20
stuck. Can anyone help me out with this I dont understand the problem.=20
Also, I tried searching multiple sources but I did not find anything=20
solid, please help.


=20

=20

------=_NextPart_000_0077_01C8204C.9E9E7FD0
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type =
content=3Dtext/html;charset=3DISO-8859-1>
<META content=3D"MSHTML 6.00.6000.16544" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY text=3D#000000 bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>Ed,</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Yes all the libraries are =
there.</FONT></DIV>
<BLOCKQUOTE=20
style=3D"PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; =
BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
<DIV>"Ed Merks" &lt;<A =
href=3D"mailto:merks@ca.ibm.com">merks@ca.ibm.com</A>&gt;=20
wrote in message <A=20
=
href=3D"news:fgploe$qek$1@build.eclipse.org">news:fgploe$qek$1@build.ecli=
pse.org</A>...</DIV>Karim,<BR><BR>I=20
don't know much about WTP so it's hard for me to help with specific=20
issues.&nbsp; But then, "a whole bunch of errors" really doesn't give =
anyone=20
much to go on.&nbsp;&nbsp; I suppose the problems are likely to be =
classpath=20
problems.&nbsp; Perhaps you have libraries or classpath variables that =
are=20
unbound or point at the old installation.&nbsp; Do things look okay in =

Window-&gt;Preferences-&gt;Java-&gt;Build Path-&gt;Classpath=20
Variable/Libraries? <BR><BR><BR>Karim wrote:=20
<BLOCKQUOTE cite=3Dmid:fgo3o6$c6t$1@build.eclipse.org =
type=3D"cite"><PRE wrap=3D"">Hi Ed,

I just changed the workspace to point to my current workspace that works =

with eclipse 3.1 and I have a whole bunch of errors. I disabled =
validation=20
but it seems like the project doesn't build correctl because when i try =
to=20
run it on the server i get a 404 error like it never built.

I also tried importing the project from scratch but the same =
things....I m=20
running out of things try!



"Ed Merks" <A class=3Dmoz-txt-link-rfc2396E =
href=3D"mailto:merks@ca.ibm.com">&lt;merks@ca.ibm.com&gt;</A> wrote in =
message=20
<A class=3Dmoz-txt-link-freetext =
href=3D"news:fgnsho$oa3$2@build.eclipse.org">news:fgnsho$oa3$2@build.ecli=
pse.org</A>...
</PRE>
<BLOCKQUOTE type=3D"cite"><PRE wrap=3D"">Karim,

Did you export the projects from one workspace and import them into=20
another. Are you reusing the same workspace? What kinds of errors are=20
you getting?

Karim wrote:
</PRE>
<BLOCKQUOTE type=3D"cite"><PRE wrap=3D"">Hi,

I am trying to migrate my existing project from eclipse 3.1 to eclipse=20
3.3 but i am getting over 100 errors. The project works perfectly in=20
eclipse 3.1 and now my manager will like me to upgrade and I am a bit=20
stuck. Can anyone help me out with this I dont understand the problem.=20
Also, I tried searching multiple sources but I did not find anything=20
solid, please help.


</PRE></BLOCKQUOTE></BLOCKQUOTE><PRE wrap=3D""><!---->

</PRE></BLOCKQUOTE><BR></BLOCKQUOTE></BODY></HTML>

------=_NextPart_000_0077_01C8204C.9E9E7FD0--
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203792 is a reply to message #203777] Tue, 06 November 2007 14:00 Go to previous messageGo to next message
Eclipse User
Originally posted by: ka_one45.hotmail.com

Hi,

The project now give me the error "cannot find tag library descriptor" but
my web.xml file is there and it also works find in eclipse 3.1 any ideas?

"Karim" <ka_one45@hotmail.com> wrote in message
news:fgpp3s$b0e$1@build.eclipse.org...
> Ed,
>
> I tried it in couple of different ways.
>
> 1. I just opened the new eclipe to point at that specific workspace
> 2. I dragged and dropped the whole folder
> 3. I tried checking it out from CVS right into the new eclipse
>
>
> I am getting many errors such as X's on all my source files. If I remove
> validation the X's go away and but when i try to run it on the server I
> get a 404 error like the files never got built.
>
>
>
> "Ed Merks" <merks@ca.ibm.com> wrote in message
> news:fgnsho$oa3$2@build.eclipse.org...
>> Karim,
>>
>> Did you export the projects from one workspace and import them into
>> another. Are you reusing the same workspace? What kinds of errors are
>> you getting?
>>
>> Karim wrote:
>>> Hi,
>>>
>>> I am trying to migrate my existing project from eclipse 3.1 to eclipse
>>> 3.3 but i am getting over 100 errors. The project works perfectly in
>>> eclipse 3.1 and now my manager will like me to upgrade and I am a bit
>>> stuck. Can anyone help me out with this I dont understand the problem.
>>> Also, I tried searching multiple sources but I did not find anything
>>> solid, please help.
>>>
>>>
>
>
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203799 is a reply to message #203792] Tue, 06 November 2007 15:26 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2272
Registered: July 2009
Senior Member
Karim wrote:
> The project now give me the error "cannot find tag library descriptor" but
> my web.xml file is there and it also works find in eclipse 3.1 any ideas?

It's possible that it just wasn't reported in that version. Which
URI is it saying it can't find? Is it mapped in the web.xml file?

--
Nitin Dahyabhai
Structured Source Editing


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Migrating from eclipse3.1 to eclipse 3.3 [message #203929 is a reply to message #203799] Wed, 07 November 2007 17:32 Go to previous message
Eclipse User
Originally posted by: ka_one45.hotmail.com

2 customer URI's and JSTL. Upgradin to eclipse 3.3 was a major problem for
me. Anyways tricks you know i can do without touching my workspace just
opening the workspace in 3.3 and making it work like it does in 3.1?



"Nitin Dahyabhai" <nitind@us.ibm.com> wrote in message
news:fgq16o$721$1@build.eclipse.org...
> Karim wrote:
>> The project now give me the error "cannot find tag library descriptor"
>> but my web.xml file is there and it also works find in eclipse 3.1 any
>> ideas?
>
> It's possible that it just wasn't reported in that version. Which URI is
> it saying it can't find? Is it mapped in the web.xml file?
>
> --
> Nitin Dahyabhai
> Structured Source Editing
Previous Topic:problem in adding Derby plug-ins to Eclipse
Next Topic:Extending the WSDL Editor
Goto Forum:
  


Current Time: Sat Sep 20 04:10:57 GMT 2014

Powered by FUDForum. Page generated in 0.01935 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software