Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Need the source code of MARTE
Need the source code of MARTE [message #1242971] Mon, 10 February 2014 10:31 Go to next message
amina magd is currently offline amina magd
Messages: 16
Registered: March 2012
Junior Member
Hello,

I need to import the source code of MARTE to make some changes.

I use Eclipse Kepler version

I tried with this link :

http://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.papyrus/tags/0.9.1_SR1/extraplugins/marte/org.eclipse.papyrus.marte.static.profile

But it does not work with the version of eclipse that i use (errors are generated)

What is the appropriate version of MARTE that i must use with Eclipse Kepler ?

Thanks for reply,
Best regards,
Amina

[Updated on: Mon, 10 February 2014 10:47]

Report message to a moderator

Re: Need the source code of MARTE [message #1243047 is a reply to message #1242971] Mon, 10 February 2014 12:51 Go to previous messageGo to next message
amina magd is currently offline amina magd
Messages: 16
Registered: March 2012
Junior Member
Resolved Smile
Re: Need the source code of MARTE [message #1249162 is a reply to message #1243047] Tue, 18 February 2014 02:19 Go to previous messageGo to next message
Vadim Peretokin is currently offline Vadim Peretokin
Messages: 29
Registered: July 2009
Junior Member
Resolved how? It would be helpful to know for others who run into the same issue.
Re: Need the source code of MARTE [message #1249473 is a reply to message #1249162] Tue, 18 February 2014 09:34 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille Letavernier
Messages: 457
Registered: February 2011
Senior Member
Hi,


The source code has been moved to git:

git://git.eclipse.org/gitroot/papyrus/org.eclipse.papyrus.git

The Marte plug-ins are available under the extraplugins/marte/ folder

For Kepler, you should use the streams/0.10-maintenance branch. For Luna, you should use master.


Regards,
Camille


Camille Letavernier
Papyrus developer
Re: Need the source code of MARTE [message #1387851 is a reply to message #1249473] Wed, 25 June 2014 17:31 Go to previous message
amina Mising name is currently offline amina Mising name
Messages: 3
Registered: March 2011
Junior Member
I tried to create a UML/MARTE profile using the source code of MARTE.
The profile is created and defined successfully, but i can not apply it on a model.
When trying to apply the created profile on a papyrus model, i get this error
the feature 'references' of 'subsets' contains an unresolved proxy 'org.eclipse.emf.ecore.impl.EObjectImpl@29b37cea{http://www.eclipse.org/papyrus/MARTE/1#//MARTE_Annexes/VSL/DataTypes/TupleType/tupleAttrib}'

(please see attached)
I am using Eclipse Kepler S2
Any help please ?
Thank you,
Best regards
  • Attachment: error.png
    (Size: 216.04KB, Downloaded 5 times)
Previous Topic:Xtext integration into Papyrus PopupEditor
Next Topic:Announcing Eclipse OCL 5.0.0 and 5.0.1 for Luna
Goto Forum:
  


Current Time: Sun Sep 21 10:19:08 GMT 2014

Powered by FUDForum. Page generated in 0.03327 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software