Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Can not profile tomat
Can not profile tomat [message #203426] Thu, 01 November 2007 17:43 Go to next message
Eclipse User
Originally posted by: wjfang.gmail.com

Hi,

I installed TPTP 4.4.1 and WTP. I am using the integrated agent controller.
I developped a web application, and want to profile it on a tomcat 5.0
server inside Eclipse. (I have set up a Tomcat 5.0 server runtime in
Eclipse).

Now I can start my web application on the internal tomcat. Testing is fine.
But when I try to profile it, I keep getting the following error message:

"Timeout waiting for Tomcat v5.0 Server at localhost to start. Server did
not start after 45s."

The "Server timeout delay" in preference is "Normal". If I set to
"Unlimited", I have to wait forever.

Any suggestion here? Does it really require a lot of time to start up tomcat
in the profiling mode? Many thanks in advance!

Cheers,

Jerry
Re: Can not profile tomat [message #203449 is a reply to message #203426] Thu, 01 November 2007 20:33 Go to previous messageGo to next message
Lawrence Mandel is currently offline Lawrence Mandel
Messages: 486
Registered: July 2009
Senior Member
Hi Jerry,

Did you start Tomcat in profiling mode? If so, is there another instance
of Tomcat (perhaps one that you're using for testing) running?

Lawrence

>Hi,
>
>I installed TPTP 4.4.1 and WTP. I am using the integrated agent
controller.
>I developped a web application, and want to profile it on a tomcat 5.0
>server inside Eclipse. (I have set up a Tomcat 5.0 server runtime in
>Eclipse).
>
>Now I can start my web application on the internal tomcat. Testing is
fine.
>But when I try to profile it, I keep getting the following error message:
>
>"Timeout waiting for Tomcat v5.0 Server at localhost to start. Server did
>not start after 45s."
>
>The "Server timeout delay" in preference is "Normal". If I set to
>"Unlimited", I have to wait forever.
>
>Any suggestion here? Does it really require a lot of time to start up
tomcat
>in the profiling mode? Many thanks in advance!
>
>Cheers,
>
>Jerry
Re: Can not profile tomat [message #203457 is a reply to message #203426] Thu, 01 November 2007 20:46 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1307
Registered: July 2009
Senior Member
Bug 202078[1] indicates that using the integrated agent controller has
problems when starting servers like Tomcat. The bug suggests the
standalone agent controller can be used instead. I don't know the
details of doing that though.

Cheers,
Larry

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=202078

Weijian wrote:
> Hi,
>
> I installed TPTP 4.4.1 and WTP. I am using the integrated agent controller.
> I developped a web application, and want to profile it on a tomcat 5.0
> server inside Eclipse. (I have set up a Tomcat 5.0 server runtime in
> Eclipse).
>
> Now I can start my web application on the internal tomcat. Testing is fine.
> But when I try to profile it, I keep getting the following error message:
>
> "Timeout waiting for Tomcat v5.0 Server at localhost to start. Server did
> not start after 45s."
>
> The "Server timeout delay" in preference is "Normal". If I set to
> "Unlimited", I have to wait forever.
>
> Any suggestion here? Does it really require a lot of time to start up tomcat
> in the profiling mode? Many thanks in advance!
>
> Cheers,
>
> Jerry
>
>
>
Re: Can not profile tomat [message #203496 is a reply to message #203457] Fri, 02 November 2007 17:09 Go to previous message
Eclipse User
Originally posted by: wjfang.gmail.com

Larry,

After I started the standalone agent controller, I can profile tomcat.
Thanks for your suggestion.


"Larry Isaacs" <Larry.Isaacs@sas.com> wrote in message
news:fgddvg$4gr$1@build.eclipse.org...
> Bug 202078[1] indicates that using the integrated agent controller has
> problems when starting servers like Tomcat. The bug suggests the
> standalone agent controller can be used instead. I don't know the details
> of doing that though.
>
> Cheers,
> Larry
>
> [1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=202078
>
> Weijian wrote:
>> Hi,
>>
>> I installed TPTP 4.4.1 and WTP. I am using the integrated agent
>> controller.
>> I developped a web application, and want to profile it on a tomcat 5.0
>> server inside Eclipse. (I have set up a Tomcat 5.0 server runtime in
>> Eclipse).
>>
>> Now I can start my web application on the internal tomcat. Testing is
>> fine.
>> But when I try to profile it, I keep getting the following error message:
>>
>> "Timeout waiting for Tomcat v5.0 Server at localhost to start. Server did
>> not start after 45s."
>>
>> The "Server timeout delay" in preference is "Normal". If I set to
>> "Unlimited", I have to wait forever.
>>
>> Any suggestion here? Does it really require a lot of time to start up
>> tomcat
>> in the profiling mode? Many thanks in advance!
>>
>> Cheers,
>>
>> Jerry
>>
>>
Previous Topic:eclipse update : wtp and europa
Next Topic:Is there an unrestricted API similar to IModelManager.getModelForRead(IFile)?
Goto Forum:
  


Current Time: Tue Sep 30 15:57:01 GMT 2014

Powered by FUDForum. Page generated in 0.10480 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software