Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Code Recommenders » Code Recommenders and XText Compatibility(I am having some issues installing Code Recommenders and Xtext in an Eclipse Luna M4/M5 IDE)
Code Recommenders and XText Compatibility [message #1238865] Sun, 02 February 2014 17:59 Go to next message
Stefan Prisca is currently offline Stefan PriscaFriend
Messages: 7
Registered: July 2013
Junior Member
Hi,

I am having some problems when installing Code Recommenders 2.x [1] and Xtext 2.5 [2] in a fresh standard Eclipse Luna IDE(it happens for both the M4 and M5 versions).[3]

I did the next things:

Downloaded the standard Eclipse Luna Package [3].
Installed XText 2.5 from the update site [2].
Installed Code Recommenders from [1].



After doing so, this error message appears when starting the IDE [5], and the xtext/xtend files are not recognized anymore.
Note that this does not happen before installing Code Recommenders.

The same happens after I install Code Recommenders over an Eclipse Java and DSL Developer package [4].

I've checked for duplicate org.eclipse.xtext.ui.shared plug-ins in the plug-in folder of the IDE, but there are none.

Any ideas on what goes wrong, or what I am doing wrong?

I attached a print-screen of my current Eclipse IDE installation details.

Thanks!
Best Regards,
Stefan.

[1]: <http://download.eclipse.org/recommenders/updates/head/>
[2]: <http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/>
[3]: <http://www.eclipse.org/downloads/packages/eclipse-standard-44-m4/lunam4>
[4]: <http://www.eclipse.org/downloads/packages/eclipse-ide-java-and-dsl-developers/lunam4>

[5]:
Errors occurred during the build.
Error instantiating builder 'org.eclipse.xtext.ui.shared.xtextBuilder'.
Plug-in org.eclipse.xtext.ui.shared was unable to load class org.eclipse.xtext.ui.shared.internal.ExecutableExtensionFactory.
org/eclipse/xtext/ui/guice/AbstractGuiceAwareExecutableExtensionFactory
Plug-in org.eclipse.xtext.ui.shared was unable to load class org.eclipse.xtext.ui.shared.internal.ExecutableExtensionFactory.
org/eclipse/xtext/ui/guice/AbstractGuiceAwareExecutableExtensionFactory
Re: Code Recommenders and XText Compatibility [message #1438806 is a reply to message #1238865] Mon, 06 October 2014 14:21 Go to previous messageGo to next message
Alexander R is currently offline Alexander RFriend
Messages: 119
Registered: July 2013
Senior Member
Hi,
did you maybe find a way to fix this problem?

~Alex
Re: Code Recommenders and XText Compatibility [message #1439720 is a reply to message #1438806] Tue, 07 October 2014 12:40 Go to previous message
Stefan Prisca is currently offline Stefan PriscaFriend
Messages: 7
Registered: July 2013
Junior Member
Hi,

I lost track of it, and it didn't occur since then.
I think that after Xtext 2.6 came out, I installed that version and it worked without any problems.

Why? Are you experiencing a similar issue?

Best Regards,
Stefan.
Previous Topic:Multiple Snipmatch git-repo
Next Topic:Malware in http://eclipse.mirror.kangaroot.net/recommenders/models/luna/jre?
Goto Forum:
  


Current Time: Fri Nov 28 00:47:54 GMT 2014

Powered by FUDForum. Page generated in 0.01675 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software