Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Re: Mylyn 2.1 is now available
Re: Mylyn 2.1 is now available [message #202433] Tue, 16 October 2007 23:44 Go to next message
David Carver is currently offline David Carver
Messages: 174
Registered: July 2009
Senior Member
Mik Kersten wrote:
> Werner, I assume that you are using the ../e3.4 update sites.
>
> http://www.eclipse.org/mylyn/downloads/
>
> Please do file a bug since this is odd (Mylyn has no dependencies on
> WTP) and we should investigate.
>

Something similar. The Project Explorer context focused UI also seems
to stop working with the WTP J2EE plugins installed. It works fine
with just the WST plugins only installed. I noticed this after
installing 2.1 of Mylyn and 2.0.1 of WTP.




> Mik
>
> Werner Keil wrote:
>> It seems, both the official 2.1 release and the Weekly Build (already
>> labels itself 2.2.x) don't work with 3.4M2 and WTP 3 correctly?!
>>
>> Nothing can be installed and the errors shown by Update Manager don't
>> seem to make much sense:
>>
>> The current configuration contains errors and this operation can have
>> unpredictable results.
>> WST Web Services UI (2.0.1.v200710021354-792EGwAufYO8FqYlmS_5Ff4sbiKz)
>> requires plug-in "org.eclipse.gef (3.2.0)", or compatible.
>> WTP Web Page Editor (1.1.0.v200709202235-3-29oA55P855A) requires
>> plug-in "org.eclipse.gef (3.2.0)", or compatible.
>> Java Persistence API Tools (1.1.0.v200709170000-772AgCYQCCz-D_LoCCEH)
>> requires feature "org.eclipse.datatools.connectivity.feature".
>> WST Common UI (2.1.0.v200709192200-7C6EIaE9RvTVninpsnWz0WgQZgle)
>> requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
>> Eclipse XML Editors and Tools
>> (2.1.0.v200709192200-7A3EIPCnbckz0itrBsMmAKQjdclf) requires plug-in
>> "org.eclipse.gef (3.2.0)", or compatible.
>>
>>
>> At least the WTP Web Page Editor does however work correctly.
>>
>> Installing both Mylyn 2.x releases over a 'naked' 3.4M2 works.
>> One can even copy such updates manually over the WTP 3 installation, but
>> while Mylyn works there too as far as I can see, adding further
>> components like 'Exras' fails with the same error (pointing to Web Page
>> Editor)
>>
>> I might be able to raise this Bug (not sure, which part is the actual
>> reason for it, but it only manifests itself when trying to install Mylyn
>> so far) using a working Mylyn installation somewhere, too...
>>
>> Thanks and Regards,
>> Werner
>>
>>
>> Mik Kersten wrote:
>>> We are pleased to announce that Mylyn 2.1 is now available and supports
>>> Eclipse 3.3 and 3.4M2.
>>>
>>> http://eclipse.org/mylyn/new/
>>>
>>> http://eclipse.org/mylyn/downloads/
>>>
>>> This release of Mylyn is also included with three of the Eclipse Europa
>>> Fall Update bundles released today:
>>>
>>> http://eclipse.org/downloads/
>>>
>>> The Mylyn Team
Re: Mylyn 2.1 is now available [message #203593 is a reply to message #202433] Fri, 02 November 2007 22:33 Go to previous message
Eclipse User
Originally posted by: beatmik.acm.org

I couldn't reproduce this. If it is still happening please file a Mylyn
bug so that we can diagnose further.

Mik

David Carver wrote:
> Mik Kersten wrote:
>> Werner, I assume that you are using the ../e3.4 update sites.
>>
>> http://www.eclipse.org/mylyn/downloads/
>>
>> Please do file a bug since this is odd (Mylyn has no dependencies on
>> WTP) and we should investigate.
>>
>
> Something similar. The Project Explorer context focused UI also seems
> to stop working with the WTP J2EE plugins installed. It works fine
> with just the WST plugins only installed. I noticed this after
> installing 2.1 of Mylyn and 2.0.1 of WTP.
Previous Topic:Is there an unrestricted API similar to IModelManager.getModelForRead(IFile)?
Next Topic:WTP, JBOSS 4.2 and EJB 2
Goto Forum:
  


Current Time: Fri Aug 01 09:59:11 EDT 2014

Powered by FUDForum. Page generated in 0.14225 seconds