Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » (Solved)The solution for the conflict when Config Glassfish 4 with the Kepler on MAC OS X 10.9.1(Some guys mentioned the wrong for username and password when the user run glassfish 4 on Eclipse Kepler.)
icon3.gif  (Solved)The solution for the conflict when Config Glassfish 4 with the Kepler on MAC OS X 10.9.1 [message #1237336] Wed, 29 January 2014 07:43
Christopher LI is currently offline Christopher LI
Messages: 1
Registered: January 2014
Junior Member
I cost several days to config the eclipse environment, and met a trouble when I clicked "Run on Server" in Eclipse Kepler, after one minute, one warning showed " wrong username or password", the starting process of Glassfish was killed. I checked a lot of threads in different forums for this topic, but those threads cannot solve the problem, because most of them were occurred in Eclipse Kepler for windows version. There is no the check box for " anonymous user" in the version of Eclipse Kepler for MAC OS. Finally, I solved the problem to the core. I hope my experience will decrease the others' time for this trouble.

The software environment of my MAC is:
OS: MAC OS X 10.9.1
Language: English
JRE: 1.7.0_10
Eclipse: Kepler SR1
Glassfish: 4.0(open source)

The Glassfish was installed from the Eclipse Marketplace, the installation process was smoothed, and I set the admin password for the default domain--domain1. Some guys said, the password shall be left with blank, my experience is no matter, you can set it in the installation process.

When you finish the installation of Glassfish, you shall perform some operations as below:

To the menu line, click "Eclipse"-->"Preferences"

index.php/fa/17355/0/

Choose "Remote System"-->"Passwords"

index.php/fa/17356/0/

When you see the windows of "Passwords", click "Add".

index.php/fa/17357/0/

Input relative info as upper picture and click "OK" and quit the "Preferences"

Until now, try it again, I assume the trouble has been removed.

If you cannot achieve the same result, please let me know, I would like to help you to find the answer.

Previous Topic:How to exclude Groovy plugin jars from Tomcat classpath
Next Topic:Managing dependnecies, WTP and Gradle cooperation
Goto Forum:
  


Current Time: Fri Aug 29 04:14:58 EDT 2014

Powered by FUDForum. Page generated in 0.02169 seconds