Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » What happened to the 1.7 support?
What happened to the 1.7 support? [message #1236804] Tue, 28 January 2014 05:14 Go to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4184
Registered: July 2009
Senior Member
Hi

One of the third party repos I use still has a 1.5 server. The 1.7
client support seemed to work fine, but using Luna M4 I can now only use
1.8 and accesses to the server just hang. A quick glance with Wireshark
suggests that a protocol interchange is expected that 1.5 does not support.

Any chance of restoring the 1.7 connectors (or fixing 1.8 to work with 1.5)?

Regards

Ed Willink
Re: What happened to the 1.7 support? [message #1238850 is a reply to message #1236804] Sun, 02 February 2014 16:54 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4184
Registered: July 2009
Senior Member
Hi

Looks like it's fixed in M5.

Regards

Ed Willink

On 28/01/2014 05:14, Ed Willink wrote:
> Hi
>
> One of the third party repos I use still has a 1.5 server. The 1.7
> client support seemed to work fine, but using Luna M4 I can now only
> use 1.8 and accesses to the server just hang. A quick glance with
> Wireshark suggests that a protocol interchange is expected that 1.5
> does not support.
>
> Any chance of restoring the 1.7 connectors (or fixing 1.8 to work with
> 1.5)?
>
> Regards
>
> Ed Willink
Re: What happened to the 1.7 support? [message #1240065 is a reply to message #1238850] Wed, 05 February 2014 16:18 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4184
Registered: July 2009
Senior Member
Hi

No it's not. But sometimes it works. TortoiseSVN 1.8.4 seems troubled too.

Checking out afresh with TortoiseSVN 1.7.12 and all is wonderful.

Definitekly seems that allowing a project conversion to 1.8 against a
1.5 server is really bad.

Regards

Ed Willink

On 02/02/2014 16:54, Ed Willink wrote:
> Hi
>
> Looks like it's fixed in M5.
>
> Regards
>
> Ed Willink
>
> On 28/01/2014 05:14, Ed Willink wrote:
>> Hi
>>
>> One of the third party repos I use still has a 1.5 server. The 1.7
>> client support seemed to work fine, but using Luna M4 I can now only
>> use 1.8 and accesses to the server just hang. A quick glance with
>> Wireshark suggests that a protocol interchange is expected that 1.5
>> does not support.
>>
>> Any chance of restoring the 1.7 connectors (or fixing 1.8 to work
>> with 1.5)?
>>
>> Regards
>>
>> Ed Willink
>
Re: What happened to the 1.7 support? [message #1257463 is a reply to message #1240065] Wed, 26 February 2014 13:03 Go to previous messageGo to next message
Alexander Gurov is currently offline Alexander GurovFriend
Messages: 96
Registered: July 2009
Member
If you're working with SVN 1.8 connectors and the native one has some issues with SVN 1.5 server support I could suggest you to try using SVN Kit-based one. Also the SVN 1.7 compatible connectors support is not discontinued and both (native and SVN Kit) connectors are available at update sites. Though we will discontinue support of SVN 1.6 compatible conectors soon.
Re: What happened to the 1.7 support? [message #1257499 is a reply to message #1257463] Wed, 26 February 2014 13:51 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 4184
Registered: July 2009
Senior Member
Hi

TortoiseSVN 1.8 fails as well so I have to use TortoiseSVN 1.7 for this
legacy repo since while the 1.7 support may not be discontinued, the
1.7 options are disabled in the Luna add-in installation window.

Regards

Ed Willink

On 26/02/2014 13:03, Alexander Gurov wrote:
> If you're working with SVN 1.8 connectors and the native one has some
> issues with SVN 1.5 server support I could suggest you to try using
> SVN Kit-based one. Also the SVN 1.7 compatible connectors support is
> not discontinued and both (native and SVN Kit) connectors are
> available at update sites. Though we will discontinue support of SVN
> 1.6 compatible conectors soon.
Re: What happened to the 1.7 support? [message #1283467 is a reply to message #1257499] Thu, 03 April 2014 12:57 Go to previous message
Igor Vinnykov is currently offline Igor VinnykovFriend
Messages: 61
Registered: July 2009
Member
Hi Ed,

I tried Subversive in Eclipse Luna M6, in my case connectors discovery didn't even try to start and I'm not sure if it is the Luna's or Subversive's fault.
On the other hand when I used update site's URL directly, I was able to install connectors for SVN 1.6, 1.7 and 1.8.
So, please try using this URL to install SVN 1.7 support.

http://community.polarion.com/projects/subversive/download/eclipse/4.0/update-site/

Best regards,
Subversive Team.
Previous Topic:Subversion on Hudson-3.1.2
Next Topic:Duplication occured
Goto Forum:
  


Current Time: Thu Dec 18 09:47:16 GMT 2014

Powered by FUDForum. Page generated in 0.01842 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software