Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Support for Spring 4.0(Looking for plan to support Spring Framework 4.0 and Java 8)
Support for Spring 4.0 [message #1235581] Fri, 24 January 2014 18:14 Go to next message
benoit besson is currently offline benoit besson
Messages: 1
Registered: January 2014
Junior Member
Hello,

I'm planning to evaluate Virgo. I downloaded the 3.0.0.RC1 version and I found it to be built with spring framework 3.0.0. Is there a plan to support Spring Framework 4.0 as it is the current production release ? Is there a plan to support Java 8 as it becomes in general availability in March ?

Thanks,

Ben.
Re: Support for Spring 4.0 [message #1235605 is a reply to message #1235581] Fri, 24 January 2014 19:29 Go to previous messageGo to next message
Florian Waibel is currently offline Florian Waibel
Messages: 99
Registered: June 2010
Member
Hi Ben,

please note the current release version is 3.6.2.RELEASE and can be found on our download page. This version uses Spring 3.1.0.RELEASE by default.

However you can replace Spring with a newer version in the user region. You can find more details in the FAQ.

Upgrading the embedded Spring version is covered in bug 351868. Please feel free to raise a bugzilla covering Java 8 support.

Regards,
florian
Re: Support for Spring 4.0 [message #1439844 is a reply to message #1235605] Tue, 07 October 2014 15:36 Go to previous messageGo to next message
Ahsen Jaffer is currently offline Ahsen Jaffer
Messages: 1
Registered: April 2014
Junior Member
Hi Florian,

I see from the FAQ that it provides details on how to upgrade/downgrade spring versions.

Do you know:

1) It does not specifically provide instructions regarding Spring framework 4.0 (since there was none at the time of writing), can the same instructions be used to use Spring framework 4.0?
2) Is there going to be a repository for Spring 4.0 OSGi bundles?

Re: Support for Spring 4.0 [message #1440405 is a reply to message #1439844] Wed, 08 October 2014 10:17 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta Georgieva
Messages: 242
Registered: October 2010
Senior Member
Ahsen Jaffer wrote on Tue, 07 October 2014 18:36
Hi Florian,

I see from the FAQ that it provides details on how to upgrade/downgrade spring versions.

Do you know:

1) It does not specifically provide instructions regarding Spring framework 4.0 (since there was none at the time of writing), can the same instructions be used to use Spring framework 4.0?



Follow Bug 439964
Re: Support for Spring 4.0 [message #1441205 is a reply to message #1439844] Thu, 09 October 2014 11:47 Go to previous message
Florian Waibel is currently offline Florian Waibel
Messages: 99
Registered: June 2010
Member
Hi Ahsen,

Ahsen Jaffer wrote on Tue, 07 October 2014 11:36

2) Is there going to be a repository for Spring 4.0 OSGi bundles?


As far a I know the "Eclipse Bundle Recipes" project hosts "only templates (not the original Jar or resulting bundle)". [1]

I'm not sure if the ServiceMix Bundles Project provides such a repository.
Seems they already created recipes for Spring 4+ (http://svn.apache.org/repos/asf/servicemix/smx4/bundles/trunk/).

Regards,
florian

[1] http://projects.eclipse.org/projects/rt.ebr
Previous Topic:Bundle Error:Import-package:xxxx can not be resovled
Next Topic:How build Tomcat OSGi Bundle
Goto Forum:
  


Current Time: Wed Oct 22 15:42:08 GMT 2014

Powered by FUDForum. Page generated in 0.02325 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software