Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues
Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #201765] Wed, 10 October 2007 16:45 Go to next message
Werner Keil is currently offline Werner Keil
Messages: 1083
Registered: July 2009
Senior Member
Hi,

I posted this earlier in the Mylyn group, but it does not seem to have
anything to do with Mylyn.

I installed both Eclipse 3.4 M2 and all required dependencies for WTP3.
Then WTP 3.0 M2 (the Runtime, not the SDK)

Random tests like setting up various servers and even the new Visual
JSP/HTML editor work perfectly well.

However, once you try running UpdateManager for every additional plugin
(e.g. Mylyn, it is the same for others like SVN client, etc.) I tried,
this is not possible due to the following errors:

The current configuration contains errors and this operation can have
unpredictable results.
WST Web Services UI (2.0.1.v200710021354-792EGwAufYO8FqYlmS_5Ff4sbiKz)
requires plug-in "org.eclipse.gef (3.2.0)", or compatible.
WTP Web Page Editor (1.1.0.v200709202235-3-29oA55P855A) requires
plug-in "org.eclipse.gef (3.2.0)", or compatible.
Java Persistence API Tools (1.1.0.v200709170000-772AgCYQCCz-D_LoCCEH)
requires feature "org.eclipse.datatools.connectivity.feature".
WST Common UI (2.1.0.v200709192200-7C6EIaE9RvTVninpsnWz0WgQZgle)
requires plug-in "org.eclipse.draw2d (3.2.0)", or compatible.
Eclipse XML Editors and Tools
(2.1.0.v200709192200-7A3EIPCnbckz0itrBsMmAKQjdclf) requires plug-in
"org.eclipse.gef (3.2.0)", or compatible.

First of all, most of those dependencies point as far back to 3.2.0 (?)

Second of all, some important parts mentioned here, like WTP Web Page
Editor work perfectly fine in tests with web pages.
Would this error be true, I'd expect the editor to not even work.

If you completely remove WTP 3 or install 3.4 M2 on its own, plugins
like Mylyn install with no problem.

Please advise, this seems like a significant problem. I understand, 3 is
probably still a very early release, so I may have to go with 2.x at
least for a production-like system.

Once I get Mylyn up and running somewhere, I guess I will also file the
bug there in Bugzilla.
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #201910 is a reply to message #201765] Thu, 11 October 2007 13:59 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Wed, 10 Oct 2007 16:45:40 -0400, Werner Keil <werner.keil@gmx.net> wr=
ote:


>
> Please advise, this seems like a significant problem. I understand, 3 =
is
> probably still a very early release, so I may have to go with 2.x at
> least for a production-like system.
>

I'm a little confused by some of the behavior you are reporting, and you=

don't say where you are getting your updates from .... but, I do know th=
ey
don't exist for WTP 3.0 M2 ... so, I'll assume that's the only problem, =
for now.

I've opened but 206070 to track.
https://bugs.eclipse.org/bugs/show_bug.cgi?id=3D206070

It'll take me a day or so to do for M2, but we do plan to make our updat=
es
available on an update site, but it will be a special one you'll have to=

add to your update manager as a new remote site:

http://download.eclipse.org/webtools/milestones/

The reason, if you're interested, is that we don't want to risk someone
using a production release of a product built on WTP 2.0 getting the wro=
ng unreleased
version of WTP installed in their product (in a perfect world, there'd b=
e no risk ... but,
we all know update manager :)

I do appreciate you letting us know you want/need this. Thank you.
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #201934 is a reply to message #201910] Thu, 11 October 2007 15:56 Go to previous messageGo to next message
Werner Keil is currently offline Werner Keil
Messages: 1083
Registered: July 2009
Senior Member
Thanks for that.

I got the archives for 3.0 M2 and its dependencies here:
http://download.eclipse.org/webtools/downloads/drops/R3.0/S- 3.0M2-20071003160832/

So I will try the Update Manager way of installing it and see, if the
problem also should occur there?
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #203600 is a reply to message #201910] Sat, 03 November 2007 17:58 Go to previous messageGo to next message
Werner Keil is currently offline Werner Keil
Messages: 1083
Registered: July 2009
Senior Member
David Williams wrote:
>
> It'll take me a day or so to do for M2, but we do plan to make our updates
> available on an update site, but it will be a special one you'll have to
> add to your update manager as a new remote site:
>
> http://download.eclipse.org/webtools/milestones/
>

It took me a little while to test this again, but now on top of Eclipse
3.4 M3 I wanted to give it a try.

However, the Update Manager link you mentioned above only contains WTP 2
Is this intended?
As I was asking about WTP 3.0, but if there is no Update Manager distro
for any of those, that's also OK.
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #204291 is a reply to message #201910] Tue, 13 November 2007 03:50 Go to previous messageGo to next message
Gabriele Garuglieri is currently offline Gabriele Garuglieri
Messages: 44
Registered: July 2009
Member
I reiterate the question, which was not answered.
The milestones update site only contains 2.1 stuff. No 3.0 updates
anywhere.

As far as i know this is the only project that still requires manual
download and installation to follow milestones builds and this is a real
pain.
We do our best to try and test new releases, but please on your side
please help us to stay current making milestones/interim builds available
via update manager like all the other eclipse projects do.

Thanks, Gabriele
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #204542 is a reply to message #204291] Fri, 16 November 2007 01:56 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Tue, 13 Nov 2007 03:50:38 -0500, Gabriele Garuglieri <gabriele.garuglieri@infoblu.it> wrote:

> I reiterate the question, which was not answered.
> The milestones update site only contains 2.1 stuff. No 3.0 updates
> anywhere.
>
> As far as i know this is the only project that still requires manual
> download and installation to follow milestones builds and this is a real
> pain.
> We do our best to try and test new releases, but please on your side
> please help us to stay current making milestones/interim builds available
> via update manager like all the other eclipse projects do.
>
> Thanks, Gabriele
>
>

That 2.1 stuff you see is the 3.0 stream "in progress", so should work fine.
Give it a try.
We'll occationally bump up the 2.x versions, but based on your experience, maybe
we should just go all the way to 3.0 next milestone.

Thanks,
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #204559 is a reply to message #204542] Fri, 16 November 2007 02:06 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Fri, 16 Nov 2007 01:56:18 -0500, David Williams <david_williams@us.ibm.com> wrote:

And, I should clarify, the very best place to get a fresh install using update manager is the
Ganymede sight.

http://download.eclipse.org/releases/ganymede/staging/

Using that site, You can also get all the pre-reqs for WTP, if you don't have them already.

Thanks,
Re: Eclipse 3.4 M2 and WTP 3.0 M2 Update Manager Issues [message #204583 is a reply to message #204559] Fri, 16 November 2007 03:02 Go to previous message
Gabriele Garuglieri is currently offline Gabriele Garuglieri
Messages: 44
Registered: July 2009
Member
Ok David, i've got it.
Sorry, i didn't understand it was 3.0. I was imagining it was a sort of
update to 2.0 and not the new 3.0 development line.

Thanks, Gabriele
Previous Topic:JEM: Introducing additional jars to a bean proxy factory classpath
Next Topic:Re: EMF Model Synchrinization with Multipage Editor (Tree based Editor and Text Editor)
Goto Forum:
  


Current Time: Thu Aug 28 09:17:37 EDT 2014

Powered by FUDForum. Page generated in 0.01966 seconds