Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Problem with GDB arm debugging(When debugging is started eclipse throws an error)
Problem with GDB arm debugging [message #1235335] Thu, 23 January 2014 23:53 Go to next message
Hoxford B is currently offline Hoxford B
Messages: 3
Registered: January 2014
Junior Member
I am attempting to debug a simple arm based c project. I keep getting a pop up error window containing the following error when ever I attempt to debug the program:
Error
Exception occurred during launch
Reason:
Error within Debug UI:
java.lang.reflect.InvocationTargetException

See attached file for full error log.
The target I am attempting to debug is the STM32F4_Discovery board. I am using GNU Arm tools to build the project, ST-Util or OpenOCD for the target gdb server, and GNU's arm-none-eabi-gdb for debugging.

Focusing on how I set up my external tool for the target gdb server I am using the following settings:
Location: dirpath\st-util.exe
Arguments: -m , so the gdb server wont quit, I get the same error with out the argument.

For debugging I am using the following settings:
GDB Hardware Debugging
GDB Command: arm-none-eabi-gdb
Remote Target: Generic TCP/IP localhost 4242
Startup: UN-checked Reset and Halt, added the command: monitor reset halt, unchecked Set program counter at, checked Set breakpoint at main, unchecked Resume, added the command continue
Using Standard GDB Hardware Debugging Launcher
Unchecked Launch in backgound under the common tab.

ANY help with this problem would be much appreciated. I feel I have scoured the internet to no avail with assistance with this problem. Thanks in advance.

Re: Problem with GDB arm debugging [message #1235495 is a reply to message #1235335] Fri, 24 January 2014 09:04 Go to previous messageGo to next message
Marc Khouzam is currently offline Marc Khouzam
Messages: 274
Registered: July 2009
Senior Member
Try the latest GDB hardware debugging. It looks like you are using the old one.
Following these instructions, choose "GDB (DSF) Hardware Debugging Launcher" instead of "Standard GDB Hardware Debugging Launcher"
http://wiki.eclipse.org/CDT/User/FAQ#How_can_I_choose_another_debugger_integration_for_CDT.3F

Marc
Re: Problem with GDB arm debugging [message #1235593 is a reply to message #1235495] Fri, 24 January 2014 13:57 Go to previous messageGo to next message
Hoxford B is currently offline Hoxford B
Messages: 3
Registered: January 2014
Junior Member
Oh my gosh, it worked, thanks Marc.
Every site I went to told me to use the Standard GDB hardware debugging over DSF-GDB. Thanks much. I plan to come back to this thread if this procedure potentially fails over time. Thanks again,

-Matt
Re: Problem with GDB arm debugging [message #1235633 is a reply to message #1235593] Fri, 24 January 2014 16:20 Go to previous message
Marc Khouzam is currently offline Marc Khouzam
Messages: 274
Registered: July 2009
Senior Member
I've opened http://eclip.se/426586 to rename the "standard" launch to something else since it is no longer 'standard' Smile
Previous Topic:Cant get builder to work in C
Next Topic:Problem with JFace!
Goto Forum:
  


Current Time: Sat Aug 23 01:46:43 EDT 2014

Powered by FUDForum. Page generated in 0.01980 seconds