Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Drag and drop into the SSE
Drag and drop into the SSE [message #200434] Mon, 24 September 2007 21:31 Go to next message
Brian Jakubik is currently offline Brian JakubikFriend
Messages: 140
Registered: July 2009
Senior Member
On the Europa release, when I drag and drop in the editor from the
navigator, It inserts it one less than where I drop it,

for example I start with:
<test id="test1"></test>

dnd from the navigator and dropping after the last > will give me
<test id="test1"></test"WebContent/NewFile4.xml">

this is what I expected (works in 1.x):
<test id="test1"></test>"WebContent/NewFile4.xml"

In 1.x of WTP I saw the expected behavior. Is this working as designed
or a bug. If the latter, let me know and Ill write it up.

Brian Jakubik
Re: Drag and drop into the SSE [message #200474 is a reply to message #200434] Tue, 25 September 2007 08:55 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 2337
Registered: July 2009
Senior Member
Brian Jakubik wrote:
> On the Europa release, when I drag and drop in the editor from the
> navigator, It inserts it one less than where I drop it,
>
> for example I start with:
> <test id="test1"></test>
>
> dnd from the navigator and dropping after the last > will give me
> <test id="test1"></test"WebContent/NewFile4.xml">
>
> this is what I expected (works in 1.x):
> <test id="test1"></test>"WebContent/NewFile4.xml"
>
> In 1.x of WTP I saw the expected behavior. Is this working as designed
> or a bug. If the latter, let me know and Ill write it up.

It works fine with 3.4 M2, so strangely there was a change in
behavior in the base that fixes the problem for us but which doesn't
seem to affect the default drag and drop support either way. Our
own DND classes haven't been touched since before 2.0 was released,
but changes in when StyledText.getOffsetAtLocation(Point) throws
Exceptions might be responsible. Please open a bug, but it's not
catastrophic enough for 2.0.1 at this point.

--
Nitin Dahyabhai
Structured Source Editing


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Drag and drop into the SSE [message #200632 is a reply to message #200474] Wed, 26 September 2007 16:12 Go to previous message
Brian Jakubik is currently offline Brian JakubikFriend
Messages: 140
Registered: July 2009
Senior Member
Thanks Nitin, Bug 204703 has been added to the database.

Nitin Dahyabhai wrote:
> Brian Jakubik wrote:
>> On the Europa release, when I drag and drop in the editor from the
>> navigator, It inserts it one less than where I drop it,
>>
>> for example I start with:
>> <test id="test1"></test>
>>
>> dnd from the navigator and dropping after the last > will give me
>> <test id="test1"></test"WebContent/NewFile4.xml">
>>
>> this is what I expected (works in 1.x):
>> <test id="test1"></test>"WebContent/NewFile4.xml"
>>
>> In 1.x of WTP I saw the expected behavior. Is this working as designed
>> or a bug. If the latter, let me know and Ill write it up.
>
> It works fine with 3.4 M2, so strangely there was a change in behavior
> in the base that fixes the problem for us but which doesn't seem to
> affect the default drag and drop support either way. Our own DND
> classes haven't been touched since before 2.0 was released, but changes
> in when StyledText.getOffsetAtLocation(Point) throws Exceptions might be
> responsible. Please open a bug, but it's not catastrophic enough for
> 2.0.1 at this point.
>
> --
> Nitin Dahyabhai
> Structured Source Editing
Previous Topic:Completion XML schema
Next Topic:log4j.properties missing from exported war file
Goto Forum:
  


Current Time: Thu Nov 27 21:06:09 GMT 2014

Powered by FUDForum. Page generated in 0.01608 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software