Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Linux testexec check selection always return true(Linux testexec check selection always return true - even if it is not)
Linux testexec check selection always return true [message #1229457] Thu, 09 January 2014 13:38 Go to next message
Dirk Willert is currently offline Dirk Willert
Messages: 22
Registered: January 2014
Junior Member
Hello, I have the following problem with testexec under Linux (see screenshot ) with
testexec under Windows eweryting works fine.
Under Linux utb_checkSelection (true) always returns true but nothing is selected
How can I fix this Problem in Linux ? Our build Management works under Linux.


Regards
Dirkindex.php/fa/17192/0/
Re: Linux testexec check selection always return true [message #1229761 is a reply to message #1229457] Fri, 10 January 2014 06:52 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

Could you say what type of application it is you're testing, on what windowing system and what linux distrubution and version? Is there anything in the logs? What happens if you execute a small test suite on linux that e.g.
- checks that a selected checkbox is selected (expected result: pass)
- checks that a selected checkbox is *not* selected (expected result: fail)
- checks that a non-selected checkbox *is* selected (expected result: fail)
- checks that a non-selected checkbox is not selected (expected result: pass)

Thanks for any information you can provide.
Alex
Re: Linux testexec check selection always return true [message #1229816 is a reply to message #1229761] Fri, 10 January 2014 09:34 Go to previous messageGo to next message
Dirk Willert is currently offline Dirk Willert
Messages: 22
Registered: January 2014
Junior Member
Hi,

it is a swing application and the IDE is running under windows 7 64Bit. The AUT is running under suse Linux Enterprise Server 11

If I use the IDE under windows, everything works as expected:

index.php/fa/17195/0/

But if I use textexec under Linux, this is the result:

index.php/fa/17199/0/


Dirk

[Updated on: Fri, 10 January 2014 09:39]

Report message to a moderator

Re: Linux testexec check selection always return true [message #1234246 is a reply to message #1229816] Tue, 21 January 2014 14:35 Go to previous messageGo to next message
Dirk Willert is currently offline Dirk Willert
Messages: 22
Registered: January 2014
Junior Member
The Problem occurs, when I using testexec unter Linux. With testexec or IDE under Windows everything works fine (as exspected above).

Regards
Dirk
Re: Linux testexec check selection always return true [message #1235376 is a reply to message #1234246] Fri, 24 January 2014 07:32 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Does the problem also occur when you start the test from the IDE on Linux?
Re: Linux testexec check selection always return true [message #1235461 is a reply to message #1235376] Fri, 24 January 2014 12:32 Go to previous messageGo to next message
Dirk Willert is currently offline Dirk Willert
Messages: 22
Registered: January 2014
Junior Member
No, in the IDE on Linux it works.

Regards,
Dirk
Re: Linux testexec check selection always return true [message #1236867 is a reply to message #1235461] Tue, 28 January 2014 09:08 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
That is indeed incredibly confusing. I know from other forum posts that you have different versions and different AUT configurations. Could you check whether it is exactly the same version and same AUT configuration running on Linux when you run the test from the ITE and from testexec? Can you post the HTML report for both?

Thanks!
Alex
Re: Linux testexec check selection always return true [message #1236990 is a reply to message #1236867] Tue, 28 January 2014 15:19 Go to previous messageGo to next message
Dirk Willert is currently offline Dirk Willert
Messages: 22
Registered: January 2014
Junior Member
Yes, it takes a litle time to find out, which configuration works with Linux and Windows.
Now I have actual one Version of a project configuration, which works under Windows and Linux. So the changes in the config files are only the server on which the AUT runs. The result in Windows and Linux ITE is as expected ok, but whith testexec it Fails.
Here a short description of my test. I have two environment variables TEST_UDV_SRV_DOXIS4_CSB_NODE=false and TEST_UDV_SRV_SSL=true. These are the values of the checkboxes after the test. After pressing "New" in the Dialog all fields are empty as you can see in the screenshots, and nothing is checked. Now I use ub_btn_checkSelection whith property SELECTED with the value of the environment variable. If it is equal, then nothing to do, if not, then use the event handler and click one time in the control. That's all and it works fine with the ITE's

Regard's
Dirk
Re: Linux testexec check selection always return true [message #1238026 is a reply to message #1236990] Fri, 31 January 2014 07:37 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

If I understand correctly, after the test, the CSB checbox should be unchecked and the SSL checkbox should be checked - right?
I can see that in the ITE test, the check selection for the SSL checkbox fails (due to it being unchecked) then succeeds on retry. In the testexec test, the check for the state of the SSL checkbox succeeds - since it is "selected" already.

I think I'm starting to understand the problem, but I still don't know where it could come from. I'll ask around.

Best regards,
Alex
Re: Linux testexec check selection always return true [message #1239086 is a reply to message #1238026] Mon, 03 February 2014 10:16 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Can you also say what Java version you are using?
Re: Linux testexec check selection always return true [message #1239444 is a reply to message #1239086] Tue, 04 February 2014 08:06 Go to previous message
Dirk Willert is currently offline Dirk Willert
Messages: 22
Registered: January 2014
Junior Member
Java Version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java Hotspot(TM) 64-Bit Server VM (build 20.1-b.02, mixed mode)
Previous Topic:Can Jubula/testexec work with Xvnc ?
Next Topic:Jira connection from Jubula stand-alone?
Goto Forum:
  


Current Time: Thu Oct 23 20:52:58 GMT 2014

Powered by FUDForum. Page generated in 0.02950 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software