Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse IDE shows ">" at every indentation.
icon9.gif  Eclipse IDE shows ">" at every indentation. [message #1229031] Wed, 08 January 2014 15:20 Go to next message
Htwe Htwe kyaing is currently offline Htwe Htwe kyaingFriend
Messages: 2
Registered: January 2014
Junior Member
Eclipse IDE shows ">" at every indentation. Please refer to attached picture.

Every time I press tab, ">" is showing in my project.

My eclipse version is 3.7.2 and using "PHP perspective".

How can I solve it?


P.S
I already tried this 2 ways.

(1)
Window -> Preferences -> General -> Editors -> Text Editors
Turn off "Show whitespace characters" option.

(2)
Window -> Preferences -> General -> Editors -> Text Editors
Turn on "Insert spaces for tabs".

Regards;







Re: Eclipse IDE shows ">" at every indentation. [message #1229128 is a reply to message #1229031] Wed, 08 January 2014 19:36 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2360
Registered: July 2009
Senior Member
The "show whitespace characters" setting controls this for most editors I've used, such as the Java editor. Perhaps there is a PHP-specific editor setting that is separate from the general Text Editors one; did you look under the PHP section of Preferences?
Re: Eclipse IDE shows ">" at every indentation. [message #1229454 is a reply to message #1229031] Thu, 09 January 2014 13:34 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 355
Registered: July 2009
Location: Japan
Senior Member
As you can see at the dialog linked from Preferences->General->Editors->Text Editors->Show whitespace characters, Eclipse uses "≫", "¶" or so as whitespaces.
Your screenshot is different from Eclipse.
I'm guessing you must have a third party plugin such as JStyle for example. Have a look at Preferences->General->JStyle if it is there.
icon14.gif  Re: Eclipse IDE shows ">" at every indentation. [message #1229498 is a reply to message #1229454] Thu, 09 January 2014 15:15 Go to previous message
Htwe Htwe kyaing is currently offline Htwe Htwe kyaingFriend
Messages: 2
Registered: January 2014
Junior Member
Hello, Eric Rizzo and Toshihiro Izumi


Thank you for your reply post.

I now checked my eclipse setting as Toshihiro Izumi's post and it is useful for me.

I just turn off => Preferences->General->JStyle-> ...(T). (Please refer attached file) Smile



Regards;
  • Attachment: JStyle.png
    (Size: 93.47KB, Downloaded 39 times)
Previous Topic:Which Eclipse
Next Topic:Error while running c++ program in eclipse juno.
Goto Forum:
  


Current Time: Mon Nov 24 00:16:08 GMT 2014

Powered by FUDForum. Page generated in 0.02815 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software