Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Exception while opening a non existing resource or resource from a closed project(org.eclipse.swt.SWTException: Widget is disposed while opening non existing resource)
Exception while opening a non existing resource or resource from a closed project [message #1228984] Wed, 08 January 2014 13:33
sajja Phani is currently offline sajja PhaniFriend
Messages: 26
Registered: August 2011
Junior Member

I am getting the following exception while trying to open a non existing resource with API

org.eclipse.swt.SWTException: Widget is disposed
	at org.eclipse.swt.SWT.error(
	at org.eclipse.swt.SWT.error(
	at org.eclipse.swt.SWT.error(
	at org.eclipse.swt.widgets.Widget.error(
	at org.eclipse.swt.widgets.Widget.checkWidget(
	at org.eclipse.swt.widgets.Control.setFocus(
	at org.eclipse.swt.widgets.Composite.setFocus(
	at org.eclipse.swt.widgets.Composite.setFocus(
	at org.eclipse.ui.texteditor.StatusTextEditor.setFocus(
	at com.example.rcp.editor.CustomTextEditor.setFocus(
	at org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.delegateSetFocus(

In earlier versions of eclipse it is working fine by opening a non editable editor with message 'Resource '.../ does not exists.'. This is especially occurring in 4.x, it is working as expected but logging the above specified exception.

What might cause this exception to be logged.

Previous Topic:Using Java mail API in RCP application
Next Topic:Load View in View or load Views in TabbedPane
Goto Forum:

Current Time: Fri Oct 09 23:57:22 GMT 2015

Powered by FUDForum. Page generated in 0.03042 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software