Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » update conflicts
update conflicts [message #1227502] Sat, 04 January 2014 18:20 Go to next message
David M. Karr is currently offline David M. Karr
Messages: 353
Registered: July 2009
Senior Member
I've hit another occurrence of the typical perplexing update conflict.

I posted about this on StackOverflow (http://stackoverflow.com/questions/20924321/eclipse-update-conflict-with-polarion-subversive-connectors), but I'll try to provide some relevant details here.

I had the 3.0.x connectors installed. This morning I checked for update, and I see that it's prompting me to install 4.0.0 versions. The update list has multiple versions of JavaHL, Native JavaHL, SVNKit, and the base "Subversive SVN Connectors".

The error message says:

Quote:
Cannot complete the install because one or more required items could not be found.
Software being installed: Native JavaHL 1.8 Implementation (Optional) 4.0.0.I20131101-1700 (org.polarion.eclipse.team.svn.connector.javahl18.feature.group 4.0.0.I20131101-1700)
Missing requirement: Native JavaHL 1.8 Implementation (Optional) 4.0.0.I20131101-1700 (org.polarion.eclipse.team.svn.connector.javahl18.feature.group 4.0.0.I20131101-1700) requires 'org.eclipse.team.svn.feature.group [2.0.0.I20131101-1700,3.0.0)' but it could not be found


What needs to be done here?
Re: update conflicts [message #1227668 is a reply to message #1227502] Sun, 05 January 2014 07:08 Go to previous messageGo to next message
David M. Karr is currently offline David M. Karr
Messages: 353
Registered: July 2009
Senior Member
Never mind. I had the wrong set of update sites. I went back and made sure that I had the prescribed list of update sites for Kepler, and it no longer offered the update to a version 4.0.x plugin.
Re: update conflicts [message #1233428 is a reply to message #1227668] Sun, 19 January 2014 16:14 Go to previous message
Alexander Gurov is currently offline Alexander Gurov
Messages: 87
Registered: July 2009
Member
Hello David,

To be more precise the 4.0.x connectors now in development and it won't be possible to install them over Subversive 1.1.x since there are API changes. They're designed for the future Subversive 2.0 version.
Previous Topic:ROOT Directory
Next Topic:Can't install Kepler connectors
Goto Forum:
  


Current Time: Tue Sep 23 12:29:32 GMT 2014

Powered by FUDForum. Page generated in 0.03139 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software