Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Deleting files in "project explorer" doesn't remove them from that view
Deleting files in "project explorer" doesn't remove them from that view [message #199313] Sat, 01 September 2007 21:44
Vadim Dmitriev is currently offline Vadim DmitrievFriend
Messages: 74
Registered: July 2009
Member
Hi.

I searched the net and bugzilla, but haven't found anything related to my
problem.
To be short: sometimes deleting files in "project explorer" removes them
from file system, but not from view itself. At the same time in "package
explorer" view everything looks like it should be, no "fake" files.
If I try to delete such files again:

!ENTRY org.eclipse.ui.ide 4 3 2007-09-02 01:26:29.781
!MESSAGE Cannot complete operation because resources no longer exist.

Only closing/opening project helps.
To be sure - just before posting I created empty folder in /WebContents/
of dynamic web project and while trying to delete it got described error.
But this error don't relate strictly to empty folders. Occasionly I
expirience the same for ordinary files in \WebContent\ or in "Java
Resources" project's tree branch.

Maybe it is a know bug. If so, please, can you give me a link to it (or
related discussion)?
Thank you!

P.S. Env: Eclipse 3.3, WTP 2.0, WinXP SP2, Sun's JVM 1.5.0_12. (Also
checked on last maintenance builds of WTP (2.0.1) and Eclipse (3.3.1) ).
Previous Topic:Merging WEB resources from different source folders
Next Topic:Web App Deployment
Goto Forum:
  


Current Time: Mon Nov 24 12:40:49 GMT 2014

Powered by FUDForum. Page generated in 0.16441 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software