Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » org.eclipse.wst.rdb.* missing
org.eclipse.wst.rdb.* missing [message #199114] Wed, 29 August 2007 22:09 Go to next message
Eclipse UserFriend
Originally posted by: dkador.salesforce.com

Hi All,

I'm trying to do a headless PDE build of the plug-in I'm working on.
I've been able to successfully build a small HelloWorld plug-in and I
can build my plug-in from within Eclipse with no problems. However,
from the command line I'm getting lots of errors about inter-plug-in
dependencies not being satisfied. They are all related to different
components in org.eclipse.wst.rdb. I'll copy and paste in part of the
build log so you can see what's going on. It seems to me like these
could be invalid dependencies, but I'm not sure if that's actually the
case. In addition, I have no idea where I can find these plug-ins to
actually rectify the situation. I've downloaded the WST all-in-one
and that doesn't seem to contain these, and I've also downloaded the
WST JDK and that doesn't haveit either. I'm a little stumped here.
Any ideas?

generateFeature:
Some inter-plug-in dependencies have not
been satisfied. Bundle
org.eclipse.wst.rdb.connection.ui:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Bundle org.eclipse.wst.rdb.core.ui:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.models.dbdefinition_[1.0.101,1.1.0).
Bundle org.eclipse.wst.rdb.core:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.dbdefinition_[1.0.101,1.1.0).
Bundle org.eclipse.wst.rdb.data.core:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Bundle org.eclipse.wst.rdb.data.ui:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.data.core_[1.0.104,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.outputview_[1.0.104,1.1.0).
Bundle org.eclipse.wst.rdb.derby.ui:
Missing required plug-in
org.eclipse.wst.rdb.server.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.connection.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.derby_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Bundle org.eclipse.wst.rdb.derby:
Missing required plug-in
org.eclipse.wst.rdb.models.dbdefinition_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Bundle org.eclipse.wst.rdb.fe.ui.actions:
Missing required plug-in org.eclipse.wst.rdb.fe.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.server.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Bundle org.eclipse.wst.rdb.fe.ui:
Missing required plug-in
org.eclipse.wst.rdb.connection.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.server.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.sqleditor_[1.0.103,1.1.0).
Bundle
org.eclipse.wst.rdb.models.dbdefinition:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Bundle org.eclipse.wst.rdb.models.sql.edit:
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Bundle org.eclipse.wst.rdb.models.sql:
Missing required plug-in
org.eclipse.emf.ecore.sdo_[2.2.0,3.0.0).
Bundle org.eclipse.wst.rdb.mysql:
Missing required plug-in
org.eclipse.wst.rdb.models.dbdefinition_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Bundle org.eclipse.wst.rdb.outputview:
Missing required plug-in org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.data.core_[1.0.104,1.1.0).
Bundle
org.eclipse.wst.rdb.server.extensions:
Missing required plug-in org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.sqleditor_[1.0.103,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.outputview_[1.0.104,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.server.ui_[1.0.101,1.1.0).
Bundle org.eclipse.wst.rdb.server.ui:
Missing required plug-in
org.eclipse.wst.rdb.connection.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.dbdefinition_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.outputview_[1.0.104,1.1.0).
Bundle org.eclipse.wst.rdb.sqleditor:
Missing required plug-in
org.eclipse.wst.rdb.connection.ui_[1.0.101,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.server.ui_[1.0.101,1.1.0).
Bundle org.eclipse.wst.rdb.sqlscrapbook:
Missing required plug-in
org.eclipse.wst.rdb.sqleditor_[1.0.103,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.core_[1.0.106,1.2.0).
Missing required plug-in
org.eclipse.wst.rdb.core.ui_[1.0.102,1.1.0).
Missing required plug-in
org.eclipse.wst.rdb.models.sql_[1.0.102,1.1.0).
[eclipse.generateFeature] Missing required plug-in
org.eclipse.wst.rdb.server.ui_[1.0.101,1.1.0).

Thanks,
Dan


--

I'm trying a new usenet client for Mac, Nemo OS X.
You can download it at http://www.malcom-mac.com/nemo
Re: org.eclipse.wst.rdb.* missing [message #199240 is a reply to message #199114] Fri, 31 August 2007 01:33 Go to previous message
David Williams is currently offline David WilliamsFriend
Messages: 701
Registered: July 2009
Senior Member
On Wed, 29 Aug 2007 18:09:40 -0400, Daniel Kador <dkador@salesforce.com> wrote:

> .... I'm getting lots of errors about inter-plug-in
> dependencies not being satisfied. They are all related to different
> components in org.eclipse.wst.rdb. ....

These rdb plugins are distributed in WTP 1.5.x.

Assuming you are trying to build a WTP 2.0 based plugin, it sounds like some 1.5.x stuff has gotten mixed in? At least in your build environment.
Previous Topic:Japplet in builty in browser
Next Topic:JSP & HTML validators performance
Goto Forum:
  


Current Time: Mon Dec 22 03:04:57 GMT 2014

Powered by FUDForum. Page generated in 0.01694 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software