Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » Re: [buckminster-dev] Strange resolver behaviour when resolving PDE plugins - using "native&quo
Re: [buckminster-dev] Strange resolver behaviour when resolving PDE plugins - using "native&quo [message #18930] Wed, 28 May 2008 11:28
Mikhail Kadan is currently offline Mikhail Kadan
Messages: 61
Registered: July 2009
Member
------=_Part_12291_14245575.1211974084885
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi.

I've updated Buckminster an hour ago (it is "1.0.0.r09309" now) and I get
this error when I try to resolve "org.eclipse.search":

Errors and Warnings
[0002] : More then one version of component
org.eclipse.core.resources:osgi.bundle$3.3.1.R33x_v20080205# OSGi is known to
Buckminster
[0002] : More then one version of component
org.eclipse.ui:osgi.bundle$3.3.1.M20071128-0800#OSGi is known to Buckminster
[0002] : More then one version of component
org.eclipse.jface.text:osgi.bundle$3.3.2.r332_20071017-0800# OSGi is known to
Buckminster
[0002] : More then one version of component
org.eclipse.jface.text:osgi.bundle$3.3.2.r332_20071017-0800# OSGi is known to
Buckminster
[0002] : More then one version of component
org.eclipse.ui:osgi.bundle$3.3.1.M20071128-0800#OSGi is known to Buckminster

I looked in my target platform, but saw only one version of each of this
components. What's the problem?

Thanks.


2008/5/27, Thomas Hallgren <thomas@tada.se>:
>
> No, you should be able to use 3.3.x. But you need to update our Buckminster
> to the latest one. For some reason the mirroring is really slow today so
> it's not yet available.
>
> - thomas
>
> Mikhail Kadan wrote:
>
>>
>>
>> Hi Mikhail,
>> What platform are you using? Is it an Eclipse 3.3.x or 3.4.x? And
>> what is the version on your org.eclipse.buckminster.core.feature?
>>
>>
>> Hi.
>>
>> I use:
>>
>> Eclipse Platform
>> Version: 3.3.2
>> Build id: M20080221-1800
>>
>> org.eclipse.buckminster.core.feature 1.0.0.r09178
>>
>> On that link (post #10)
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=229930 I read it has a bug
>> in PDE concerning my issue :-) Do I have to revert to Eclipse 3.3.1 or even
>> earlier? I cannot use 3.4 version because our corporate policy doesn't allow
>> using unstable versions.
>>
>> Thanks.
>> ------------------------------------------------------------ ------------
>>
>> _______________________________________________
>> buckminster-dev mailing list
>> buckminster-dev@eclipse.org
>> https://dev.eclipse.org/mailman/listinfo/buckminster-dev
>>
>>
>
> _______________________________________________
> buckminster-dev mailing list
> buckminster-dev@eclipse.org
> https://dev.eclipse.org/mailman/listinfo/buckminster-dev
>

------=_Part_12291_14245575.1211974084885
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Hi.<br><br>I&#39;ve updated Buckminster an hour ago (it is &quot;1.0.0.r09309&quot; now) and I get this error when I try to resolve &quot;org.eclipse.search&quot;:<br><br>Errors and Warnings<br> [0002] : More then one version of component org.eclipse.core.resources:osgi.bundle$3.3.1.R33x_v20080205# OSGi is known to Buckminster<br>
[0002] : More then one version of component org.eclipse.ui:osgi.bundle$3.3.1.M20071128-0800#OSGi is known to Buckminster<br> [0002] : More then one version of component org.eclipse.jface.text:osgi.bundle$3.3.2.r332_20071017-0800# OSGi is known to Buckminster<br>
[0002] : More then one version of component org.eclipse.jface.text:osgi.bundle$3.3.2.r332_20071017-0800# OSGi is known to Buckminster<br> [0002] : More then one version of component org.eclipse.ui:osgi.bundle$3.3.1.M20071128-0800#OSGi is known to Buckminster<br>
<br>I looked in my target platform, but saw only one version of each of this components. What&#39;s the problem?<br><br>Thanks.<br><br><br><div><span class="gmail_quote">2008/5/27, Thomas Hallgren &lt;<a href="mailto:thomas@tada.se">thomas@tada.se</a>&gt;:</span><blockquote class="gmail_quote" style="margin-top: 0; margin-right: 0; margin-bottom: 0; margin-left: 0; margin-left: 0.80ex; border-left-color: #cccccc; border-left-width: 1px; border-left-style: solid; padding-left: 1ex">
No, you should be able to use 3.3.x. But you need to update our Buckminster to the latest one. For some reason the mirroring is really slow today so it&#39;s not yet available.<br><br> - thomas<br><br> Mikhail Kadan wrote:<br>
<blockquote class="gmail_quote" style="margin-top: 0; margin-right: 0; margin-bottom: 0; margin-left: 0.80ex; border-left-color: #cccccc; border-left-width: 1px; border-left-style: solid; padding-left: 1ex"><div><span class="e" id="q_11a2ad6fb5ed3e4e_1"><br>
<br> &nbsp; &nbsp;Hi Mikhail,<br> &nbsp; &nbsp;What platform are you using? Is it an Eclipse 3.3.x or 3.4.x? And<br> &nbsp; &nbsp;what is the version on your org.eclipse.buckminster.core.feature?<br><br><br> Hi.<br><br> I use:<br><br> Eclipse Platform<br>
Version: 3.3.2<br> Build id: M20080221-1800<br><br> org.eclipse.buckminster.core.feature 1.0.0.r09178<br><br> On that link (post #10) <a href="https://bugs.eclipse.org/bugs/show_bug.cgi?id=229930" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">https://bugs.eclipse.org/bugs/show_bug.cgi?id=229930</a> I read it has a bug in PDE concerning my issue :-) Do I have to revert to Eclipse 3.3.1 or even earlier? I cannot use 3.4 version because our corporate policy doesn&#39;t allow using unstable versions.<br>
<br> Thanks.<br></span></div><span class="q"> ------------------------------------------------------------ ------------ <br><br> _______________________________________________<br> buckminster-dev mailing list<br><a href="mailto:buckminster-dev@eclipse.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">buckminster-dev@eclipse.org</a><br>
<a href="https://dev.eclipse.org/mailman/listinfo/buckminster-dev" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">https://dev.eclipse.org/mailman/listinfo/buckminster-dev</a><br> &nbsp;<br></span></blockquote>
<div><span class="e" id="q_11a2ad6fb5ed3e4e_4"><br> _______________________________________________<br> buckminster-dev mailing list<br><a href="mailto:buckminster-dev@eclipse.org" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">buckminster-dev@eclipse.org</a><br>
<a href="https://dev.eclipse.org/mailman/listinfo/buckminster-dev" target="_blank" onclick="return top.js.OpenExtLink(window,event,this)">https://dev.eclipse.org/mailman/listinfo/buckminster-dev</a><br></span></div></blockquote>
</div><br>

------=_Part_12291_14245575.1211974084885--
Previous Topic:Re: [buckminster-dev] Strange resolver behaviour when resolving PDE plugins - using "native&quo
Next Topic:Re: [buckminster-dev] Strange resolver behaviour when resolving PDE plugins - using "native&quo
Goto Forum:
  


Current Time: Thu Sep 18 22:02:19 GMT 2014

Powered by FUDForum. Page generated in 0.05028 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software