Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Cannot start up web server(s) from eclipse
Cannot start up web server(s) from eclipse [message #1221960] Wed, 18 December 2013 21:14 Go to next message
Laura McCord is currently offline Laura McCordFriend
Messages: 5
Registered: December 2013
Junior Member
I just installed the new Eclipse Keplar version and I'm trying to set up a couple servers. One server is a Tomcat server and the other is a Pluto server.

I followed the directions by pointing to the source directories for each but when I start either of them up the console indicates they are started, yet when I try to go to localhost:8080 I get a 404 error. I know that after I configure one of the servers I see them under the "Servers" drop-down from the Project Explorer and each have a drop-down with catalina, context, server, and web.xml files. I'm wondering if somehow the context of the servers are breaking and that's why I'm getting a 404 because if it wasn't attempting to start the browser would indicate that going to localhost:8080 is not reachable.

If I start them up manually from the source directories they start up fine. I am able to run the Mongrel plugin without any issues from Eclipse and see that the tomcat instance starts but I'd like to set up more servers using the Server type.

Any suggestions?

Thanks
Re: Cannot start up web server(s) from eclipse [message #1222034 is a reply to message #1221960] Wed, 18 December 2013 22:16 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry IsaacsFriend
Messages: 1310
Registered: July 2009
Senior Member
On 12/18/2013 4:14 PM, Laura McCord wrote:
> I just installed the new Eclipse Keplar version and I'm trying to set up
> a couple servers. One server is a Tomcat server and the other is a Pluto
> server.
>
> I followed the directions by pointing to the source directories for each
> but when I start either of them up the console indicates they are
> started, yet when I try to go to localhost:8080 I get a 404 error. I
> know that after I configure one of the servers I see them under the
> "Servers" drop-down from the Project Explorer and each have a drop-down
> with catalina, context, server, and web.xml files. I'm wondering if
> somehow the context of the servers are breaking and that's why I'm
> getting a 404 because if it wasn't attempting to start the browser would
> indicate that going to localhost:8080 is not reachable.
>
> If I start them up manually from the source directories they start up
> fine. I am able to run the Mongrel plugin without any issues from
> Eclipse and see that the tomcat instance starts but I'd like to set up
> more servers using the Server type.
>
> Any suggestions?
>
> Thanks

For Tomcat in Web Tools, the server instance that is created by default
has no built in content. Unless you have added a project to the server
and tried to access content in that project, 404 is normal. For details,
see the Tomcat FAQ[1]

Cheers,
Larry

[1] http://wiki.eclipse.org/WTP_Tomcat_FAQ
Re: Cannot start up web server(s) from eclipse [message #1222525 is a reply to message #1222034] Fri, 20 December 2013 17:14 Go to previous message
Laura McCord is currently offline Laura McCordFriend
Messages: 5
Registered: December 2013
Junior Member
Thanks Larry, for pointing out the FAQ link. I did test and my test application did run on those server entries.
Previous Topic:Open web page programmatically
Next Topic:Deployment issue from glassfish 4.0 using eclipse plug-in
Goto Forum:
  


Current Time: Sun Nov 23 07:35:31 GMT 2014

Powered by FUDForum. Page generated in 0.01953 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software