Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Yet Another Install Problem(Can't install e(fx)clipse )
Yet Another Install Problem [message #1220866] Sat, 14 December 2013 20:56 Go to next message
Sean McElroy is currently offline Sean McElroyFriend
Messages: 3
Registered: December 2013
Junior Member
Hello,

I'm trying to install e(fx)clipse and I'm getting this error:

Software being installed: e(fx)clipse - IDE - Juno/Indigo 0.9.0.201312110809 (org.eclipse.fx.ide.all.prekepler.feature.feature.group 0.9.0.201312110809)
Missing requirement: e(fx)clipse - IDE - RRobot 0.9.0.201312110809 (org.eclipse.fx.ide.rrobot.feature.feature.group 0.9.0.201312110809) requires 'org.eclipse.xtend.sdk.feature.group 2.4.2' but it could not be found
Cannot satisfy dependency:
From: e(fx)clipse - IDE - Kepler 0.9.0.201312110809 (org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201312110809)
To: org.eclipse.fx.ide.rrobot.feature.feature.group [0.9.0.201312110809]
Cannot satisfy dependency:
From: e(fx)clipse - IDE - Juno/Indigo 0.9.0.201312110809 (org.eclipse.fx.ide.all.prekepler.feature.feature.group 0.9.0.201312110809)
To: org.eclipse.fx.ide.all.kepler.feature.feature.group [0.9.0.201312110809]

I am using Indigo SR2 and Java jdk1.7.0_45
Re: Yet Another Install Problem [message #1220891 is a reply to message #1220866] Sun, 15 December 2013 16:24 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5468
Registered: July 2009
Senior Member
The error says that the xtext dependency is NOT satisfied. You need to
add the xtext update site explicitly on Indigo.

From other thread of today it looks this is not the only problem you'll
encounter in Indigo/Juno. I'd suggest you use Kepler as the base
Eclipse, although in theory e(fx)clipse could get run on Indigo/Juno we
are not testing this regularly.

Is there a reason you use Indigo?

Tom

On 14.12.13 22:49, Sean McElroy wrote:
> Hello,
>
> I'm trying to install e(fx)clipse and I'm getting this error:
>
> Software being installed: e(fx)clipse - IDE - Juno/Indigo
> 0.9.0.201312110809
> (org.eclipse.fx.ide.all.prekepler.feature.feature.group 0.9.0.201312110809)
> Missing requirement: e(fx)clipse - IDE - RRobot 0.9.0.201312110809
> (org.eclipse.fx.ide.rrobot.feature.feature.group 0.9.0.201312110809)
> requires 'org.eclipse.xtend.sdk.feature.group 2.4.2' but it could not be
> found
> Cannot satisfy dependency:
> From: e(fx)clipse - IDE - Kepler 0.9.0.201312110809
> (org.eclipse.fx.ide.all.kepler.feature.feature.group 0.9.0.201312110809)
> To: org.eclipse.fx.ide.rrobot.feature.feature.group
> [0.9.0.201312110809]
> Cannot satisfy dependency:
> From: e(fx)clipse - IDE - Juno/Indigo 0.9.0.201312110809
> (org.eclipse.fx.ide.all.prekepler.feature.feature.group 0.9.0.201312110809)
> To: org.eclipse.fx.ide.all.kepler.feature.feature.group
> [0.9.0.201312110809]
>
> I am using Indigo SR2 and Java jdk1.7.0_45
Re: Yet Another Install Problem [message #1220940 is a reply to message #1220891] Mon, 16 December 2013 09:34 Go to previous messageGo to next message
Sean McElroy is currently offline Sean McElroyFriend
Messages: 3
Registered: December 2013
Junior Member
Hi Tom,

The only reason I'm using Indigo is because I have it installed. Kepler it is then.

Thanks,
Sean
Re: Yet Another Install Problem [message #1220943 is a reply to message #1220940] Mon, 16 December 2013 09:38 Go to previous message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 5468
Registered: July 2009
Senior Member
Right you are much safer going with Kepler because this where we develop
in and for. 0.9.0 will target Kepler and 1.0.0 will target Luna (while
we are trying to stay compatible with Kepler).

For an easy start you could use the nighlty builds available at
http://downloads.efxclipse.bestsolution.at/downloads/nightly/sdk.

Tom

On 16.12.13 10:34, Sean McElroy wrote:
> Hi Tom,
>
> The only reason I'm using Indigo is because I have it installed. Kepler
> it is then.
>
> Thanks,
> Sean
Previous Topic:Install problem
Next Topic:e(fx)clipse target platform distribution
Goto Forum:
  


Current Time: Thu Nov 27 13:47:58 GMT 2014

Powered by FUDForum. Page generated in 0.03279 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software