Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » No Euro Symbol
No Euro Symbol [message #1220747] Fri, 13 December 2013 06:40 Go to next message
Marina Orth is currently offline Marina Orth
Messages: 36
Registered: September 2012
Member
Hello,

i'm trying something like this:

select "€" from dual. The result looks like that: ¬. So replace ¬ with €, and all is good. If i choose a text element and set text to "€" all is good.

Now i want to do this:
select text from table. With text = "hello world. pay with €". The result is looking like that "hello world. pay with ". The euro symbol is not visible...

One other thing: there is a parameter called euro. birt report viewer is integrated in other software. in this software i set parameter euro as "test €" and render the report. result: "test ". The euro symbol is not visible too...

What can i do, to show proberly the € symbol?
Re: No Euro Symbol [message #1220832 is a reply to message #1220747] Fri, 13 December 2013 18:15 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1424
Registered: July 2009
Senior Member

Any way you can show me this issue in a sample report? If you have to use sample data other than the sample database, just use a flat file or scripted dataset.

Michael
Actuate – The BIRT Company™

BIRT Developer Center
Check out the new, free BIRT Viewer Toolkit
Re: No Euro Symbol [message #1220926 is a reply to message #1220832] Mon, 16 December 2013 03:18 Go to previous messageGo to next message
Marina Orth is currently offline Marina Orth
Messages: 36
Registered: September 2012
Member
Hello,

i've tested what you said. For a scripted data source all is fine. For a flat file there's also no euro symbol. But no blank like before. There's a square now. See attached file.

Kind regards
  • Attachment: test.zip
    (Size: 2.47KB, Downloaded 14 times)
Re: No Euro Symbol [message #1222214 is a reply to message #1220926] Thu, 19 December 2013 17:59 Go to previous messageGo to next message
Michael Williams is currently offline Michael Williams
Messages: 1424
Registered: July 2009
Senior Member

For the flat file, if you change the encoding of the .txt file to utf-8, it works fine. So, this issue is happening only when coming from your JDBC database? Let me know. I'll have to try it out.

Michael
Actuate – The BIRT Company™

BIRT Developer Center
Check out the new, free BIRT Viewer Toolkit
Re: No Euro Symbol [message #1222339 is a reply to message #1220747] Fri, 20 December 2013 02:36 Go to previous message
Marina Orth is currently offline Marina Orth
Messages: 36
Registered: September 2012
Member
Hi,

for the flat file utf-8 is working. So yes, this issue is happening for jdbc-databases. What should i do?

Kind regards
Previous Topic:Crosstab hiding of columns and rows does not reflect when export to excel/pdf
Next Topic:Empty pie chart
Goto Forum:
  


Current Time: Fri Apr 25 02:50:12 EDT 2014

Powered by FUDForum. Page generated in 0.04984 seconds