Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » PHP formatter inserts unwanted whitespace in web pages
PHP formatter inserts unwanted whitespace in web pages [message #1219919] Fri, 06 December 2013 18:26 Go to next message
Hendrik Maryns is currently offline Hendrik MarynsFriend
Messages: 31
Registered: July 2009
Member
Hi all, I was refered here from e.newcomer with the following question:

Because the server my website is on does not support SSI, but does
support php, all my web pages are .php, although they are mainly html
with just an occasional <?php include. Anyway, it is thus opened with
the php editor (I think), which started introducing a space after each
html tag a while ago, even when this is unwanted, e.g. after <a>. How
can I change this back?

Example:
===============
<li>
<a
href="Wiskunde/Stattiestiek/pdfs/toets 2 stattiestiek 9A 2011.pdf"
title="toets stattiestiek en misleiden" type="application/pdf">Toets
statistiek en misleiden</a>
, gebaseerd op Getal en Ruimte en toets van Bart (
<a type="text/x-tex"
href="Wiskunde/Stattiestiek/bronbestanden/toets 2 stattiestiek 9A
2011.tex"
title="TeX-bronbestant voor toets">TeX-bronbestand</a>
).

Note the unwanted spaces and linebreaks before and after <a> which is
immediately followed by , or ) or preceded by (

Cheers, H.
--
Hendrik Maryns
http://hendrikmaryns.name
===========
signature.asc?!?
http://en.wikipedia.org/wiki/PGP
http://mindprod.com/project/mailreadernewsreader.html
Re: PHP formatter inserts unwanted whitespace in web pages [message #1219941 is a reply to message #1219919] Sat, 07 December 2013 01:34 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro IzumiFriend
Messages: 356
Registered: July 2009
Location: Japan
Senior Member
The only case I can reproduce such a formatting is...
Preferences->Web->HTML Files->Editor, remove all 'Inline Elements'.

Before:
index.php/fa/16956/0/
After - by default:
index.php/fa/16957/0/
After - configuring preferences:
index.php/fa/16958/0/

[Updated on: Sat, 07 December 2013 01:35]

Report message to a moderator

Re: PHP formatter inserts unwanted whitespace in web pages [message #1220532 is a reply to message #1219941] Thu, 12 December 2013 11:47 Go to previous message
Hendrik Maryns is currently offline Hendrik MarynsFriend
Messages: 31
Registered: July 2009
Member
Hi,

Op 07-12-13 02:34, schreef Toshihiro Izumi:
> The only case I can reproduce such a formatting is...
> Preferences->Web->HTML Files->Editor, remove all 'Inline Elements'.

I have no ‘Editor’ option there, since I do not have the HTML editor
installed. I use the PHP editor.

Cheers, H.
--
Hendrik Maryns
http://hendrikmaryns.name
===========
signature.asc?!?
http://en.wikipedia.org/wiki/PGP
http://mindprod.com/project/mailreadernewsreader.html
Previous Topic:Eclipse crashes
Next Topic:An error occurred while automatically activating bundle org.eclipse.php.debug.core
Goto Forum:
  


Current Time: Fri Nov 28 17:31:29 GMT 2014

Powered by FUDForum. Page generated in 0.01594 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software