Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Exporting Feature-based Product
Exporting Feature-based Product [message #1219912] Fri, 06 December 2013 16:52 Go to next message
Carlo Mor is currently offline Carlo Mor
Messages: 2
Registered: December 2013
Junior Member
Hello to all
I'm trying to figure out how to create an eclipse based rcp application for the management of the project of my society.
Right now i'm trying to create the base feature-based application in order to add and update functionality through p2 framework.
Actually, i stopped in the exporting process. The application runs correctly in the eclipse environment, but fail to start once deployed in the os.

Java states "error 13" and the log states:
SESSION Fri Dec 06 17:51:04 CET 2013 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2013-12-06 17:51:04.711
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.RuntimeException: Could not find framework
at org.eclipse.equinox.launcher.Main.getBootPath(Main.java:992)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:571)
at org.eclipse.equinox.launcher.Main.run(Main.java:1450)


Another, more complex project, plugin based, run flawlessly.
Any idea about?
Re: Exporting Feature-based Product [message #1220068 is a reply to message #1219912] Mon, 09 December 2013 13:06 Go to previous messageGo to next message
Sopot Cela is currently offline Sopot Cela
Messages: 597
Registered: December 2010
Senior Member

Probably jvm related. Make sure it can find the jvm or supply it via the -vm arg. Also make sure it's the right 32-64 bit arch.
Re: Exporting Feature-based Product [message #1220087 is a reply to message #1220068] Mon, 09 December 2013 15:40 Go to previous message
Carlo Mor is currently offline Carlo Mor
Messages: 2
Registered: December 2013
Junior Member
The Virtual machine is correct. I tried to export a blank project, one configured as feature-based, one configurd as plugin based. No problem with the plugin based, not working the feature based.
Previous Topic:Can't find contributed HandledToolItem in MApplication
Next Topic:Creating a command line/no GUI application
Goto Forum:
  


Current Time: Fri Oct 31 11:33:48 GMT 2014

Powered by FUDForum. Page generated in 0.09683 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software