Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Eclipse Application performace issues Windows 8(Performace issues with RCP Application over Windows 8)
Eclipse Application performace issues Windows 8 [message #1219786] Thu, 05 December 2013 19:16 Go to next message
Jose Renato is currently offline Jose Renato
Messages: 11
Registered: February 2011
Junior Member
Hi everyone.

I have an Eclipse Application that works fine on almost every machine with a lot of different OS.

But, I have this one machine that has incredible performance problems.

The machine is a Dell Notebook with:
Intel Core i5-3337U CPU 1.80Ghz
6GB RAM
OS: Windows 8 Single Language

I'm using JAVA 1.6.0_45

The application usually takes less than 20 seconds to start in normal conditions. But, in this machine it takes more than 35 seconds.

And, when it is started, the views are very slow to be painted. Actually you can see the componente being panted.

I'm stuck, and don't know what else I can do

- I updated de JRE (was using 1.6.0_27)
- Disabled Antivirus
- Disabled Firewall
- Close other applications
- Increase the total memory allocated for JAVA
- Updated the GPU drivers (the allocated memory for it is 128mb)

Please, anyone can help me with that? I have to solve this.
Re: Eclipse Application performace issues Windows 8 [message #1220508 is a reply to message #1219786] Thu, 12 December 2013 09:17 Go to previous messageGo to next message
sumit singh is currently offline sumit singh
Messages: 131
Registered: October 2012
Location: Bangalore
Senior Member

Is this same eclipse is working properly in others PC.

Can you try to set following setting see if it works What are the best JVM settings for Eclipse
Re: Eclipse Application performace issues Windows 8 [message #1220992 is a reply to message #1220508] Mon, 16 December 2013 14:39 Go to previous message
Jose Renato is currently offline Jose Renato
Messages: 11
Registered: February 2011
Junior Member
Yes,

I already tried that from this exactly post, with no success.

Any other thoughts?
Previous Topic:Webstart , equinox launcher which parameters in JNLP file
Next Topic:Coolbar using Handler/Commands
Goto Forum:
  


Current Time: Fri Sep 19 09:52:43 GMT 2014

Powered by FUDForum. Page generated in 0.01710 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software