Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Can't install PDT under Linux (dependency issue)(PDT installation problem.)
Can't install PDT under Linux (dependency issue) [message #1219262] Tue, 03 December 2013 00:42 Go to next message
Peter Kuykendall is currently offline Peter Kuykendall
Messages: 2
Registered: December 2013
Junior Member
I'm new to Eclipse and PHP. I'm trying to install Eclipse and PDT as part of my effort to teach myself PHP.

Platform is Linux Mint 13 Maya.

Eclipse installed without issue.

I get this message when tring to install PDT from the "Help -> Install New Software.." menu.

Cannot complete the install because one or more required items could not be found.
Software being installed: PHP Development Tools (PDT) 3.1.2.201212211235 (org.eclipse.php.feature.group 3.1.2.201212211235)
Missing requirement: PDT Server UI Plug-in 3.1.2.201212211235 (org.eclipse.php.server.ui 3.1.2.201212211235) requires 'bundle org.eclipse.dltk.ui [4.0.0,5.0.0)' but it could not be found
Cannot satisfy dependency:
From: PHP Development Tools (PDT) 3.1.2.201212211235 (org.eclipse.php.feature.group 3.1.2.201212211235)
To: org.eclipse.php.server.ui [3.1.2.201212211235]

Any ideas?

Thanks - Pete
Re: Can't install PDT under Linux (dependency issue) [message #1219435 is a reply to message #1219262] Tue, 03 December 2013 20:38 Go to previous messageGo to next message
Peter Kuykendall is currently offline Peter Kuykendall
Messages: 2
Registered: December 2013
Junior Member
Update: I just downloaded Eclipse for Windows XP 32 bit and then installed PDT per the instructions. That went fine on that platform. It appears that the problem is limited to the Linux platform.
Re: Can't install PDT under Linux (dependency issue) [message #1219624 is a reply to message #1219435] Thu, 05 December 2013 01:14 Go to previous messageGo to next message
Toshihiro Izumi is currently offline Toshihiro Izumi
Messages: 351
Registered: July 2009
Location: Japan
Senior Member
For the installation,
1) Download eclipse 4.3.1(Kepler) from //www.eclipse.org/downloads, extract it, start eclipse.
2) Install PDT thru 'Install New Software' from preconfigured Kepler repository.(//download.eclipse.org/releases/kepler)
That's all. What kind of difficulty is there.
Even if you choosed the eclipse package in Ubuntu repository,(note that it is 3.7.2(Indigo) based)
1) Install eclipse with Software Manager or Package Manager, start eclipse.
2) Install PDT thru 'Install New Software' from preconfigured Indigo repository.(//download.eclipse.org/releases/indigo)
That's all. What kind of difficulty is there. Even though you'll get PDT 3.0.1 in this case.

>Software being installed: PHP Development Tools (PDT) 3.1.2.201212211235 (org.eclipse.php.feature.group 3.1.2.201212211235)
You are going to install PDT 3.1.2, and it is for/in Eclipse 3.8/4.2(Juno). You need to add Juno repository in 'Available Software Sites'.
If you had installed eclipse from Ubuntu repository and you had added the abandoned update site //download.eclipse.org/tools/pdt/updates/release (in accordance with the abandoned page //www.eclipse.org/pdt/downloads/), you'll encounter this dependency problem. Because it is wrong.
Re: Can't install PDT under Linux (dependency issue) [message #1231039 is a reply to message #1219624] Mon, 13 January 2014 17:19 Go to previous message
Sathish Kumar is currently offline Sathish Kumar
Messages: 1
Registered: January 2014
Junior Member
Try this http://download.eclipse.org/tools/pdt/updates/3.2-nightly
Previous Topic:Workspace is Self-replicating
Next Topic:add to the Code Assist for PHP Dev Tools?
Goto Forum:
  


Current Time: Thu Oct 23 12:27:23 GMT 2014

Powered by FUDForum. Page generated in 0.01750 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software