Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Beginner Help: Europa and Preview Server
Beginner Help: Europa and Preview Server [message #196053] Wed, 11 July 2007 14:57 Go to next message
Eclipse UserFriend
Originally posted by: sgilbert.occ.cccd.edu

Hi,
From reading the Europa release notes I got the impression that I could
use the built-in embedded Jetty Preview server to develop and view both
JSP and servlets (without installing an extra application server such as
Tomcat). If that's not possible, could someone let me know.

I'm trying to do the simplest thing that could possibly work, (Hello
World) and not having a lot of success. Here's what I've done:
1. Downloaded Europa for J2EE developers
2. Created a dynamic Web project
3. Selected J2EE Preview as the runtime with default configuration
4. Dynamic Web Module and Java 6 selected as Facets
5. Add a new JSP file (html markup) named index.jsp
6. When I run the JSP file, I get this error:

java.lang.NoClassDefFoundError:
org/apache/commons/el/ExpressionEvaluatorImpl

I can find this class inside the plugins directory in the appropriate jar
file, which makes me think that this is something I'm doing wrong in the
configuration.

In addition, I tried adding a "Hello World" servlet and the Preview server
was unable to find the class file.

Any help would be greatly appreciated.

--Steve
Re: Beginner Help: Europa and Preview Server [message #196184 is a reply to message #196053] Wed, 11 July 2007 20:18 Go to previous messageGo to next message
Angel Vera is currently offline Angel VeraFriend
Messages: 63
Registered: July 2009
Member

The only thing that comes to mind is if your project is Targeting the
correct runtime? You can check if your project is targeting the preview
server by going into the "properties" of the project and selecting the
"Targeted Runtime" tab, make sure that it points to the preview server.

sgilbert@occ.cccd.edu (Stephen Gilbert) wrote in
news:68ba846a64f9aa482b13ff829ec92a47$1@www.eclipse.org:

> ExpressionEvaluatorImpl
>


Regards,
--
Angel Vera
WTP Server Tools Developer
Re: Beginner Help: Europa and Preview Server [message #196207 is a reply to message #196184] Wed, 11 July 2007 20:55 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: sgilbert.occ.cccd.edu

Hi,
Thanks. Yes, it does seem to be targeting the correct server. In the
Libraries tab in the Java Build Path it has the J2EE Preview Server on
localhost. The server starts correctly, but seems to die (500 error) on
the error posted. It's kind of interesting to me that the apache jar files
(org.apache.commons.el...) don't seem to be referenced anywhere in the
Libraries. I'm assuming the Preview server does this "behind the scenes"?
I tried adding this as an external Jar and got the same error message.
(I'm still kind of trying to keep everything as simple as possible. I'm
following the "Hello World" instructions I found posted for GlassFish, but
just pointing to the Preview Server instead.)
--Steve
Re: Beginner Help: Europa and Preview Server [message #196293 is a reply to message #196207] Thu, 12 July 2007 12:13 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jens.ja-web.de

Stephen Gilbert wrote:
> Hi,
> Thanks. Yes, it does seem to be targeting the correct server. In the
> Libraries tab in the Java Build Path it has the J2EE Preview Server on
> localhost. The server starts correctly, but seems to die (500 error) on
> the error posted. It's kind of interesting to me that the apache jar
> files (org.apache.commons.el...) don't seem to be referenced anywhere in
> the Libraries. I'm assuming the Preview server does this "behind the
> scenes"? I tried adding this as an external Jar and got the same error
> message.

hello,

I got the same error.

workaround for me is:

Configure the "J2EE Preview at localhost" "Run" settings, go to the
classpath section and add the missing jars (so far org.apache.commons.el
and org.apache.jasper) as "User entries"

After doing that I can run simple JSP pages on the Preview server!

But I have other trouble in configuring JDNI database resources and
other environment settings :( Cannot figure out where to put them

Jens
Re: Beginner Help: Europa and Preview Server [message #196336 is a reply to message #196293] Thu, 12 July 2007 14:02 Go to previous message
Eclipse UserFriend
Originally posted by: sgilbert.occ.cccd.edu

Hi,

Thanks, that seems to work for me.

This looks like bug 181081 which is marked as closed. That should at least
partly fix the problem. I went and looked at the sources using the CVS
browser and it looks like the patch described there hasn't actually been
applied yet. I don't know how long it takes for those kinds of changes to
filter down, and I don't know if the change made there (adding
org.apache.jaspar) to the classpath will fix the JSP problem. It still
seems like the org.apache.commons.el will be missing.

I haven't gotten as far as the JNDI stuff, so I really am not of any help
there.

Thanks again.

--Steve
Previous Topic:requires plug-in "org.eclipse.wst.server.core (1.0.103)", or equivalent.
Next Topic:Servlet Faces SErvlet is not available
Goto Forum:
  


Current Time: Mon Dec 22 02:06:35 GMT 2014

Powered by FUDForum. Page generated in 0.01670 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software