Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Why the new publish delays ?
Why the new publish delays ? [message #194965] Tue, 26 June 2007 05:26 Go to next message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi everybody,

I noticed with some horror that in WTP2.0 RC4 there is a forced publishing delay
for JBoss and Jonas plugins. For a small sample app, it took before about one
second to publish, now 10 secs. A look in the JBoss antscript "jboss323.xml"
revealed this:

<project name="deployextension" default="deploy.j2ee.web" basedir=".">
===> <property name="pause.deploy" value="10" />
<property name="pause.undeploy" value="5" />
<target name="deploy.j2ee.web">
<jar destfile="${project.working.dir}/${module.name}.war">
<zipfileset dir="${module.dir}">
<include name="**/*.*" />
<exclude name="**/*.war" />
</zipfileset>
</jar>
<move file="${project.working.dir}/${module.name}.war"
todir="${server.publish.dir}" />
===> <sleep seconds="${pause.deploy}" />
</target>
...

Why this new pause ? To me it looked as a bad regressions at first glance,
before I found the entry in the buildfile.

Is it related to the new auto publishing features (which default to an interval
of 5 seconds on a local server) ?

If there is no good explanation I would consider it a major regression :-(

Best regards

Wolfgang
Re: Why the new publish delays ? [message #195905 is a reply to message #194965] Tue, 10 July 2007 04:19 Go to previous messageGo to next message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

Hi !

Nobody to comment on this :-( ? If not I will open a bugzilla request...

Wolfgang

Wolfgang Knauf wrote:
> Hi everybody,
>
> I noticed with some horror that in WTP2.0 RC4 there is a forced
> publishing delay for JBoss and Jonas plugins. For a small sample app, it
> took before about one second to publish, now 10 secs. A look in the
> JBoss antscript "jboss323.xml" revealed this:
>
> <project name="deployextension" default="deploy.j2ee.web" basedir=".">
> ===> <property name="pause.deploy" value="10" />
> <property name="pause.undeploy" value="5" />
> <target name="deploy.j2ee.web">
> <jar destfile="${project.working.dir}/${module.name}.war">
> <zipfileset dir="${module.dir}">
> <include name="**/*.*" />
> <exclude name="**/*.war" />
> </zipfileset>
> </jar>
> <move file="${project.working.dir}/${module.name}.war"
> todir="${server.publish.dir}" />
> ===> <sleep seconds="${pause.deploy}" />
> </target>
> ...
>
> Why this new pause ? To me it looked as a bad regressions at first
> glance, before I found the entry in the buildfile.
>
> Is it related to the new auto publishing features (which default to an
> interval of 5 seconds on a local server) ?
>
> If there is no good explanation I would consider it a major regression :-(
>
> Best regards
>
> Wolfgang
Re: Why the new publish delays ? [message #196260 is a reply to message #195905] Thu, 12 July 2007 04:25 Go to previous message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

https://bugs.eclipse.org/bugs/show_bug.cgi?id=196215

Wolfgang Knauf wrote:
> Hi !
>
> Nobody to comment on this :-( ? If not I will open a bugzilla request...
>
> Wolfgang
>
> Wolfgang Knauf wrote:
>> Hi everybody,
>>
>> I noticed with some horror that in WTP2.0 RC4 there is a forced
>> publishing delay for JBoss and Jonas plugins. For a small sample app,
>> it took before about one second to publish, now 10 secs. A look in the
>> JBoss antscript "jboss323.xml" revealed this:
>>
>> <project name="deployextension" default="deploy.j2ee.web" basedir=".">
>> ===> <property name="pause.deploy" value="10" />
>> <property name="pause.undeploy" value="5" />
>> <target name="deploy.j2ee.web">
>> <jar destfile="${project.working.dir}/${module.name}.war">
>> <zipfileset dir="${module.dir}">
>> <include name="**/*.*" />
>> <exclude name="**/*.war" />
>> </zipfileset>
>> </jar>
>> <move file="${project.working.dir}/${module.name}.war"
>> todir="${server.publish.dir}" />
>> ===> <sleep seconds="${pause.deploy}" />
>> </target>
>> ...
>>
>> Why this new pause ? To me it looked as a bad regressions at first
>> glance, before I found the entry in the buildfile.
>>
>> Is it related to the new auto publishing features (which default to an
>> interval of 5 seconds on a local server) ?
>>
>> If there is no good explanation I would consider it a major regression
>> :-(
>>
>> Best regards
>>
>> Wolfgang
Previous Topic:Announcing Webtools 2.0
Next Topic:Why MySQL DataSource Configuration not working in eclipse wtp 2
Goto Forum:
  


Current Time: Fri Aug 22 08:03:48 EDT 2014

Powered by FUDForum. Page generated in 0.02535 seconds