Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Some Webservice features are missed in my WTP+eclipse
Some Webservice features are missed in my WTP+eclipse [message #194691] Tue, 19 June 2007 10:23 Go to next message
Eclipse User
Originally posted by: reene2008.gmail.com

This is a multi-part message in MIME format.

------=_NextPart_000_0023_01C7B2C0.7B033060
Content-Type: text/plain;
charset="gb2312"
Content-Transfer-Encoding: quoted-printable

Hi,
I followed the tutorial to build a bottom up webservice application.
http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebServi=
ce/bu_tutorial.html

but i have some problem in configuring the wtp.

I opened Window -> Preferences -> Web Services=20
there are only three items=20
Web Services
Axis2 Preferences
Profile Compliance validation
Resource Management

It sould be like this

Web Services
Axis Emitter
Axis2 Preferences
Popup Dialog Selection
Profile Compliance an...
Project Toplopy
Resource Management
....

Under File -> New -> Other... -> Web Services=20
Web Services
Ant Files
Unit Test UDDI
WSDL

web services
Ant files
unit test uddi
web service
web service client =A3=A8It doesn't have this two items.=A3=A9
wsdl

right click the=20

My system configuration is:=20

WindowsXP SP2=20
Eclipse WTP 2.0 RC3
Eclipse 3.3=20
(I downloaded the wtp eclipse emf gef and dtp all from here
=
http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0RC3-200706=
140654/)
Java JDK1.6.0rc-b014=20
Tomcat v6.0=20




------=_NextPart_000_0023_01C7B2C0.7B033060
Content-Type: text/html;
charset="gb2312"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; charset=3Dgb2312">
<META content=3D"MSHTML 6.00.2900.3086" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY>
<DIV><FONT size=3D2>Hi,</FONT></DIV>
<DIV><FONT size=3D2>&nbsp;&nbsp;&nbsp; I followed the tutorial to build =
a bottom=20
up webservice application.</FONT></DIV>
<DIV><A=20
href=3D" http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2=
WebService/bu_tutorial.html"><FONT=20
size=3D2> http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis=
2WebService/bu_tutorial.html</FONT></A></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>&nbsp;&nbsp;&nbsp; but i have some problem in =
configuring the=20
wtp.</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>I&nbsp;opened&nbsp;<STRONG>Window -&gt; Preferences =
-&gt; Web=20
Services</STRONG> </FONT></DIV>
<DIV><FONT size=3D2>there are only <STRONG>three</STRONG> =
items&nbsp;</FONT></DIV>
<DIV><FONT size=3D2>Web Services<BR>&nbsp;Axis2 =
Preferences<BR>&nbsp;Profile=20
Compliance validation<BR>&nbsp;Resource Management</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>It sould be like this</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>Web Services<BR>&nbsp;Axis Emitter<BR>&nbsp;Axis2=20
Preferences<BR>&nbsp;<FONT color=3D#ff0000>Popup Dialog=20
Selection<BR></FONT>&nbsp;Profile Compliance an...<BR>&nbsp;<FONT=20
color=3D#ff0000>Project Toplopy</FONT><BR>&nbsp;Resource =
Management<BR><FONT=20
color=3D#ff0000>&nbsp;....</FONT></FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV>Under&nbsp;File -&gt; New -&gt; Other... -&gt; Web =
Services&nbsp;</DIV>
<DIV><FONT size=3D2>Web Services<BR>&nbsp;Ant Files<BR>&nbsp;Unit Test=20
UDDI<BR>&nbsp;WSDL</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>web services<BR>&nbsp;Ant files<BR>&nbsp;unit test=20
uddi<BR>&nbsp;<FONT color=3D#ff0000>web service<BR>&nbsp;web service =
client =A3=A8It=20
doesn't have this two items.=A3=A9<BR></FONT>&nbsp;wsdl</FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>right click the </FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2>My system configuration is: <BR><BR>WindowsXP SP2 =
<BR>Eclipse=20
WTP 2.0 RC3</FONT></DIV>
<DIV><FONT size=3D2>Eclipse 3.3&nbsp;</FONT></DIV>
<DIV><FONT size=3D2>(I downloaded the wtp eclipse emf gef and dtp all =
from=20
here<BR>&nbsp;</FONT><A=20
href=3D" http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0RC=
3-200706140654/"><FONT=20
size=3D2> http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0R=
C3-200706140654/</FONT></A><FONT=20
size=3D2>)<BR>Java JDK1.6.0rc-b014 <BR>Tomcat v6.0 <BR></FONT></DIV>
<DIV><FONT size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT size=3D2><BR></FONT>&nbsp;</DIV></BODY></HTML>

------=_NextPart_000_0023_01C7B2C0.7B033060--
Re: Some Webservice features are missed in my WTP+eclipse [message #194931 is a reply to message #194691] Mon, 25 June 2007 16:28 Go to previous message
Andrew Mak is currently offline Andrew Mak
Messages: 41
Registered: July 2009
Member
Hi Hao,

Try making sure that your eclipse is using the correct JDK. To do so,
open up the eclipse.ini file and add to the top of the file the following:

-vm
<path to your JDK1.6>\bin\javaw.exe

Also, you may want to download RC4 [1] and give that a try.

Andrew

[1]
http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0RC4-200706212235/

Hao Xu wrote:

> Hi,
> I followed the tutorial to build a bottom up webservice application.
>
http://www.eclipse.org/webtools/community/tutorials/BottomUp Axis2WebService/bu_tutorial.html

> but i have some problem in configuring the wtp.

> I opened Window -> Preferences -> Web Services
> there are only three items
> Web Services
> Axis2 Preferences
> Profile Compliance validation
> Resource Management

> It sould be like this

> Web Services
> Axis Emitter
> Axis2 Preferences
> Popup Dialog Selection
> Profile Compliance an...
> Project Toplopy
> Resource Management
> ....

> Under File -> New -> Other... -> Web Services
> Web Services
> Ant Files
> Unit Test UDDI
> WSDL

> web services
> Ant files
> unit test uddi
> web service
> web service client £šIt doesn't have this two items.£©
> wsdl

> right click the

> My system configuration is:

> WindowsXP SP2
> Eclipse WTP 2.0 RC3
> Eclipse 3.3
> (I downloaded the wtp eclipse emf gef and dtp all from here
>
http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0RC3-200706140654/)
> Java JDK1.6.0rc-b014
> Tomcat v6.0
Previous Topic:Where can I get javax.wsdl?
Next Topic:Content Assist supported for Expression Language in JSP?
Goto Forum:
  


Current Time: Sat Aug 23 01:39:09 EDT 2014

Powered by FUDForum. Page generated in 0.03431 seconds