Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » "The selection is not within a valid module" after sharing Dynamic Web Project
"The selection is not within a valid module" after sharing Dynamic Web Project [message #194289] Mon, 11 June 2007 19:44 Go to next message
Ken Murphy is currently offline Ken Murphy
Messages: 4
Registered: July 2009
Junior Member
Hi,

I've configured a dynamic web project and checked it into CVS. when
selecting "run as > run on server" from either the JSP editor, or from
the package explorer, it successfully executes the selected JSP file on
the local tomcat server. however when others check out the shared
project (or i check it out as a seperate project), any attempt to "run
on server" for the same JSP results in the error:

"The selection is not within a valid module"

It would appear that some crucial piece of project configuration
information is not being shared via CVS.

I'm using:

Eclipse: 3.3.RC2
WTP-5-2.0RC2
Tomcat 6.0.13
JDK 1.5.12

please advise... thanks!

Ken
Re: "The selection is not within a valid module" after sharing Dynamic Web Project [message #194297 is a reply to message #194289] Tue, 12 June 2007 11:26 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1287
Registered: July 2009
Senior Member
This may be related to:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=154833

See Comment #3. Still on my to-do list is to file the enhancement
request. Doing something about this will have to occur post WTP 2.0 due
to the scope of the changes that will likely be required.

The current handling of project modules is such that the project name
must match the deploy-name in the
..settings/org.eclipse.wst.common.component for "everything" to work
correctly. If they don't match, I believe the symptom you are
experiencing is one of the "things" that goes wrong.

Cheers,
Larry

Ken Murphy wrote:
> Hi,
>
> I've configured a dynamic web project and checked it into CVS. when
> selecting "run as > run on server" from either the JSP editor, or from
> the package explorer, it successfully executes the selected JSP file on
> the local tomcat server. however when others check out the shared
> project (or i check it out as a seperate project), any attempt to "run
> on server" for the same JSP results in the error:
>
> "The selection is not within a valid module"
>
> It would appear that some crucial piece of project configuration
> information is not being shared via CVS.
>
> I'm using:
>
> Eclipse: 3.3.RC2
> WTP-5-2.0RC2
> Tomcat 6.0.13
> JDK 1.5.12
>
> please advise... thanks!
>
> Ken
Re: "The selection is not within a valid module" after sharing Dynamic Web Project [message #194336 is a reply to message #194297] Tue, 12 June 2007 15:37 Go to previous message
Ken Murphy is currently offline Ken Murphy
Messages: 4
Registered: July 2009
Junior Member
Larry-

That's it. I was able to work around this problem by checking out the
shared project into a project with the identical name as the original.
I no longer get the error.

Many thanks!
Ken

Larry Isaacs wrote:
> This may be related to:
>
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=154833
>
> See Comment #3. Still on my to-do list is to file the enhancement
> request. Doing something about this will have to occur post WTP 2.0 due
> to the scope of the changes that will likely be required.
>
> The current handling of project modules is such that the project name
> must match the deploy-name in the
> .settings/org.eclipse.wst.common.component for "everything" to work
> correctly. If they don't match, I believe the symptom you are
> experiencing is one of the "things" that goes wrong.
>
> Cheers,
> Larry
>
> Ken Murphy wrote:
>> Hi,
>>
>> I've configured a dynamic web project and checked it into CVS. when
>> selecting "run as > run on server" from either the JSP editor, or from
>> the package explorer, it successfully executes the selected JSP file
>> on the local tomcat server. however when others check out the shared
>> project (or i check it out as a seperate project), any attempt to "run
>> on server" for the same JSP results in the error:
>>
>> "The selection is not within a valid module"
>>
>> It would appear that some crucial piece of project configuration
>> information is not being shared via CVS.
>>
>> I'm using:
>>
>> Eclipse: 3.3.RC2
>> WTP-5-2.0RC2
>> Tomcat 6.0.13
>> JDK 1.5.12
>>
>> please advise... thanks!
>>
>> Ken
Previous Topic:WTP 2.0 RC1 / RC2 doesn't show J2EE perspective or WEB project types
Next Topic:CVS for WTP
Goto Forum:
  


Current Time: Wed Apr 16 06:51:13 EDT 2014

Powered by FUDForum. Page generated in 0.27417 seconds