Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Target Management » Converting all TM "Require Bundle" includes to "Import Package" for UI pieces(TM does not work with Eclipse RAP because it specifically requires bundles instead of importing)
Converting all TM "Require Bundle" includes to "Import Package" for UI pieces [message #1206105] Sun, 24 November 2013 00:02
Jay Billings is currently offline Jay BillingsFriend
Messages: 43
Registered: July 2011
Member
Everyone,

Hello! I hope you are well!

A few weeks ago I was experimenting with Eclipse RAP, hoping to replace my RCP-based project with a RAP build. Unfortunately I found that would not be possible because my project depends on RSE, which in turn explicitly requires UI bundles with the "Require Bundle" statement in the Manifest instead of using "Import Package."

If you're interested, I am willing to go through and make all of the necessary changes to the Manifest files so that Import Package will be used in all of the TM bundles. In fact, I'm about 1/3 of the way through already since pulling master from the git repo earlier.

Is this cool with you? Can I make these changes and submit them back to you?

All the Best,
Jay


Jay Jay Billings
Oak Ridge National Laboratory
Twitter: @jayjaybillings
Previous Topic:Where are the connections stored?
Next Topic:Editor not in dirty state after remote save failed
Goto Forum:
  


Current Time: Thu Nov 27 03:04:41 GMT 2014

Powered by FUDForum. Page generated in 0.07708 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software