Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » SWTBot » Moving to using JUnit 4.5
Moving to using JUnit 4.5 [message #18479] Thu, 29 January 2009 05:27 Go to next message
Ketan Padegaonkar is currently offline Ketan PadegaonkarFriend
Messages: 873
Registered: July 2009
Senior Member
And a new build coming out, I *PROMISE* :)

SWTBot will be moving to JUnit 4.5
(https://bugs.eclipse.org/bugs/show_bug.cgi?id=259787).

Note that this is only for plain SWT based tests, and not recommended
for plugin-tests (https://bugs.eclipse.org/bugs/show_bug.cgi?id=153429)

What does this mean to existing users:
======================================
It means that your existing tests that use JUnit 3.8.x (or 4.x) will
still continue to work.

This means that going ahead you can use the latest and greatest version
of JUnit to write tests that look better than before.

-- Ketan
Re: Moving to using JUnit 4.5 [message #18491 is a reply to message #18479] Thu, 29 January 2009 09:56 Go to previous messageGo to next message
Hans Schwaebli is currently offline Hans SchwaebliFriend
Messages: 70
Registered: July 2009
Member
Thats very good news!
Re: Moving to using JUnit 4.5 [message #18499 is a reply to message #18479] Thu, 29 January 2009 22:41 Go to previous message
Hans Schwaebli is currently offline Hans SchwaebliFriend
Messages: 70
Registered: July 2009
Member
@Ketan
As discussed I created a bug issue for it:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=262980
Previous Topic:SWTBot developers list
Next Topic:Using custom applications for SWTBot testing instead of Eclipse examples
Goto Forum:
  


Current Time: Fri Dec 19 23:40:01 GMT 2014

Powered by FUDForum. Page generated in 0.12942 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software