Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » WTP 2.0 RC1 problems
WTP 2.0 RC1 problems [message #193288] Sun, 27 May 2007 12:17 Go to next message
Ehrann Mehdan is currently offline Ehrann Mehdan
Messages: 10
Registered: July 2009
Junior Member
Hi

I used the Europa update site to get WTP 2.0 RC1 with dependencies,

it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
and static web project types (actually the only WTP feature is the server)

when I look at the current configuration I see this error:

Included feature "WST Web Services UI" version
"2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.

I also tried to download apache geronimo server adapter and after a
"successfull" install and restart got a little red X in the "manage
configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
following error:

Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced by
this feature is missing.


another thing... why is the update manager unstopable,
you press cancel, and it takes few minutes to really stop...

thanks

Michael
Re: WTP 2.0 RC1 problems [message #193312 is a reply to message #193288] Sun, 27 May 2007 15:02 Go to previous messageGo to next message
Ehrann Mehdan is currently offline Ehrann Mehdan
Messages: 10
Registered: July 2009
Junior Member
more information:
in the manage configuration I get this error for WST Web Services Core:


Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
feature is not included at runtime. Runtime includes plug-in version
"1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
"2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".


"Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
news:f3bst1$3um$1@build.eclipse.org...
> Hi
>
> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>
> it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
> and static web project types (actually the only WTP feature is the server)
>
> when I look at the current configuration I see this error:
>
> Included feature "WST Web Services UI" version
> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>
> I also tried to download apache geronimo server adapter and after a
> "successfull" install and restart got a little red X in the "manage
> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
> following error:
>
> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced
> by this feature is missing.
>
>
> another thing... why is the update manager unstopable,
> you press cancel, and it takes few minutes to really stop...
>
> thanks
>
> Michael
>
Re: WTP 2.0 RC1 problems [message #193319 is a reply to message #193312] Sun, 27 May 2007 19:50 Go to previous messageGo to next message
Eclipse User
Originally posted by: jacek.pospychala.pl.ibm.com

Michael,
please make sure that you have following features: JST, WST, EMF, XSD,
SDO, GEF
I've noticed that some of web tools features don't explicitly require
EMF and XSD and then they fail softly in initialization.
If this doesn't help, please start eclipse with following options:
-debug
-consolelog
-clean

so, when started it will open console window and log all problems. You
should look specifically for entries saying that something is missing.
These missing bundles may stop other bundles from being loaded.

Michael Tanner wrote:
> more information:
> in the manage configuration I get this error for WST Web Services Core:
>
>
> Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
> feature is not included at runtime. Runtime includes plug-in version
> "1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
> "2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".
>
>
> "Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
> news:f3bst1$3um$1@build.eclipse.org...
>
>> Hi
>>
>> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>>
>> it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
>> and static web project types (actually the only WTP feature is the server)
>>
>> when I look at the current configuration I see this error:
>>
>> Included feature "WST Web Services UI" version
>> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>>
>> I also tried to download apache geronimo server adapter and after a
>> "successfull" install and restart got a little red X in the "manage
>> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
>> following error:
>>
>> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced
>> by this feature is missing.
>>
>>
>> another thing... why is the update manager unstopable,
>> you press cancel, and it takes few minutes to really stop...
>>
>> thanks
>>
>> Michael
>>
>>
>
>
>
Re: WTP 2.0 RC1 problems [message #193372 is a reply to message #193319] Mon, 28 May 2007 20:11 Go to previous messageGo to next message
Eclipse User
Originally posted by: mikevoxcap.hotmail.com

I had a similar problem. Not sure if this is what you want to do, but I blew
away my eclipse and installed Eclipse 3.3RC1 from here:

http://download.eclipse.org/eclipse/downloads/drops/S-3.3RC1 -200705171700/

Then, I downloaded and unzipped the following from this link:

http://download.eclipse.org/modeling/emf/emf/downloads/drops /2.3.0/S200705230200//emf-sdo-xsd-SDK-2.3.0RC1.zip
http://download.eclipse.org/tools/gef/downloads/drops/S-3.3R C1-200705230926/GEF-SDK-3.3RC1.zip
http://download.eclipse.org/datatools/downloads/1.5/dtp-sdk_ 1.5RC1.zip
http://download.eclipse.org/webtools/downloads/drops/R2.0/S- 2.0RC1-200705250432/wtp-S-2.0RC1-200705250432.zip

After this, I ran Eclipse and did a find updates from my local hard drive to
install the files from above. It allowed me to see J2EE perspective and the
like.

"Jacek Pospychala" <jacek.pospychala@pl.ibm.com> wrote in message
news:f3cndf$v7n$1@build.eclipse.org...
> Michael,
> please make sure that you have following features: JST, WST, EMF, XSD,
> SDO, GEF
> I've noticed that some of web tools features don't explicitly require EMF
> and XSD and then they fail softly in initialization.
> If this doesn't help, please start eclipse with following options:
> -debug
> -consolelog
> -clean
>
> so, when started it will open console window and log all problems. You
> should look specifically for entries saying that something is missing.
> These missing bundles may stop other bundles from being loaded.
>
> Michael Tanner wrote:
>> more information:
>> in the manage configuration I get this error for WST Web Services Core:
>>
>>
>> Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
>> feature is not included at runtime. Runtime includes plug-in version
>> "1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
>> "2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".
>>
>>
>> "Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
>> news:f3bst1$3um$1@build.eclipse.org...
>>
>>> Hi
>>>
>>> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>>>
>>> it doesn't seem to work, the J2EE perspective is gone, as well as
>>> dynamic and static web project types (actually the only WTP feature is
>>> the server)
>>>
>>> when I look at the current configuration I see this error:
>>>
>>> Included feature "WST Web Services UI" version
>>> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>>>
>>> I also tried to download apache geronimo server adapter and after a
>>> "successfull" install and restart got a little red X in the "manage
>>> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
>>> following error:
>>>
>>> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0"
>>> referenced by this feature is missing.
>>>
>>>
>>> another thing... why is the update manager unstopable,
>>> you press cancel, and it takes few minutes to really stop...
>>>
>>> thanks
>>>
>>> Michael
>>>
>>>
>>
>>
>>
Re: WTP 2.0 RC1 problems [message #193420 is a reply to message #193312] Tue, 29 May 2007 08:14 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 696
Registered: July 2009
Senior Member
On Sun, 27 May 2007 11:02:24 -0400, Michael Tanner <ehrann.mehdan@gmail.com> wrote:

> more information:
> in the manage configuration I get this error for WST Web Services Core:
>
>
> Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
> feature is not included at runtime. Runtime includes plug-in version
> "1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
> "2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".
>
>

This particular errro existed in RC0, but does not in RC1 (I haven't seen it).

I wonder if some mirror you are going to is just a bit slow and you are actually getting
the RC0 bits?
Re: WTP 2.0 RC1 problems [message #193451 is a reply to message #193420] Tue, 29 May 2007 11:54 Go to previous messageGo to next message
Ehrann Mehdan is currently offline Ehrann Mehdan
Messages: 10
Registered: July 2009
Junior Member
I used automatically select mirrors, so I can't tell...
I'm trying some of the suggestions above to see if it works...

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.ts2w56psac05ss@dmw2t23.ibm.com...
> On Sun, 27 May 2007 11:02:24 -0400, Michael Tanner
> <ehrann.mehdan@gmail.com> wrote:
>
>> more information:
>> in the manage configuration I get this error for WST Web Services Core:
>>
>>
>> Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
>> feature is not included at runtime. Runtime includes plug-in version
>> "1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
>> "2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".
>>
>>
>
> This particular errro existed in RC0, but does not in RC1 (I haven't seen
> it).
>
> I wonder if some mirror you are going to is just a bit slow and you are
> actually getting
> the RC0 bits?
Re: WTP 2.0 RC1 problems [message #193457 is a reply to message #193420] Tue, 29 May 2007 11:58 Go to previous messageGo to next message
Ehrann Mehdan is currently offline Ehrann Mehdan
Messages: 10
Registered: July 2009
Junior Member
Taiwan Shu-Te university mirror was used by my last update that reproduced
the problem

"David Williams" <david_williams@us.ibm.com> wrote in message
news:op.ts2w56psac05ss@dmw2t23.ibm.com...
> On Sun, 27 May 2007 11:02:24 -0400, Michael Tanner
> <ehrann.mehdan@gmail.com> wrote:
>
>> more information:
>> in the manage configuration I get this error for WST Web Services Core:
>>
>>
>> Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
>> feature is not included at runtime. Runtime includes plug-in version
>> "1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
>> "2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".
>>
>>
>
> This particular errro existed in RC0, but does not in RC1 (I haven't seen
> it).
>
> I wonder if some mirror you are going to is just a bit slow and you are
> actually getting
> the RC0 bits?
Re: WTP 2.0 RC1 problems [message #193502 is a reply to message #193319] Tue, 29 May 2007 14:58 Go to previous messageGo to next message
Ehrann Mehdan is currently offline Ehrann Mehdan
Messages: 10
Registered: July 2009
Junior Member
1) got them all
2) ran with -debug etc, no error messages...

hm...

"Jacek Pospychala" <jacek.pospychala@pl.ibm.com> wrote in message
news:f3cndf$v7n$1@build.eclipse.org...
> Michael,
> please make sure that you have following features: JST, WST, EMF, XSD,
> SDO, GEF
> I've noticed that some of web tools features don't explicitly require EMF
> and XSD and then they fail softly in initialization.
> If this doesn't help, please start eclipse with following options:
> -debug
> -consolelog
> -clean
>
> so, when started it will open console window and log all problems. You
> should look specifically for entries saying that something is missing.
> These missing bundles may stop other bundles from being loaded.
>
> Michael Tanner wrote:
>> more information:
>> in the manage configuration I get this error for WST Web Services Core:
>>
>>
>> Plug-in: "javax.wsdl" version: "1.4.0.v200705152208" referenced by this
>> feature is not included at runtime. Runtime includes plug-in version
>> "1.5.1.v200705160542" supplied by feature "WST Web Services Core" version
>> "2.0.0.v200705150123-7G7PE_PEDx2WYLXkvVg20j1441".
>>
>>
>> "Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
>> news:f3bst1$3um$1@build.eclipse.org...
>>
>>> Hi
>>>
>>> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>>>
>>> it doesn't seem to work, the J2EE perspective is gone, as well as
>>> dynamic and static web project types (actually the only WTP feature is
>>> the server)
>>>
>>> when I look at the current configuration I see this error:
>>>
>>> Included feature "WST Web Services UI" version
>>> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>>>
>>> I also tried to download apache geronimo server adapter and after a
>>> "successfull" install and restart got a little red X in the "manage
>>> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
>>> following error:
>>>
>>> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0"
>>> referenced by this feature is missing.
>>>
>>>
>>> another thing... why is the update manager unstopable,
>>> you press cancel, and it takes few minutes to really stop...
>>>
>>> thanks
>>>
>>> Michael
>>>
>>>
>>
>>
>>
Re: WTP 2.0 RC1 problems [message #193710 is a reply to message #193288] Thu, 31 May 2007 11:27 Go to previous messageGo to next message
Eclipse User
Originally posted by: ranavishal.gmail.com

Same problem... Tried everything but its not working!

"Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
news:f3bst1$3um$1@build.eclipse.org...
> Hi
>
> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>
> it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
> and static web project types (actually the only WTP feature is the server)
>
> when I look at the current configuration I see this error:
>
> Included feature "WST Web Services UI" version
> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>
> I also tried to download apache geronimo server adapter and after a
> "successfull" install and restart got a little red X in the "manage
> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
> following error:
>
> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced
> by this feature is missing.
>
>
> another thing... why is the update manager unstopable,
> you press cancel, and it takes few minutes to really stop...
>
> thanks
>
> Michael
>
Re: WTP 2.0 RC1 problems [message #193962 is a reply to message #193710] Tue, 05 June 2007 08:13 Go to previous messageGo to next message
Ehrann Mehdan is currently offline Ehrann Mehdan
Messages: 10
Registered: July 2009
Junior Member
it seems WTP needs JRE 1.5
didn't see where it is mentioned...

"Vishal Rana" <ranavishal@gmail.com> wrote in message
news:f3mbf4$14c$1@build.eclipse.org...
> Same problem... Tried everything but its not working!
>
> "Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
> news:f3bst1$3um$1@build.eclipse.org...
>> Hi
>>
>> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>>
>> it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
>> and static web project types (actually the only WTP feature is the
>> server)
>>
>> when I look at the current configuration I see this error:
>>
>> Included feature "WST Web Services UI" version
>> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>>
>> I also tried to download apache geronimo server adapter and after a
>> "successfull" install and restart got a little red X in the "manage
>> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
>> following error:
>>
>> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced
>> by this feature is missing.
>>
>>
>> another thing... why is the update manager unstopable,
>> you press cancel, and it takes few minutes to really stop...
>>
>> thanks
>>
>> Michael
>>
>
>
Re: WTP 2.0 RC1 problems [message #193969 is a reply to message #193962] Tue, 05 June 2007 11:02 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------090102060107060401040208
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Michael,

It needs EMF which needs Java 5.0 and we do indicate that in our
requirements for that download:

http://www.eclipse.org/modeling/emf/downloads/?project=

I think it also directly needs Java 5.0, but I'm not sure about that.


Michael Tanner wrote:
> it seems WTP needs JRE 1.5
> didn't see where it is mentioned...
>
> "Vishal Rana" <ranavishal@gmail.com> wrote in message
> news:f3mbf4$14c$1@build.eclipse.org...
>
>> Same problem... Tried everything but its not working!
>>
>> "Michael Tanner" <ehrann.mehdan@gmail.com> wrote in message
>> news:f3bst1$3um$1@build.eclipse.org...
>>
>>> Hi
>>>
>>> I used the Europa update site to get WTP 2.0 RC1 with dependencies,
>>>
>>> it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
>>> and static web project types (actually the only WTP feature is the
>>> server)
>>>
>>> when I look at the current configuration I see this error:
>>>
>>> Included feature "WST Web Services UI" version
>>> "2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.
>>>
>>> I also tried to download apache geronimo server adapter and after a
>>> "successfull" install and restart got a little red X in the "manage
>>> configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
>>> following error:
>>>
>>> Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced
>>> by this feature is missing.
>>>
>>>
>>> another thing... why is the update manager unstopable,
>>> you press cancel, and it takes few minutes to really stop...
>>>
>>> thanks
>>>
>>> Michael
>>>
>>>
>>
>
>
>


--------------090102060107060401040208
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Michael,<br>
<br>
It needs EMF which needs Java 5.0 and we do indicate that in our
requirements for that download:<br>
<blockquote><a
href="http://www.eclipse.org/modeling/emf/downloads/?project=">http://www.eclipse.org/modeling/emf/downloads/?project=</a><br>
</blockquote>
I think it also directly needs Java 5.0, but I'm not sure about that.<br>
<br>
<br>
Michael Tanner wrote:
<blockquote cite="mid:f435uq$dk9$1@build.eclipse.org" type="cite">
<pre wrap="">it seems WTP needs JRE 1.5
didn't see where it is mentioned...

"Vishal Rana" <a class="moz-txt-link-rfc2396E" href="mailto:ranavishal@gmail.com">&lt;ranavishal@gmail.com&gt;</a> wrote in message
<a class="moz-txt-link-freetext" href="news:f3mbf4$14c$1@build.eclipse.org">news:f3mbf4$14c$1@build.eclipse.org</a>...
</pre>
<blockquote type="cite">
<pre wrap="">Same problem... Tried everything but its not working!

"Michael Tanner" <a class="moz-txt-link-rfc2396E" href="mailto:ehrann.mehdan@gmail.com">&lt;ehrann.mehdan@gmail.com&gt;</a> wrote in message
<a class="moz-txt-link-freetext" href="news:f3bst1$3um$1@build.eclipse.org">news:f3bst1$3um$1@build.eclipse.org</a>...
</pre>
<blockquote type="cite">
<pre wrap="">Hi

I used the Europa update site to get WTP 2.0 RC1 with dependencies,

it doesn't seem to work, the J2EE perspective is gone, as well as dynamic
and static web project types (actually the only WTP feature is the
server)

when I look at the current configuration I see this error:

Included feature "WST Web Services UI" version
"2.0.0.v200705141340-791ECAAuhYR8_5enYk64ulz-Csh3" contains problems.

I also tried to download apache geronimo server adapter and after a
"successfull" install and restart got a little red X in the "manage
configuration" screen next to org.apache.geronimo.feature 1.1.0 with the
following error:

Plug-in "org.apache.geronimo.deployment.model" version "1.0.0" referenced
by this feature is missing.


another thing... why is the update manager unstopable,
you press cancel, and it takes few minutes to really stop...

thanks

Michael

</pre>
</blockquote>
<pre wrap="">
</pre>
</blockquote>
<pre wrap=""><!---->

</pre>
</blockquote>
<br>
</body>
</html>

--------------090102060107060401040208--
Re: WTP 2.0 RC1 problems [message #194500 is a reply to message #193420] Wed, 13 June 2007 05:54 Go to previous message
Eclipse User
Originally posted by: wtp.newsgroup.gmail.com

I used the RC1 but it has the same problem. I show the classes in
javax.wsdl.* is similar to org.eclispe.wst.wsdl.*; Is that the plugin name
is change?????
Previous Topic:Using existing Eclipse Plug-ins as part of a WTP application
Next Topic:The selected wizard could not be started
Goto Forum:
  


Current Time: Thu Oct 23 03:50:25 GMT 2014

Powered by FUDForum. Page generated in 0.07099 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software