Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » eclipse Kepler on MacOS X configuration for using autotools(problem when building a project from eclipse with autotools )
eclipse Kepler on MacOS X configuration for using autotools [message #1200541] Thu, 21 November 2013 04:38
Véronique Legrand is currently offline Véronique Legrand
Messages: 5
Registered: July 2013
Junior Member
Hello,

I want to use eclipse as IDE for C/C++ development under a mac OS 10.8.5.
I have downloaded and installed eclipse Kepler for C/C++ developpers (CDT).
To get the gcc compiler, I installed XCode 5.0.2.

I also installed manually the autotools (autoconf 2.69 ; automake 1.14) since I will need to provide portable packaged programs.

The problem is : how to configure eclipse to use autotools. I know that the eclipse version I use is made for it since I can create an « autotools project » and, when I click on « Build », I see in the eclipse console tat eclipse tries to run :

sh -c "autoreconf -i"

But it fails. I get the following trace :

Invoking autoreconf in build directory: /Users/sis/workspace1/test_use_autotools/

sh -c "autoreconf -i"
autoreconf: 'configure.ac' or 'configure.in' is required

Configuration failed with error

What surprises me is that configure.ac and configure.in exist (they actually were created by eclipse when I created the autotools).
I tried to open a Terminal window, go to the /Users/sis/workspace1/test_use_autotools/ directory and enter :
sh -c "autoreconf -i"
and it worked well.

Any idea of what goes wrong ?
Previous Topic:New C++ Class wizard adding C: in the #include statement
Next Topic:C/C++ indexer issue
Goto Forum:
  


Current Time: Thu Jul 31 23:55:26 EDT 2014

Powered by FUDForum. Page generated in 0.01483 seconds