Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Possible Eclipse 3.3.0 (M6) bug with WTP / org.apache.geronimo
Possible Eclipse 3.3.0 (M6) bug with WTP / org.apache.geronimo [message #192289] Wed, 09 May 2007 16:52 Go to next message
Eclipse UserFriend
Originally posted by:

I am trying to develop a Servlet project with Eclipse and Apache Tomcat. I
found a great tutorial on this at: -tutorial/

but it is written for Eclipse 3.2 and I ran into a problem when I tried it
with Eclipse 3.3.0 (M6) bug:

At the Europa Discovery Site, after picking WST and JST, “Select Required”
did not pick any additional features. I thought that was ok and proceeded
without the other features that “Select Required” had added in that
tutorial. In a later step (still following the tutorial), when I got to
the New Server Runtime Wizard, this list appeared:
HTTP Server
[red square icon] JS22 Runtime Library
[red square icon] Preview

This did not match the list from the tutorial, so I clicked on the
“Download Additional Server Adapters” link above that, and downloaded

I was hoping that would add Apache to this list (matching the tutorial)
but it did not. I was then experimenting and returned to Europa Discovery
Site, and when I pick anything (like Java Persistence), an error appears
that indicates the geronimo install is not complete:

org.apache.geronimo.feature (1.2.0) requires plug-in

After a few hours of experimenting with Eclipse, I managed to revert
Eclipse to a configuration before the geronimo.feature installation, and
Eclipse will once again accept other plug-ins.

What is the right way to install WST so that one can develop a Servlet
with Eclipse and Apache Tomcat?

If I was on the right track, please let me know and I will file a bug
report on the geronimo issue.

This issue is holding up a JBuilder->Eclipse transition for our 7-person
web development team (, so any advice would be greatly

Re: Possible Eclipse 3.3.0 (M6) bug with WTP / org.apache.geronimo [message #192303 is a reply to message #192289] Wed, 09 May 2007 17:48 Go to previous message
Eclipse UserFriend
Originally posted by:


It sounds like something didn't get installed correctly from the update
site because the JST part of WTP (necessary for any java-related work
and J2EE servers, such as Tomcat) did not activate.

You may want to try downloading WTP 2.0 M6 along with the necessary
dependencies from the WTP download site.

- Konstantin
Previous Topic:removing a jar from web app libraries
Next Topic:Migrating JBuilder2005 web server project to Eclipse 3.3
Goto Forum:

Current Time: Sun Nov 29 07:14:53 GMT 2015

Powered by FUDForum. Page generated in 0.05706 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software