Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » C/C++ indexer issue
C/C++ indexer issue [message #1196482] Tue, 19 November 2013 12:44 Go to next message
Ernst Maurer is currently offline Ernst MaurerFriend
Messages: 29
Registered: January 2011
Junior Member

This problem was raised a many times,
but I didn't see clear resolution or explanation from the developers.

I mean the issue when mingw C++ builds a project successfully but indexer can't resolve library references in the code and hightlights std/stl includes etc.
First of all, I've set system variable MINGW_HOME.
So, the questions:
1. Seems that currently we do not need to set mingw/bin to system path, because when MINGW_HOME has been set, bin subfolder from mingw is added within eclipse automatically. is it correct?
2. Previous eclipse versions (now I use Kepler) were having this feature:
when I select MINGW toolchain in C++ project settings, it adds "standard" includes into the project pathes automatically . for me it looked like eclipse "knew" mingw folder structure and was adding libs and includes without manual steps. Seems Kepler does not perform this, is it right? or I m doing something wrong and this should still work?
3. not sure that questions 1 and 2 related with indexer issue but possibly. anyway main question to experienced eclipsers, please clarify me with step-by-step instructions how to solve the problem with indexer which can't resolve the symbols, unlike the compiler which does this during the compilation successfully

Thank you!
Re: C/C++ indexer issue [message #1199178 is a reply to message #1196482] Wed, 20 November 2013 18:22 Go to previous messageGo to next message
Ernst Maurer is currently offline Ernst MaurerFriend
Messages: 29
Registered: January 2011
Junior Member

I see that I have to add all paths/symbols manually in the project settings,

so the question is now :
I believe eclipse "knows" toolchain settings (it really was there) and add these settings to C++ project automatically depends of selected toolchain.

why this is currently not so? or I have to click some "magic" checkbox somewhere to make this enabled?
Re: C/C++ indexer issue [message #1201070 is a reply to message #1199178] Thu, 21 November 2013 15:07 Go to previous message
Ernst Maurer is currently offline Ernst MaurerFriend
Messages: 29
Registered: January 2011
Junior Member

seems this is an error in Kepler release Evil or Very Mad

Juno fills up all standard paths on toolchain selecting.
but Kepler does not
(rolling back to Juno...)

is this possible to raise a ticket for the developers to fix this?

[Updated on: Thu, 21 November 2013 15:08]

Report message to a moderator

Previous Topic:eclipse Kepler on MacOS X configuration for using autotools
Next Topic:configure eclipse-cdt to use gcc from custom location
Goto Forum:
  


Current Time: Sat Nov 22 10:35:17 GMT 2014

Powered by FUDForum. Page generated in 0.02559 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software