Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » EJB 3 project
EJB 3 project [message #191276] Wed, 11 April 2007 05:29 Go to next message
Eclipse UserFriend
Originally posted by: bhaban.gmail.com

Hi all,

I create ejb 3 project in wtp 2.0M6 platform. it creates successfully but
without ejb-jar.xml file. can anyone please suggest me whether this is a
bug or any others problem.

thanking you

regards
bhaban
Web Services on Tomcat [message #191284 is a reply to message #191276] Wed, 11 April 2007 08:08 Go to previous messageGo to next message
Mirza Hadzic is currently offline Mirza HadzicFriend
Messages: 19
Registered: July 2009
Junior Member
Hi,

I have two problems running WST web services on Tomcat 5.

1. If I create new web service (bottom-up), using Tomcat 5, Axis, file
service-config.wsdd looks OK. But then I change some service methods,
and use wizard to re-create web service again. Everything looks OK
except WEB-INF/service-config.wsdd which contains old web service
methods and parameters, it was not updated. (I created Bug 181791) This
is problem when project is exported to WAR archive. At other machines it
doesn't work because service-config.wsdd does not match java classes.

2. When I export web services project to WAR archive and other person
deploys it on his Tomcat, it creates directory on his computer (!)
<PATH_TO_ECLIPSE_WORKSPACE> \.metadata\.plugins\org.eclipse.wst.server.core\tmp0\webapps \ <NAME_OF_PROJECT>\WEB-INF\attachments

<PATH_TO_ECLIPSE_WORKSPACE> and <NAME_OF_PROJECT> are variables specific
to my project and eclipse settings.

Why?

Thanks,

Mirza
Re: EJB 3 project [message #191311 is a reply to message #191276] Wed, 11 April 2007 12:41 Go to previous message
Eclipse UserFriend
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

It's a feature.

I created an enhancement request to re-enable the creation of the deployment
descriptors for JavaEE5 projects:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=181894

You can vote for it if you miss the deployment descriptors ;-).

Best regards

Wolfgang

bhaban wrote:
> Hi all,
> I create ejb 3 project in wtp 2.0M6 platform. it creates successfully
> but without ejb-jar.xml file. can anyone please suggest me whether this
> is a bug or any others problem.
> thanking you
>
> regards
> bhaban
>
Previous Topic:JBoss 4 / EJB3 serverdefinition for JavaEE5 /WTP 2.0
Next Topic:Eclipse crashes!
Goto Forum:
  


Current Time: Sun Dec 21 21:43:45 GMT 2014

Powered by FUDForum. Page generated in 0.01767 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software