Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » J2EE Application Tutorial Question
J2EE Application Tutorial Question [message #189461] Fri, 09 March 2007 00:23 Go to next message
Eclipse User
Originally posted by: sorton.wmode.com

Has anyone gone through the tutorial "Creating a JEE Application using WTP
2.0 M5 driver."
( http://www.eclipse.org/webtools/jst/components/j2ee/scenario s/jee5_application_creation_tutorial.html).

I'm trying to go through it, but don't understand step 2:

"choose a JEE5 server (* At the time of writing we were unable to find any
servers that would work with the new facets as they require server adapter
plugins in WTP to work with the new facets, we chose an internal test
server)as the Target Runtime".

What internal test server? Is this internal to his system or Eclipse?
I'm thinking it must be his system. So, does this mean that the tutorial
is unusable?

Any help appreciated.

Thanks!
Re: J2EE Application Tutorial Question [message #189469 is a reply to message #189461] Fri, 09 March 2007 07:54 Go to previous messageGo to next message
Jacek Laskowski is currently offline Jacek Laskowski
Messages: 8
Registered: July 2009
Junior Member
Shelli wrote:

> "choose a JEE5 server (* At the time of writing we were unable to find
> any servers that would work with the new facets as they require server
> adapter plugins in WTP to work with the new facets, we chose an internal
> test server)as the Target Runtime".

I haven't done it, but it's certainly no longer true that there's no
server adapter plugin to work with the new facet. See Apache Geronimo v2
plugin for such a adapter -
http://people.apache.org/dist/geronimo/eclipse/unstable. Chances are the
example works fine with Geronimo.

Jacek

--
Jacek Laskowski
http://www.jaceklaskowski.pl
Re: J2EE Application Tutorial Question [message #189477 is a reply to message #189461] Fri, 09 March 2007 16:34 Go to previous message
Eclipse User
Originally posted by: wknauf_NO_._INSIDE_hg-online.de

JBoss 4.0.5 with EJB3 should work with this plugin:
http://www.informatik.fh-wiesbaden.de/~knauf/public/

But there are some bugs in M5, currently Web 2.5 facet is broken:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=174769

Best regards

Wolfgang

Shelli wrote:

> "choose a JEE5 server (* At the time of writing we were unable to find
> any servers that would work with the new facets as they require server
> adapter plugins in WTP to work with the new facets, we chose an internal
> test server)as the Target Runtime".
>
Previous Topic:Submit does not work with Textarea
Next Topic:WTP, Axis and Tomcat
Goto Forum:
  


Current Time: Sun Oct 26 04:42:02 GMT 2014

Powered by FUDForum. Page generated in 0.02091 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software