Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Publishing StackOverflowError
Publishing StackOverflowError [message #188747] Tue, 27 February 2007 23:20
shelley  is currently offline shelley
Messages: 11
Registered: July 2009
Junior Member
A StackOverflowError has been occurring when trying to use WebSphere 6.0 with
the latest WTP/Eclipse milestones. When trying to publish, clean, open the
launch config, or perform any action on my WebSphere server, an error occurs: An
internal error occurred during: "Publishing to IBM WebSphere 6...". The .log
shows a StackOverflowError caused by the Resolver class
resolvePropertiesFromCache() method.

!ENTRY org.eclipse.core.jobs 4 2 2007-02-27 17:09:11.523
!MESSAGE An internal error occurred during: "Publishing to IBM WebSphere 6...".
!STACK 0
java.lang.StackOverflowError
at java.util.HashMap.get(HashMap.java:320)
at
org.eclipse.core.internal.variables.StringVariableManager.ge tDynamicVariable(StringVariableManager.java:414)
at
org.eclipse.jst.server.generic.internal.xml.Resolver.resolve Property(Resolver.java:122)
at
org.eclipse.jst.server.generic.internal.xml.Resolver.resolve PropertiesFromCache(Resolver.java:90)
at
org.eclipse.jst.server.generic.internal.xml.Resolver.resolve PropertiesFromCache(Resolver.java:91)
at
org.eclipse.jst.server.generic.internal.xml.Resolver.resolve PropertiesFromCache(Resolver.java:91)
at
org.eclipse.jst.server.generic.internal.xml.Resolver.resolve PropertiesFromCache(Resolver.java:91)
at
org.eclipse.jst.server.generic.internal.xml.Resolver.resolve PropertiesFromCache(Resolver.java:91)
. . .
. . .

I just installed the latest stable Eclipse 3.3 milestone (Version: 3.3.0, Build
id: I20070222-0951) and the latest Web Tools Platform 2.0 milestone (M5).
Publishing is working correctly with other servers (I've tested JBoss 4 and
Tomcat 5.5).

Also, WebSphere 6.0 publishes and starts correctly in the latest Eclipse 3.2
release with the latest WTP 1.5.3 release, with identical server configuration
as used with Eclipse3.3/WTP2.

Any ideas would be greatly appreciated.
Previous Topic:Error while creating ejb project from a EJB Jar file
Next Topic:Is there a HTML\XML Editor control?
Goto Forum:
  


Current Time: Tue Sep 02 21:34:25 GMT 2014

Powered by FUDForum. Page generated in 0.01991 seconds