Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » problem with Java EE5 / J2EE perspecitve in wtp2.0M5
problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #188598] Mon, 26 February 2007 08:35 Go to next message
Eclipse User
Originally posted by: niklas.antoncic.volvo.com

I have downloaded and successfully installed all required components of
the WTP 2.0M5 build and I cannot find any Java EE related perspectives.
When I open it up it looks like a clean Eclipse 3.3 installation. Is this
a bug or a feature. Do I need to configure anything?

Im running on XP and have installed the followinig files packages:
dtp-sdk_1.5M5.zip
eclipse-SDK-3.3M5eh-win32.zip
emf-sdo-xsd-SDK-2.3.0M5.zip
GEF-SDK-3.3M5.zip
wtp-jpa-S-2.0M5-200702230758.zip
wtp-jsf-S-2.0M5-200702230758.zip
wtp-sdk-S-2.0M5-200702230758.zip

Any suggestions?

best regards / Niklas Antoncic
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #188607 is a reply to message #188598] Mon, 26 February 2007 08:44 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

Niklas,

You've run with -clean after unzipping these things? You've looked at
the Error Log view (<workspace>/.metadata/.log) for clues? And you're
running Eclipse with a 5.0 or higher JVM?


Niklas Antoncic wrote:
> I have downloaded and successfully installed all required components
> of the WTP 2.0M5 build and I cannot find any Java EE related
> perspectives. When I open it up it looks like a clean Eclipse 3.3
> installation. Is this a bug or a feature. Do I need to configure
> anything?
>
> Im running on XP and have installed the followinig files packages:
> dtp-sdk_1.5M5.zip
> eclipse-SDK-3.3M5eh-win32.zip
> emf-sdo-xsd-SDK-2.3.0M5.zip
> GEF-SDK-3.3M5.zip
> wtp-jpa-S-2.0M5-200702230758.zip
> wtp-jsf-S-2.0M5-200702230758.zip
> wtp-sdk-S-2.0M5-200702230758.zip
>
> Any suggestions?
>
> best regards / Niklas Antoncic
>
>
>
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #188629 is a reply to message #188607] Mon, 26 February 2007 11:24 Go to previous messageGo to next message
Eclipse User
Originally posted by: niklas.antoncic.volvo.com

Thanks for the quick response.

I tried your suggestions but still no success.

I found this in the log:

!SESSION 2007-02-26 17:15:59.013
-----------------------------------------------
eclipse.buildId=I20070222-0951
java.version=1.4.2_03
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=sv_SE
Framework arguments: -launcher C:\wtp2\eclipse\eclipse.exe -name Eclipse
-startup
C:\wtp2\eclipse\plugins\org.eclipse.equinox.launcher_1.0.0.v 20070208a.jar
Command-line arguments: -os win32 -ws win32 -arch x86 -launcher
C:\wtp2\eclipse\eclipse.exe -name Eclipse -startup
C:\wtp2\eclipse\plugins\org.eclipse.equinox.launcher_1.0.0.v 20070208a.jar
-clean

!ENTRY org.eclipse.ui 4 4 2007-02-26 17:16:08.720
!MESSAGE Invalid preference page path: SQL Results View Options


It looks as if it is running with java 1.4. I have configured in
preferences to run with java 1.5 and the java -version returns java 1.5 so
i dont know where it gets 1.4 from.

what is wrong?
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #188635 is a reply to message #188629] Mon, 26 February 2007 12:06 Go to previous messageGo to next message
Eclipse User
Originally posted by: kosta.bea.com

You can control which java vm is used to launch Eclipse by specifying a
"-vm <location>" switch in the eclipse.ini file.

- Konstantin
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #188978 is a reply to message #188629] Fri, 02 March 2007 04:48 Go to previous messageGo to next message
Mike Henry is currently offline Mike Henry
Messages: 3
Registered: July 2009
Junior Member
I was having similar problems, probably due to an installation of Java
1.4 that was being picked up. I uninstalled the 1.4 jdk and things
worked from then on.

YMMV,

-Mike
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #189154 is a reply to message #188978] Mon, 05 March 2007 18:34 Go to previous messageGo to next message
Eclipse User
Originally posted by: kmg.NOSPAM_merseymail.com

I've had similar problems to yourself and Niklas.

However I've checked everything out: I'm running with 1.4.2, ran eclipse
-clean, checked the logs and I still don't get a J2EE perspective. I've
probably missed something. If anyone can advise on what the pre-reqs are
for a J2EE persepctive, I'd be obliged! My version of Eclipse is 3.3.0
Thanks

Mike Henry wrote:
> I was having similar problems, probably due to an installation of Java
> 1.4 that was being picked up. I uninstalled the 1.4 jdk and things
> worked from then on.
>
> YMMV,
>
> -Mike

> I was having similar problems, probably due to an installation of Java
> 1.4 that was being picked up. I uninstalled the 1.4 jdk and things
> worked from then on.
>
> YMMV,
>
> -Mike
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #189160 is a reply to message #189154] Mon, 05 March 2007 20:39 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2229
Registered: July 2009
Senior Member
kmg wrote:
> I've had similar problems to yourself and Niklas.
>
> However I've checked everything out: I'm running with 1.4.2, ran eclipse
> -clean, checked the logs and I still don't get a J2EE perspective. I've
> probably missed something. If anyone can advise on what the pre-reqs are
> for a J2EE persepctive, I'd be obliged! My version of Eclipse is 3.3.0
> Thanks

WTP 2.0 requires JRE 1.5 or newer to run.

--
Nitin Dahyabhai
Structured Source Editor


---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: problem with Java EE5 / J2EE perspecitve in wtp2.0M5 [message #189233 is a reply to message #189160] Tue, 06 March 2007 13:03 Go to previous message
Eclipse User
Originally posted by: kmg.NOSPAM_merseymail.com

Nitin Dahyabhai wrote:
> kmg wrote:
>> I've had similar problems to yourself and Niklas.
>>
>> However I've checked everything out: I'm running with 1.4.2, ran
>> eclipse -clean, checked the logs and I still don't get a J2EE
>> perspective. I've probably missed something. If anyone can advise on
>> what the pre-reqs are for a J2EE persepctive, I'd be obliged! My
>> version of Eclipse is 3.3.0
>> Thanks
>
> WTP 2.0 requires JRE 1.5 or newer to run.
>
> --
> Nitin Dahyabhai
> Structured Source Editor
Apologies Nitin, I should have read the subject line more closely. I was
using the all-in-one WTP package :
wtp-all-in-one-sdk-R-1.5.3-win32.zip(md5)

I cant find any prereqs for that particular version. (Doesnt mean there
arent any - I just cant see them)
Previous Topic:The XSD Editor
Next Topic:error removing share from project
Goto Forum:
  


Current Time: Tue Jul 22 11:33:14 EDT 2014

Powered by FUDForum. Page generated in 0.04039 seconds