Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » NOEXEC error libpiAgent.so for tomcat 5.0 in AIX 5.1 64bit.
NOEXEC error libpiAgent.so for tomcat 5.0 in AIX 5.1 64bit. [message #17837] Fri, 06 May 2005 19:27 Go to next message
Eclipse User
Originally posted by: rayli.hotmail.com

I try to start up the tomcat 5.0 with the following setting:
------------------------------------------------------------
export JPDA_TRANSPORT=dt_socket
export JPDA_ADDRESS=8000
export LIBPATH=/home/qasys2/raserver/lib
export JAVA_OPTS='-Xms100M -Xmx200M -XrunpiAgent:server=enabled'
------------------------------------------------------------
but it failed in error "Can't load "libpiAgent.so", because load ENOEXEC on
shared library(s) /home/qasys2/raserver/lib/libpiAgent.so
xmloadJVMHelperLib piAgent server=enabled, failed
Could not create the Java virtual machine."
Does anyone have this problem? is it something to do with 64bit JRE

my java version:
java version "1.4.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
Classic VM (build 1.4.1, J2RE 1.4.1 IBM AIX 5L for PowerPC (64 bit JVM)
build caix64141-20030703a (JIT enabled: jitc))
Re: NOEXEC error libpiAgent.so for tomcat 5.0 in AIX 5.1 64bit. [message #17850 is a reply to message #17837] Fri, 06 May 2005 19:51 Go to previous messageGo to next message
Eclipse User
Originally posted by: rayli.hotmail.com

When I use Java 1.3 32bit, it works.

java version "1.3.1"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1)
Classic VM (build 1.3.1, J2RE 1.3.1 IBM AIX build ca131-20021107 (JIT
enabled: jitc))

"raymond" <rayli@hotmail.com> wrote in message
news:d5ggs8$n8c$1@news.eclipse.org...
> I try to start up the tomcat 5.0 with the following setting:
> ------------------------------------------------------------
> export JPDA_TRANSPORT=dt_socket
> export JPDA_ADDRESS=8000
> export LIBPATH=/home/qasys2/raserver/lib
> export JAVA_OPTS='-Xms100M -Xmx200M -XrunpiAgent:server=enabled'
> ------------------------------------------------------------
> but it failed in error "Can't load "libpiAgent.so", because load ENOEXEC
on
> shared library(s) /home/qasys2/raserver/lib/libpiAgent.so
> xmloadJVMHelperLib piAgent server=enabled, failed
> Could not create the Java virtual machine."
> Does anyone have this problem? is it something to do with 64bit JRE
>
> my java version:
> java version "1.4.1"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
> Classic VM (build 1.4.1, J2RE 1.4.1 IBM AIX 5L for PowerPC (64 bit JVM)
> build caix64141-20030703a (JIT enabled: jitc))
>
>
Re: NOEXEC error libpiAgent.so for tomcat 5.0 in AIX 5.1 64bit. [message #17904 is a reply to message #17850] Wed, 11 May 2005 18:39 Go to previous message
Samson Wai is currently offline Samson Wai
Messages: 46
Registered: July 2009
Member
Hi Ray,

I am guessing you are using the same machine to run both 32-bit and 64-bit
JVM, right?

The piAgent is not ported to 64-bit AIX yet. The one available from
Eclipse.org is a 32-bit compiled version. A 64-bit version is in plan for
future release.

Samson



"raymond" <rayli@hotmail.com> wrote in message
news:d5gi8m$osl$1@news.eclipse.org...
> When I use Java 1.3 32bit, it works.
>
> java version "1.3.1"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.1)
> Classic VM (build 1.3.1, J2RE 1.3.1 IBM AIX build ca131-20021107 (JIT
> enabled: jitc))
>
> "raymond" <rayli@hotmail.com> wrote in message
> news:d5ggs8$n8c$1@news.eclipse.org...
> > I try to start up the tomcat 5.0 with the following setting:
> > ------------------------------------------------------------
> > export JPDA_TRANSPORT=dt_socket
> > export JPDA_ADDRESS=8000
> > export LIBPATH=/home/qasys2/raserver/lib
> > export JAVA_OPTS='-Xms100M -Xmx200M -XrunpiAgent:server=enabled'
> > ------------------------------------------------------------
> > but it failed in error "Can't load "libpiAgent.so", because load
ENOEXEC
> on
> > shared library(s) /home/qasys2/raserver/lib/libpiAgent.so
> > xmloadJVMHelperLib piAgent server=enabled, failed
> > Could not create the Java virtual machine."
> > Does anyone have this problem? is it something to do with 64bit JRE
> >
> > my java version:
> > java version "1.4.1"
> > Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1)
> > Classic VM (build 1.4.1, J2RE 1.4.1 IBM AIX 5L for PowerPC (64 bit JVM)
> > build caix64141-20030703a (JIT enabled: jitc))
> >
> >
>
>
Previous Topic:How to generate reuseable code?
Next Topic:is it possible to profile j2ee applications
Goto Forum:
  


Current Time: Thu Sep 18 12:00:59 GMT 2014

Powered by FUDForum. Page generated in 0.03005 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software