Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Webdoclet + Websphere 6 - How to make Descriptors?
Webdoclet + Websphere 6 - How to make Descriptors? [message #187501] Fri, 02 February 2007 16:21
Kai Hackemesser is currently offline Kai HackemesserFriend
Messages: 6
Registered: July 2009
Junior Member
Hi there,

I'm currently creating a J2EE project with eclipse. I've installed WST
plugin 1.5.2. I've activated xdoclet/webdoclet with task
"DeploymentDescriptor" and "Websphere". Of course I've set up the
xdoclet binary path (for version 1.2.3) and it is working correctly. I
can run xdoclet in my web project and it is creating/updating the
web.xml using my different xml fragments. But it doesn't create
Websphere specific descriptors as I would expect. If I run xdoclet (via
right-click on the project and then "Run XDoclet") I have following ant
result:

Buildfile:
C:\workspace\.metadata\.plugins\org.eclipse.jst.j2ee.ejb.ann otations.xdoclet\tempAnt.xml
init:
webdoclet:
[webdoclet] 02.02.2007 13:09:32 xdoclet.XDocletMain start
[webdoclet] INFO: Running <deploymentdescriptor/>
[webdoclet] Generating web.xml.
BUILD SUCCESSFUL
Total time: 3 seconds

I've taken a look at that tempAnt.xml and it looks like this (removed
not importand parts vor readability:
....
<taskdef name="webdoclet"
classname="xdoclet.modules.web.WebDocletTask">
<classpath refid="project.class.path"/>
</taskdef>
<webdoclet
destdir="${web.module.webinf}"
mergedir="${xdoclet.merge.dir}"
excludedtags="@version,@author,@todo"
addedtags="@wtp generated"
force="${xdoclet.force}"
verbose="true" >
<!-- SERVLETS START -->
<fileset dir="${web.module.src}" defaultexcludes="yes">

</fileset>
<!-- SERVLETS END -->
<deploymentdescriptor useIds="true"
servletspec="${servlet.spec.version}" displayname="${web}"
validatexml="false" mergedir="${web.module.webinf}" />
</webdoclet>


the deploymentdescriptor tag is there, but I would expect an
webspherewebxml tag, too. Am I wrong, or is this missing, and when it is
missing, then why?

Kind regards,
Kai
Previous Topic:XSD Editor collapsing/expanding
Next Topic:Force WSDL Editor on .wsdl entensions
Goto Forum:
  


Current Time: Thu Nov 27 10:00:46 GMT 2014

Powered by FUDForum. Page generated in 0.01548 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software