Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » Empty output model with ATL+ANT and metamodel from xsd file
Empty output model with ATL+ANT and metamodel from xsd file [message #1181218] Mon, 11 November 2013 13:01 Go to next message
Victor Pavon is currently offline Victor Pavon
Messages: 49
Registered: April 2012
Location: Spain
Member
Hello,

I have define a MMT with ATL. This have as input a model conforms a metamodel generated from a xsd file using EMF. If I run the transformation with Eclipse configuration it work properly. But when I try execute the transformation with an ANT task the output model is empty. I tried severals configurations:

1. Load de metamodel using its uri. The execution returns an empty model:
<atl.loadModel modelHandler="EMF" name="mmStrutsConfig" metamodel="MOF" uri="platform:/org.eclipse.modisco.struts.config/resource/StrutsConfig.xsd" />


2. Load de metamodel using its path. The execution returns with an error ([atl.loadModel] org.eclipse.m2m.atl.core.ATLCoreException: Error loading file:/C:\Users\victor\Dropbox\ECLIPSE\workspaceMoDisco10\repositorios\org.eclipse.modisco.struts.config\org.eclipse.modisco.struts.config\model\StrutsConfig13.ecore: null):
<atl.loadModel modelHandler="EMF" name="mmStrutsConfig" metamodel="MOF" path="../../org.eclipse.modisco.struts.config/org.eclipse.modisco.struts.config/model/StrutsConfig13.ecore" />


Best regards,
Víctor Pavón.


Víctor Pavón,
Research at Quercus Software Engineering Group
University of Extremadura, Spain.
Re: Empty output model with ATL+ANT and metamodel from xsd file [message #1182452 is a reply to message #1181218] Tue, 12 November 2013 07:36 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 607
Registered: July 2009
Senior Member
Hello,

Concerning your first case, have you checked that the metamodel is actually well-loaded (for instance by re-serializing it as an Ecore file using "atl.saveModel")?

Best regards,


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: Empty output model with ATL+ANT and metamodel from xsd file [message #1182510 is a reply to message #1182452] Tue, 12 November 2013 08:30 Go to previous messageGo to next message
Victor Pavon is currently offline Victor Pavon
Messages: 49
Registered: April 2012
Location: Spain
Member
Hello Hugo,

I check if the metamodel is well-loaded, re-serializing it, and it is well-loaded.

Best regards,
Víctor.


Víctor Pavón,
Research at Quercus Software Engineering Group
University of Extremadura, Spain.

[Updated on: Tue, 12 November 2013 08:30]

Report message to a moderator

Re: Empty output model with ATL+ANT and metamodel from xsd file [message #1182531 is a reply to message #1182510] Tue, 12 November 2013 08:49 Go to previous messageGo to next message
Hugo Bruneliere is currently offline Hugo Bruneliere
Messages: 607
Registered: July 2009
Senior Member
So it is not coming from the metamodel loading.
If you're sure that the transformation itself is OK, thus it can only come from your input model that may be not properly loaded: could you check this too?

Best regards,


------------------------------------------
Hugo Bruneliere - R&D Engineer
AtlanMod research team (Inria, EMN & LINA)
Ecole des Mines de Nantes
Nantes - France
------------------------------------------
Re: Empty output model with ATL+ANT and metamodel from xsd file [message #1182544 is a reply to message #1182531] Tue, 12 November 2013 09:00 Go to previous message
Victor Pavon is currently offline Victor Pavon
Messages: 49
Registered: April 2012
Location: Spain
Member
The problem was on the model load. I load a wrong file conforms to another metamodel that I use in the transformation. Thank you very much for your help Smile

Best regards,
Víctor Pavón.


Víctor Pavón,
Research at Quercus Software Engineering Group
University of Extremadura, Spain.
Previous Topic:[EMFTVM] How to transform stereotypes values?
Next Topic:[Theoretical?] Transformation problems not solvable with declarative languages?
Goto Forum:
  


Current Time: Fri Oct 24 13:38:38 GMT 2014

Powered by FUDForum. Page generated in 0.01684 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software