Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Deployement problem again
Deployement problem again [message #186160] Sun, 14 January 2007 07:22
Eclipse User
Originally posted by: stephane_cauvi.yahoo.fr

Hi,

I am running eclipse 3.2, wtp 1.5.3 on Win XP.
I have a very simple Struts project with a .properties resources file
containing messages that worked fine on JBoss 4.0.5.
After I added messages to the resources file I got "Missing message.."
exception. I checked the published ear file and the resources file in it
was an former one.
If I publish the project, the published resources files is an older
version, If I publish it once more the right
version is published. If I publish the project again, the older version
is published again, abd so an. So once the project has been published
properly I have to publish it two times to deploy it again.
I tried to clean, the project, remove it from the server, delete the tmp
directory
under
\workspaces\default\.metadata\.plugins\org.eclipse.wst.serve r.core\ etc,
etc, nothing worked. I dont't know where
wtp stores an older version of the file. I wasted some hours with this
silly problem. I could write some
ant task to clean files if wtp is unable to do it but I don't know what to
clean since there are no documentation available
about the strange things that wtp does with project's files when
publishing.

Does someone have an idea?
Previous Topic:Axis2 Integration
Next Topic:problem with css, javascript and images
Goto Forum:
  


Current Time: Wed Aug 20 12:42:39 EDT 2014

Powered by FUDForum. Page generated in 0.08686 seconds