Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Voicetools » openvxml 3.0 - app deployment on voxeo
openvxml 3.0 - app deployment on voxeo [message #17486] Thu, 04 October 2007 14:59 Go to next message
Eclipse User
Originally posted by: tliese.gmx.de

Hi,

i very much appreciate your new version of openVXML 3.0, although 2.1 was
already fine. v3.0 contains some tempting features, e.g. voice recording
to variables and playback from PlayPrompt variables, which I really need
to build my app.
So far, so good, but happiness is not to stay...
When I tried to deploy a (very) simple app under v3.0 that deploys and
runs fine under v2.1, I cannot run this simple app on my current
tomcat/apache config (latest xampp, JAVA 1.6). The web application service
runs proven OK, because I use it successfully with v2.1 too).
I am using the Voxeo Prophecy 8.0 voice platform together with the latest
xampp tomcat/apache package.
On v2.1 the URL http://192.168.2.108:8080/dbdemo/openVXML worked fine
within the Voxeo management console (Call Routing).
My question now is:
What is the correct syntax to use in the Voxeo Prophecy management console
for the URL when using OpenVXML 3.0 instead of v2.1 ?


Thank you very much for responding in advance.
regards
Thomas
Re: openvxml 3.0 - app deployment on voxeo [message #17489 is a reply to message #17486] Mon, 29 October 2007 08:01 Go to previous messageGo to next message
Eclipse User
Originally posted by: openvxml.kitsonkelly.com

Guys,

I am having a similiar problem with OpenVXML 3.0. I try to export the
application, and the only choice to me that seems to make any sense is
"Other|Web Application". The problem is the exported .WAR doesn't include
any openVXML directory, only an eclipse directory. I have tried on two
different machines to no avail.

I tried the canidate release of VTP 2.0 and the WAR exported fine, with
the OpenVXML directory, but I then got the following errors:

javax.servlet.ServletException: Error instantiating servlet class
org.eclipse.vtp.framework.kernel.http.HTTPConnector
java.lang.NoClassDefFoundError:
org/apache/commons/fileupload/FileItemFactory

This was using a war generated in the binary all-in-one release canidate
of VTP 2.0.

Regards,
Kitson P. Kelly
Re: openvxml 3.0 - app deployment on voxeo [message #18652 is a reply to message #17486] Wed, 12 December 2007 18:52 Go to previous messageGo to next message
Eclipse User
Originally posted by: eabello.surnet.cl

Hi,
The 3.0 have a change:

http://192.168.2.108:8080/dbdemo/name_proyect_eclipse



http://www.openmethods.com/activate.php?id=52
download manual GettingStart.pdf page 33

(I speak spanish )
Thomas escribió:
> Hi,
>
> i very much appreciate your new version of openVXML 3.0, although 2.1
> was already fine. v3.0 contains some tempting features, e.g. voice
> recording to variables and playback from PlayPrompt variables, which I
> really need to build my app.
> So far, so good, but happiness is not to stay...
> When I tried to deploy a (very) simple app under v3.0 that deploys and
> runs fine under v2.1, I cannot run this simple app on my current
> tomcat/apache config (latest xampp, JAVA 1.6). The web application
> service runs proven OK, because I use it successfully with v2.1 too).
> I am using the Voxeo Prophecy 8.0 voice platform together with the
> latest xampp tomcat/apache package.
> On v2.1 the URL http://192.168.2.108:8080/dbdemo/openVXML worked fine
> within the Voxeo management console (Call Routing). My question now is:
> What is the correct syntax to use in the Voxeo Prophecy management
> console for the URL when using OpenVXML 3.0 instead of v2.1 ?
>
>
> Thank you very much for responding in advance.
> regards
> Thomas
>
>
Re: openvxml 3.0 - app deployment on voxeo [message #18674 is a reply to message #17489] Wed, 12 December 2007 18:54 Go to previous message
Eclipse User
Originally posted by: eabello.surnet.cl

download and copy to WEB-INF\lib , commons-fileupload-1.2.jar
Kitson Kelly escribió:
> Guys,
>
> I am having a similiar problem with OpenVXML 3.0. I try to export the
> application, and the only choice to me that seems to make any sense is
> "Other|Web Application". The problem is the exported .WAR doesn't
> include any openVXML directory, only an eclipse directory. I have tried
> on two different machines to no avail.
>
> I tried the canidate release of VTP 2.0 and the WAR exported fine, with
> the OpenVXML directory, but I then got the following errors:
>
> javax.servlet.ServletException: Error instantiating servlet class
> org.eclipse.vtp.framework.kernel.http.HTTPConnector
> java.lang.NoClassDefFoundError:
> org/apache/commons/fileupload/FileItemFactory
>
> This was using a war generated in the binary all-in-one release canidate
> of VTP 2.0.
>
> Regards,
> Kitson P. Kelly
>
Re: openvxml 3.0 - app deployment on voxeo [message #576516 is a reply to message #17486] Mon, 29 October 2007 08:01 Go to previous message
Eclipse User
Originally posted by: openvxml.kitsonkelly.com

Guys,

I am having a similiar problem with OpenVXML 3.0. I try to export the
application, and the only choice to me that seems to make any sense is
"Other|Web Application". The problem is the exported .WAR doesn't include
any openVXML directory, only an eclipse directory. I have tried on two
different machines to no avail.

I tried the canidate release of VTP 2.0 and the WAR exported fine, with
the OpenVXML directory, but I then got the following errors:

javax.servlet.ServletException: Error instantiating servlet class
org.eclipse.vtp.framework.kernel.http.HTTPConnector
java.lang.NoClassDefFoundError:
org/apache/commons/fileupload/FileItemFactory

This was using a war generated in the binary all-in-one release canidate
of VTP 2.0.

Regards,
Kitson P. Kelly
Re: openvxml 3.0 - app deployment on voxeo [message #576683 is a reply to message #17486] Wed, 12 December 2007 18:52 Go to previous message
Eugenio Abello is currently offline Eugenio Abello
Messages: 9
Registered: July 2009
Junior Member
Hi,
The 3.0 have a change:

http://192.168.2.108:8080/dbdemo/name_proyect_eclipse



http://www.openmethods.com/activate.php?id=52
download manual GettingStart.pdf page 33

(I speak spanish )
Thomas escribió:
> Hi,
>
> i very much appreciate your new version of openVXML 3.0, although 2.1
> was already fine. v3.0 contains some tempting features, e.g. voice
> recording to variables and playback from PlayPrompt variables, which I
> really need to build my app.
> So far, so good, but happiness is not to stay...
> When I tried to deploy a (very) simple app under v3.0 that deploys and
> runs fine under v2.1, I cannot run this simple app on my current
> tomcat/apache config (latest xampp, JAVA 1.6). The web application
> service runs proven OK, because I use it successfully with v2.1 too).
> I am using the Voxeo Prophecy 8.0 voice platform together with the
> latest xampp tomcat/apache package.
> On v2.1 the URL http://192.168.2.108:8080/dbdemo/openVXML worked fine
> within the Voxeo management console (Call Routing). My question now is:
> What is the correct syntax to use in the Voxeo Prophecy management
> console for the URL when using OpenVXML 3.0 instead of v2.1 ?
>
>
> Thank you very much for responding in advance.
> regards
> Thomas
>
>
Re: openvxml 3.0 - app deployment on voxeo [message #576730 is a reply to message #17489] Wed, 12 December 2007 18:54 Go to previous message
Eugenio Abello is currently offline Eugenio Abello
Messages: 9
Registered: July 2009
Junior Member
download and copy to WEB-INF\lib , commons-fileupload-1.2.jar
Kitson Kelly escribió:
> Guys,
>
> I am having a similiar problem with OpenVXML 3.0. I try to export the
> application, and the only choice to me that seems to make any sense is
> "Other|Web Application". The problem is the exported .WAR doesn't
> include any openVXML directory, only an eclipse directory. I have tried
> on two different machines to no avail.
>
> I tried the canidate release of VTP 2.0 and the WAR exported fine, with
> the OpenVXML directory, but I then got the following errors:
>
> javax.servlet.ServletException: Error instantiating servlet class
> org.eclipse.vtp.framework.kernel.http.HTTPConnector
> java.lang.NoClassDefFoundError:
> org/apache/commons/fileupload/FileItemFactory
>
> This was using a war generated in the binary all-in-one release canidate
> of VTP 2.0.
>
> Regards,
> Kitson P. Kelly
>
Previous Topic:Tomcat Application Deployment
Next Topic:Tomcat Application Deployment
Goto Forum:
  


Current Time: Thu Oct 30 23:48:42 GMT 2014

Powered by FUDForum. Page generated in 0.02877 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software